aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-09 16:20:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-09 16:20:43 +0000
commite53393acc8df9347399975f4d653784587d731ce (patch)
treecacd21a6ad22719dcea587a4c0b6d7c9de39efb0
parentd95fd234c58e34d5236e430b9b52582856e508cc (diff)
downloadports-e53393acc8df9347399975f4d653784587d731ce.tar.gz
ports-e53393acc8df9347399975f4d653784587d731ce.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/py-petsc4py/Makefile28
-rw-r--r--math/py-petsc4py/distinfo5
-rw-r--r--math/py-petsc4py/pkg-descr4
-rw-r--r--math/py-petsc4py/pkg-plist1
5 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index c7b60d39e9a4..a6304979fcfe 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -692,6 +692,7 @@
SUBDIR += py-pandas
SUBDIR += py-pandas-datareader
SUBDIR += py-patsy
+ SUBDIR += py-petsc4py
SUBDIR += py-piranha
SUBDIR += py-plastex
SUBDIR += py-probstat
diff --git a/math/py-petsc4py/Makefile b/math/py-petsc4py/Makefile
new file mode 100644
index 000000000000..1989333134e2
--- /dev/null
+++ b/math/py-petsc4py/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= petsc4py
+DISTVERSION= 3.9.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+PATCH_SITES= https://bitbucket.org/petsc/petsc4py/commits/
+PATCHFILES= ab877906425e/raw:-p1
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= PETSc for Python
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+BUILD_DEPENDS= ${PYNUMPY}
+LIB_DEPENDS= libmpich.so:net/mpich2 \
+ libpetsc.so:science/PETSc
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+MAKE_ENV= PETSC_DIR=${LOCALBASE}
+
+.include <bsd.port.mk>
diff --git a/math/py-petsc4py/distinfo b/math/py-petsc4py/distinfo
new file mode 100644
index 000000000000..cd4feb9981a6
--- /dev/null
+++ b/math/py-petsc4py/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1528554205
+SHA256 (petsc4py-3.9.1.tar.gz) = 0ccee912216f100d9b08637e036df00e043a530303ff8afd7c3ac7c454681fb9
+SIZE (petsc4py-3.9.1.tar.gz) = 1651526
+SHA256 (ab877906425e/raw) = ef07a5622ce5a55dc555455aff5c59a6395bdef74b11aa576d58642db7c4ccfc
+SIZE (ab877906425e/raw) = 2706
diff --git a/math/py-petsc4py/pkg-descr b/math/py-petsc4py/pkg-descr
new file mode 100644
index 000000000000..5228b0d9bffa
--- /dev/null
+++ b/math/py-petsc4py/pkg-descr
@@ -0,0 +1,4 @@
+Python bindings for PETSc, the Portable, Extensible Toolkit for Scientific
+Computation.
+
+WWW: https://bitbucket.org/petsc/petsc4py
diff --git a/math/py-petsc4py/pkg-plist b/math/py-petsc4py/pkg-plist
new file mode 100644
index 000000000000..e74aeb3ae4ac
--- /dev/null
+++ b/math/py-petsc4py/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/petsc4py/lib/PETSc.so