aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-02-03 20:03:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-02-03 20:03:23 +0000
commite7d3acd16dcb1da43b9feeaf5058773f7fa309c8 (patch)
treed7779e167692068666e4b14ab76634978e480dd9
parentc41770c4873fe1489ce4652a20a41155d9877a7b (diff)
downloadports-e7d3acd16dcb1da43b9feeaf5058773f7fa309c8.tar.gz
ports-e7d3acd16dcb1da43b9feeaf5058773f7fa309c8.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/avldrums-lv2/Makefile35
-rw-r--r--audio/avldrums-lv2/distinfo5
-rw-r--r--audio/avldrums-lv2/pkg-descr18
4 files changed, 59 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index c621e35abc79..2280a053f1ac 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -50,6 +50,7 @@
SUBDIR += autocd
SUBDIR += autotalent
SUBDIR += autozen
+ SUBDIR += avldrums-lv2
SUBDIR += aylet
SUBDIR += baresip
SUBDIR += baudline
diff --git a/audio/avldrums-lv2/Makefile b/audio/avldrums-lv2/Makefile
new file mode 100644
index 000000000000..b60b5b5e5cd9
--- /dev/null
+++ b/audio/avldrums-lv2/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= avldrums
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.2
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Dedicated AVLDrumkits LV2 Plugin
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+
+USES= gmake pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= x42
+GH_PROJECT= ${PORTNAME}.lv2
+GH_TUPLE= x42:robtk:05eb4b8:robtk/robtk
+USE_GL= gl glu
+USE_GNOME= glib20 pango cairo
+USE_XORG= x11
+
+MAKE_ENV= avldrums_VERSION=${PORTVERSION}
+
+PLIST_FILES= lib/lv2/avldrums.lv2/Black_Pearl_4_LV2.sf2 \
+ lib/lv2/avldrums.lv2/Red_Zeppelin_4_LV2.sf2 \
+ lib/lv2/avldrums.lv2/avldrums.so \
+ lib/lv2/avldrums.lv2/avldrums.ttl \
+ lib/lv2/avldrums.lv2/avldrumsUI_gl.so \
+ lib/lv2/avldrums.lv2/manifest.ttl
+
+.include <bsd.port.mk>
diff --git a/audio/avldrums-lv2/distinfo b/audio/avldrums-lv2/distinfo
new file mode 100644
index 000000000000..942a81b4c96d
--- /dev/null
+++ b/audio/avldrums-lv2/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1517653395
+SHA256 (x42-avldrums.lv2-v0.2.2_GH0.tar.gz) = 7e29a502bcede0ef7bd03214cae145653bff53be812c46cd2e6e13d91bbda4d5
+SIZE (x42-avldrums.lv2-v0.2.2_GH0.tar.gz) = 35319971
+SHA256 (x42-robtk-05eb4b8_GH0.tar.gz) = 44170fee5cd0f4d05d1d0723d981da05713966a8de3f0634fb446bc740c0efc7
+SIZE (x42-robtk-05eb4b8_GH0.tar.gz) = 114046
diff --git a/audio/avldrums-lv2/pkg-descr b/audio/avldrums-lv2/pkg-descr
new file mode 100644
index 000000000000..e6f9329f117a
--- /dev/null
+++ b/audio/avldrums-lv2/pkg-descr
@@ -0,0 +1,18 @@
+avldrums.lv2 is a drum sample player plugin written by Robin Gareus
+dedicated to Glen MacArthur's AVLdrums. This self-contained plugin
+provides a convenient way to rapidly sequence and mix midi-drums.
+
+The AVLdrums comes as two separate drumkits: Black Pearl and Red Zeppelin.
+There are 5 velocity layers for each of the 28 kits pieces or drum-zones
+for both kits.
+
+The main benefits compared to loading the soundfont into a generic sample
+player are:
+* built-in MIDNAM: The plugin informs the host about note-names
+* Semantic grouping of ports: fan-out separate mics to individual tracks
+* Compatible stereo/multi-out variant: Allows to in-place replace the stereo
+ version with multi-out. Start with stereo when sequencing and when moving
+ to the mixing stage use separate outputs to process or customize level and
+ pan of individual drums.
+
+WWW: http://x42-plugins.com/x42/x42-avldrums