aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2009-03-30 14:18:26 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2009-03-30 14:18:26 +0000
commite8cfa8fc26b36614b4dea942cb24bd069c3727df (patch)
treede0dde4249b27de9fe54b9b67e95c60400dd13e7
parente39ca1479413ea8fea3d39155f8cc711eccdd4dd (diff)
Mark MAKE_JOBS_SAFE
Notes
Notes: svn path=/head/; revision=231308
-rw-r--r--audio/festalon/Makefile1
-rw-r--r--audio/ocp/Makefile1
-rw-r--r--audio/openspc/Makefile1
-rw-r--r--audio/playgsf/Makefile1
-rw-r--r--audio/xmms-openspc/Makefile2
-rw-r--r--ftp/weex/Makefile1
-rw-r--r--security/idea/Makefile2
7 files changed, 9 insertions, 0 deletions
diff --git a/audio/festalon/Makefile b/audio/festalon/Makefile
index ef41e413c3b4..1c3e484acaf0 100644
--- a/audio/festalon/Makefile
+++ b/audio/festalon/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/audio/ocp/Makefile b/audio/ocp/Makefile
index 0f29c94a81fa..829fb743bbd0 100644
--- a/audio/ocp/Makefile
+++ b/audio/ocp/Makefile
@@ -26,6 +26,7 @@ ONLY_FOR_ARCHS= i386
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/audio/openspc/Makefile b/audio/openspc/Makefile
index 4478f16e8ad3..48ddd8d5f19e 100644
--- a/audio/openspc/Makefile
+++ b/audio/openspc/Makefile
@@ -19,6 +19,7 @@ COMMENT= A command line player for .spc and .zst files
ONLY_FOR_ARCHS= i386 # contains x86 asm code
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
+MAKE_JOBS_SAFE= yes
PORTDOCS= README
PLIST_FILES= bin/OpenSPClite include/OpenSPC.h lib/libOpenSPC.so \
diff --git a/audio/playgsf/Makefile b/audio/playgsf/Makefile
index c634ed694a8c..08b6b85c28ba 100644
--- a/audio/playgsf/Makefile
+++ b/audio/playgsf/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao
USE_GMAKE= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
# disable optimization flags to avoid a possible bug in gcc
# (gcc tries to allocate memory in an endless loop)
diff --git a/audio/xmms-openspc/Makefile b/audio/xmms-openspc/Makefile
index 121ef034a4f4..3a3cf5686e6f 100644
--- a/audio/xmms-openspc/Makefile
+++ b/audio/xmms-openspc/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm \
xmms:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+MAKE_JOBS_SAFE= yes
+
PLIST_FILES= lib/xmms/Input/openspc.la \
lib/xmms/Input/openspc.so
diff --git a/ftp/weex/Makefile b/ftp/weex/Makefile
index f7135f12a5d9..8ba45647bab1 100644
--- a/ftp/weex/Makefile
+++ b/ftp/weex/Makefile
@@ -17,6 +17,7 @@ COMMENT= A non-interactive FTP client
GNU_CONFIGURE= yes
MANCOMPRESSED= no
+MAKE_JOBS_SAFE= yes
PORTDOCS= ChangeLog README
MAN1= weex.1
diff --git a/security/idea/Makefile b/security/idea/Makefile
index a3d8f40d036f..1697be9613a6 100644
--- a/security/idea/Makefile
+++ b/security/idea/Makefile
@@ -17,6 +17,8 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A command line idea encryption and decryption utility
+MAKE_JOBS_SAFE= yes
+
RESTRICTED= "Crypto; IDEA is a patented algorithm that requires proper licensing"
WRKSRC= ${WRKDIR}/${PORTNAME}