aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2011-09-08 08:44:17 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2011-09-08 08:44:17 +0000
commitecaa793d7a08ba5fa83bbb85c12cb606030b5d04 (patch)
tree7b26c34ea6188d601b47d6de99d79f49038a6d52
parent0384302b961ef0f201c0829f3ad04f1123fc86ed (diff)
downloadports-ecaa793d7a08ba5fa83bbb85c12cb606030b5d04.tar.gz
ports-ecaa793d7a08ba5fa83bbb85c12cb606030b5d04.zip
Notes
-rw-r--r--www/node/Makefile2
-rw-r--r--www/node/files/extra-patch-src__node_buffer.cc11
-rw-r--r--www/node04/Makefile2
-rw-r--r--www/node04/files/extra-patch-src__node_buffer.cc11
4 files changed, 24 insertions, 2 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index f326ad717576..7388baa4fc0a 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -36,7 +36,7 @@ PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
LIB_DEPENDS+= v8.1:${PORTSDIR}/lang/v8
CONFIGURE_ARGS+= --shared-v8-includes=${LOCALBASE}/include --shared-v8-libpath=${LOCALBASE}/lib
PLIST_SUB+= SHAREDV8="@comment "
-BROKEN= does not build with new v8
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-src__node_buffer.cc
.else
PLIST_SUB+= SHAREDV8=""
.endif
diff --git a/www/node/files/extra-patch-src__node_buffer.cc b/www/node/files/extra-patch-src__node_buffer.cc
new file mode 100644
index 000000000000..265219e77cfd
--- /dev/null
+++ b/www/node/files/extra-patch-src__node_buffer.cc
@@ -0,0 +1,11 @@
+--- src/node_buffer.cc.orig 2011-09-08 16:40:06.000000000 +0800
++++ src/node_buffer.cc 2011-09-08 16:40:18.000000000 +0800
+@@ -478,7 +478,7 @@ Handle<Value> Buffer::Utf8Write(const Ar
+
+ if (written > 0 && p[written-1] == '\0' && char_written == length) {
+ uint16_t last_char;
+- s->Write(&last_char, length - 1, 1, String::NO_HINTS);
++ s->Write(&last_char, length - 1, 1, String::NO_OPTIONS);
+ if (last_char != 0 || written > s->Utf8Length()) {
+ written--;
+ }
diff --git a/www/node04/Makefile b/www/node04/Makefile
index f326ad717576..7388baa4fc0a 100644
--- a/www/node04/Makefile
+++ b/www/node04/Makefile
@@ -36,7 +36,7 @@ PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
LIB_DEPENDS+= v8.1:${PORTSDIR}/lang/v8
CONFIGURE_ARGS+= --shared-v8-includes=${LOCALBASE}/include --shared-v8-libpath=${LOCALBASE}/lib
PLIST_SUB+= SHAREDV8="@comment "
-BROKEN= does not build with new v8
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-src__node_buffer.cc
.else
PLIST_SUB+= SHAREDV8=""
.endif
diff --git a/www/node04/files/extra-patch-src__node_buffer.cc b/www/node04/files/extra-patch-src__node_buffer.cc
new file mode 100644
index 000000000000..265219e77cfd
--- /dev/null
+++ b/www/node04/files/extra-patch-src__node_buffer.cc
@@ -0,0 +1,11 @@
+--- src/node_buffer.cc.orig 2011-09-08 16:40:06.000000000 +0800
++++ src/node_buffer.cc 2011-09-08 16:40:18.000000000 +0800
+@@ -478,7 +478,7 @@ Handle<Value> Buffer::Utf8Write(const Ar
+
+ if (written > 0 && p[written-1] == '\0' && char_written == length) {
+ uint16_t last_char;
+- s->Write(&last_char, length - 1, 1, String::NO_HINTS);
++ s->Write(&last_char, length - 1, 1, String::NO_OPTIONS);
+ if (last_char != 0 || written > s->Utf8Length()) {
+ written--;
+ }