aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-02-19 09:41:37 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-02-19 09:41:37 +0000
commited8a43a60369711cd9c81802905ad1914b465698 (patch)
tree01aaefde4704269898c86de2120b36f595490c5c
parent7360591d8a820953e04b52f59f6863dad7b44914 (diff)
downloadports-ed8a43a60369711cd9c81802905ad1914b465698.tar.gz
ports-ed8a43a60369711cd9c81802905ad1914b465698.zip
Notes
-rw-r--r--devel/libchipcard-kde/Makefile8
-rw-r--r--mail/dcc-dccd/Makefile8
-rw-r--r--net-im/gyach/Makefile8
-rw-r--r--net/gnome-mud/Makefile8
-rw-r--r--net/gyach/Makefile8
5 files changed, 35 insertions, 5 deletions
diff --git a/devel/libchipcard-kde/Makefile b/devel/libchipcard-kde/Makefile
index fbd689c4ba94..99811b5ec0ca 100644
--- a/devel/libchipcard-kde/Makefile
+++ b/devel/libchipcard-kde/Makefile
@@ -26,7 +26,13 @@ CONFIGURE_ARGS+= --with-distri=freebsd --with-kde3-prefix=${LOCALBASE}\
USE_KDELIBS_VER= 3
USE_REINPLACE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Links against conflicting thread libraries"
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's,libkdeui.so.4,libkdeui.so,' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/dcc-dccd/Makefile b/mail/dcc-dccd/Makefile
index b7290958cbcd..114b9acc5808 100644
--- a/mail/dcc-dccd/Makefile
+++ b/mail/dcc-dccd/Makefile
@@ -32,10 +32,16 @@ CONFIGURE_ARGS+= --disable-dccm --disable-dccifd
PLIST_SUB+= WITH_SENDMAIL="@comment"
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Links against conflicting thread libraries"
+.endif
+
post-patch:
${FIND} ${WRKSRC} -type f -exec \
${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' {} \;
${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g' \
${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-im/gyach/Makefile b/net-im/gyach/Makefile
index b5afadd7028d..5fb7c463443b 100644
--- a/net-im/gyach/Makefile
+++ b/net-im/gyach/Makefile
@@ -18,4 +18,10 @@ GNU_CONFIGURE= yes
USE_GNOME= gtk20
USE_X_PREFIX= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Links against conflicting thread libraries"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/gnome-mud/Makefile b/net/gnome-mud/Makefile
index 2ed3dbb59c57..e5d236e32809 100644
--- a/net/gnome-mud/Makefile
+++ b/net/gnome-mud/Makefile
@@ -27,8 +27,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN6= gnome-mud.6
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Links against conflicting thread libraries"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|prefix)/games|prefix)/bin|g' ${WRKSRC}/src/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/gyach/Makefile b/net/gyach/Makefile
index b5afadd7028d..5fb7c463443b 100644
--- a/net/gyach/Makefile
+++ b/net/gyach/Makefile
@@ -18,4 +18,10 @@ GNU_CONFIGURE= yes
USE_GNOME= gtk20
USE_X_PREFIX= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Links against conflicting thread libraries"
+.endif
+
+.include <bsd.port.post.mk>