aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-04-06 16:06:50 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-04-06 16:06:50 +0000
commiteda86fe37b4417cdb157c06fd51eb9c82bb078d5 (patch)
tree4abacea73136b0345330081911e80e12289b7606
parente29db935a8ce5c98e4642a8d443668bd3f6bb9e9 (diff)
downloadports-eda86fe37b4417cdb157c06fd51eb9c82bb078d5.tar.gz
ports-eda86fe37b4417cdb157c06fd51eb9c82bb078d5.zip
Notes
-rw-r--r--databases/Makefile1
-rw-r--r--databases/linux-f10-sqlite3/Makefile31
-rw-r--r--databases/linux-f10-sqlite3/distinfo.i3866
-rw-r--r--databases/linux-f8-sqlite3/Makefile31
-rw-r--r--databases/linux-f8-sqlite3/distinfo.i3866
5 files changed, 75 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index d3e39aee3361..bc509532c61e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -144,6 +144,7 @@
SUBDIR += libsdb
SUBDIR += libudbc
SUBDIR += libzdb
+ SUBDIR += linux-f8-sqlite3
SUBDIR += linux-oracle-instantclient-basic
SUBDIR += linux-oracle-instantclient-sdk
SUBDIR += linux-oracle-instantclient-sqlplus
diff --git a/databases/linux-f10-sqlite3/Makefile b/databases/linux-f10-sqlite3/Makefile
new file mode 100644
index 000000000000..9905270c1355
--- /dev/null
+++ b/databases/linux-f10-sqlite3/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: databases/linux-f8-sqlite3
+# Date created: 2009-04-05
+# Whom: bsam
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlite3
+PORTVERSION= 3.4.2
+CATEGORIES= databases linux
+PKGNAMEPREFIX= linux-f8-
+DISTNAME= sqlite-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= The library that implements an embeddable SQL database engine (Linux Fedora 8)
+
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 8
+RPMVERSION= 3.fc8
+BRANDELF_FILES= usr/bin/sqlite3
+USE_LDCONFIG= yes
+
+PLIST_FILES= usr/bin/sqlite3 usr/lib/libsqlite3.so.0 \
+ usr/lib/libsqlite3.so.0.8.6
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= README
+MANPREFIX= ${PREFIX}/usr/share
+MAN1= sqlite3.1
+DESCR= ${.CURDIR}/../${PORTNAME}3/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/databases/linux-f10-sqlite3/distinfo.i386 b/databases/linux-f10-sqlite3/distinfo.i386
new file mode 100644
index 000000000000..9f7b5e228a6c
--- /dev/null
+++ b/databases/linux-f10-sqlite3/distinfo.i386
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.i386.rpm) = 3e39af1d538377c75983f9edc43e069c
+SHA256 (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.i386.rpm) = 2aa5ae5f7d644c00d403eec6884828a307cb3d8f3623ca086d3b1b7fae2c4f95
+SIZE (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.i386.rpm) = 242426
+MD5 (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.src.rpm) = 7e609c5e9f3d448f42d21ad05fdc4d33
+SHA256 (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.src.rpm) = 674d6844b6f3e75b0d9ec8115adf397d937e2a752fae9d466000989cbc9f10ce
+SIZE (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.src.rpm) = 2383301
diff --git a/databases/linux-f8-sqlite3/Makefile b/databases/linux-f8-sqlite3/Makefile
new file mode 100644
index 000000000000..9905270c1355
--- /dev/null
+++ b/databases/linux-f8-sqlite3/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: databases/linux-f8-sqlite3
+# Date created: 2009-04-05
+# Whom: bsam
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlite3
+PORTVERSION= 3.4.2
+CATEGORIES= databases linux
+PKGNAMEPREFIX= linux-f8-
+DISTNAME= sqlite-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= The library that implements an embeddable SQL database engine (Linux Fedora 8)
+
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 8
+RPMVERSION= 3.fc8
+BRANDELF_FILES= usr/bin/sqlite3
+USE_LDCONFIG= yes
+
+PLIST_FILES= usr/bin/sqlite3 usr/lib/libsqlite3.so.0 \
+ usr/lib/libsqlite3.so.0.8.6
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= README
+MANPREFIX= ${PREFIX}/usr/share
+MAN1= sqlite3.1
+DESCR= ${.CURDIR}/../${PORTNAME}3/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/databases/linux-f8-sqlite3/distinfo.i386 b/databases/linux-f8-sqlite3/distinfo.i386
new file mode 100644
index 000000000000..9f7b5e228a6c
--- /dev/null
+++ b/databases/linux-f8-sqlite3/distinfo.i386
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.i386.rpm) = 3e39af1d538377c75983f9edc43e069c
+SHA256 (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.i386.rpm) = 2aa5ae5f7d644c00d403eec6884828a307cb3d8f3623ca086d3b1b7fae2c4f95
+SIZE (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.i386.rpm) = 242426
+MD5 (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.src.rpm) = 7e609c5e9f3d448f42d21ad05fdc4d33
+SHA256 (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.src.rpm) = 674d6844b6f3e75b0d9ec8115adf397d937e2a752fae9d466000989cbc9f10ce
+SIZE (rpm/i386/fedora/8/sqlite-3.4.2-3.fc8.src.rpm) = 2383301