aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2001-01-21 14:22:06 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2001-01-21 14:22:06 +0000
commitf75b7fce5c8c26b6bab36c4ee125cb86cc8f7fc3 (patch)
treee14cd33515ceae87cb3aaeb5a3ba208438ebdc5d
parent13506ce5fe57f0454b2efa142fb19a4da28ba546 (diff)
downloadports-f75b7fce5c8c26b6bab36c4ee125cb86cc8f7fc3.tar.gz
ports-f75b7fce5c8c26b6bab36c4ee125cb86cc8f7fc3.zip
Notes
-rw-r--r--www/mod_php3/Makefile8
-rw-r--r--www/mod_php4/Makefile8
-rw-r--r--www/mod_php5/Makefile8
3 files changed, 3 insertions, 21 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index ad2bd50f6f48..0d6eefc08358 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -27,10 +27,8 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
PHP_DISTDIR= distributions
-APXS= ${PREFIX}/sbin/apxs
-
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-apxs=${APXS} \
+CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
--enable-versioning \
--with-system-regex \
--with-config-file-path=${PREFIX}/etc \
@@ -42,11 +40,7 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
MKDIR="${MKDIR}"
-.if exists(${APXS})
-AP_LIBEXEC!= ${APXS} -q LIBEXEC
-.else
AP_LIBEXEC= ${PREFIX}/libexec/apache
-.endif
PHPDOCDIR= ${PREFIX}/share/doc/php3
PLIST_SUB= PHPDOCDIR=${PHPDOCDIR:S/^${PREFIX}\///} \
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index f897c201e3d0..e1a490b4158f 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -26,10 +26,8 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
PHP_DISTDIR= distributions
-APXS= ${PREFIX}/sbin/apxs
-
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-apxs=${APXS} \
+CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
--enable-versioning \
--with-system-regex \
--with-config-file-path=${PREFIX}/etc \
@@ -44,11 +42,7 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
MKDIR="${MKDIR}" \
CAT="${CAT}"
-.if exists(${APXS})
-AP_LIBEXEC!= ${APXS} -q LIBEXEC
-.else
AP_LIBEXEC= ${PREFIX}/libexec/apache
-.endif
PHPDOCDIR= ${PREFIX}/share/doc/php
PLIST_SUB= PHPDOCDIR=${PHPDOCDIR:S/^${PREFIX}\///} \
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index f897c201e3d0..e1a490b4158f 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -26,10 +26,8 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
PHP_DISTDIR= distributions
-APXS= ${PREFIX}/sbin/apxs
-
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-apxs=${APXS} \
+CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
--enable-versioning \
--with-system-regex \
--with-config-file-path=${PREFIX}/etc \
@@ -44,11 +42,7 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
MKDIR="${MKDIR}" \
CAT="${CAT}"
-.if exists(${APXS})
-AP_LIBEXEC!= ${APXS} -q LIBEXEC
-.else
AP_LIBEXEC= ${PREFIX}/libexec/apache
-.endif
PHPDOCDIR= ${PREFIX}/share/doc/php
PLIST_SUB= PHPDOCDIR=${PHPDOCDIR:S/^${PREFIX}\///} \