aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2008-10-03 20:14:37 +0000
committerRenato Botelho <garga@FreeBSD.org>2008-10-03 20:14:37 +0000
commitf872963e61b2fda5a7acb614cb3bbfae7ac1a69f (patch)
tree13d8c2e1a7eba142e9c31d5eaee57c0b4c1df8e9
parentacbdc288f6e9711da705b9442b702f30cfd90527 (diff)
downloadports-f872963e61b2fda5a7acb614cb3bbfae7ac1a69f.tar.gz
ports-f872963e61b2fda5a7acb614cb3bbfae7ac1a69f.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ipaddr/Makefile25
-rw-r--r--devel/py-ipaddr/distinfo3
-rw-r--r--devel/py-ipaddr/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e155c35a1468..8b122f8c8836 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2131,6 +2131,7 @@
SUBDIR += py-ice
SUBDIR += py-icu
SUBDIR += py-instant
+ SUBDIR += py-ipaddr
SUBDIR += py-istring
SUBDIR += py-jcc
SUBDIR += py-json-py
diff --git a/devel/py-ipaddr/Makefile b/devel/py-ipaddr/Makefile
new file mode 100644
index 000000000000..7ad04b855a9d
--- /dev/null
+++ b/devel/py-ipaddr/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-ipaddr
+# Date created: 2008-10-03
+# Whom: Murilo Opsfelder <mopsfelder@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipaddr
+PORTVERSION= 1.0.0
+CATEGORIES= devel python
+MASTER_SITES= http://ipaddr-py.googlecode.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= mopsfelder@gmail.com
+COMMENT= A Google open source IPv4/IPv6 manipulation library in Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= ipaddr
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/ipaddr.py \
+ %%PYTHON_SITELIBDIR%%/ipaddr.pyc \
+ %%PYTHON_SITELIBDIR%%/ipaddr.pyo
+
+.include <bsd.port.mk>
diff --git a/devel/py-ipaddr/distinfo b/devel/py-ipaddr/distinfo
new file mode 100644
index 000000000000..4e30491ea361
--- /dev/null
+++ b/devel/py-ipaddr/distinfo
@@ -0,0 +1,3 @@
+MD5 (ipaddr-1.0.0.tar.gz) = 2eec9c501a9d836fb366b89b8808eaf5
+SHA256 (ipaddr-1.0.0.tar.gz) = 80d76b51bc3a488c730342b17e13e41617fc4883fe18fbbb8687164eb3a903eb
+SIZE (ipaddr-1.0.0.tar.gz) = 15138
diff --git a/devel/py-ipaddr/pkg-descr b/devel/py-ipaddr/pkg-descr
new file mode 100644
index 000000000000..fb6fce38d59c
--- /dev/null
+++ b/devel/py-ipaddr/pkg-descr
@@ -0,0 +1,7 @@
+A Google open source IPv4/IPv6 manipulation library in Python.
+This library is used to create/poke/manipulate IPv4 and
+IPv6 addresses and prefixes.
+Development mailing list:
+http://groups.google.com/group/ipaddr-py-dev
+
+WWW: http://code.google.com/p/ipaddr-py/