aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2009-08-03 20:35:54 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2009-08-03 20:35:54 +0000
commitfab4a382daaf6aba6423c7253621f38e628dc5ca (patch)
treed6d866c6baae39254358af2e308e1be3888ad797
parentf5a8651ec9c4bff94a6d3bcc40fa5a349f1c7bcc (diff)
downloadports-fab4a382daaf6aba6423c7253621f38e628dc5ca.tar.gz
ports-fab4a382daaf6aba6423c7253621f38e628dc5ca.zip
Notes
-rw-r--r--net-im/amsn/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/net-im/amsn/Makefile b/net-im/amsn/Makefile
index 53aa3a9ed7be..710ab574a7fa 100644
--- a/net-im/amsn/Makefile
+++ b/net-im/amsn/Makefile
@@ -22,14 +22,26 @@ RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
${LOCALBASE}/lib/tls/tls.tcl:${PORTSDIR}/devel/tcltls \
dtplite:${PORTSDIR}/devel/tcllib
-GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
--with-tk=${LOCALBASE}/lib/tk8.4
-CONFIGURE_ENV= TK_INC_SPEC=${LOCALBASE}/include/tk8.4/generic
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ TK_INC_SPEC=${LOCALBASE}/include/tk8.4/generic
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB+= NLS=""
+.endif
post-patch:
@${FIND} ${WRKSRC} -name '*.c' -or -name '*.h' | ${XARGS} ${REINPLACE_CMD} -e 's| ||'