aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-04-20 15:25:31 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-04-20 15:25:31 +0000
commitfbced9f2f1f6d00553fbad7a0908c9a456060842 (patch)
tree8a979a4c90bae3ca66919cdaccdaa93bb6f9815e
parentb02c845ce61b3c511bb6a35f573db0b17540b4d0 (diff)
downloadports-fbced9f2f1f6d00553fbad7a0908c9a456060842.tar.gz
ports-fbced9f2f1f6d00553fbad7a0908c9a456060842.zip
Notes
-rw-r--r--audio/icecast/Makefile8
-rw-r--r--audio/icecast/distinfo2
-rw-r--r--audio/icecast/files/patch-aa67
-rw-r--r--audio/icecast/pkg-install9
-rw-r--r--audio/icecast2/Makefile8
-rw-r--r--audio/icecast2/distinfo2
-rw-r--r--audio/icecast2/files/patch-aa67
-rw-r--r--audio/icecast2/pkg-install9
8 files changed, 8 insertions, 164 deletions
diff --git a/audio/icecast/Makefile b/audio/icecast/Makefile
index 1c1192629baf..848536e4f33b 100644
--- a/audio/icecast/Makefile
+++ b/audio/icecast/Makefile
@@ -6,14 +6,12 @@
#
PORTNAME= icecast
-PORTVERSION= 1.3.7
-PORTREVISION= 1
+PORTVERSION= 1.3.10
+PORTREVISION= 0
CATEGORIES= audio net
MASTER_SITES= http://www.icecast.org/releases/
-MAINTAINER= chip@eboai.org
-
-FORBIDDEN= "Nope, still insecure..lots of tasty buffer overflows"
+MAINTAINER= zach@pabst.bendnet.com
HAS_CONFIGURE= yes
CONFIGURE_ARGS=--with-libwrap
diff --git a/audio/icecast/distinfo b/audio/icecast/distinfo
index 8aaa993cbf06..b61318fd3c22 100644
--- a/audio/icecast/distinfo
+++ b/audio/icecast/distinfo
@@ -1 +1 @@
-MD5 (icecast-1.3.7.tar.gz) = 74f78ca33bea3cfd562530bc90d0d214
+MD5 (icecast-1.3.10.tar.gz) = e76e54daf1ad7335b4905e89e387d747
diff --git a/audio/icecast/files/patch-aa b/audio/icecast/files/patch-aa
deleted file mode 100644
index bd3c746dfc71..000000000000
--- a/audio/icecast/files/patch-aa
+++ /dev/null
@@ -1,67 +0,0 @@
---- src/http.c.orig Wed Jul 5 10:41:27 2000
-+++ src/http.c Sat Mar 10 23:03:45 2001
-@@ -710,7 +710,7 @@
- if (fd < 0)
- sock_write (clicon->sock, "%s", out);
- else
-- fd_write (fd, out);
-+ fd_write (fd, "%s", out);
-
- return 1;
- } else {
---- src/utility.c.orig Wed Jul 5 12:52:40 2000
-+++ src/utility.c Sat Mar 10 23:01:37 2001
-@@ -162,7 +162,7 @@
-
- if (!param) {
- fd_write (info.statsfile,
-- buf);
-+ "%s", buf);
- flags2string (admin, NULL);
- fd_write (info.statsfile, "\n");
- } else {
-@@ -198,7 +198,7 @@
- nice_time (get_time () - con->connect_time, timebuf), type);
-
- if (!param)
-- fd_write (info.statsfile, buf);
-+ fd_write (info.statsfile, "%s", buf);
- else
- sock_write (*sock, "%s", buf);
- }
-@@ -223,7 +223,7 @@
- source->num_clients);
-
- if (!param)
-- fd_write (info.statsfile, buf);
-+ fd_write (info.statsfile, "%s", buf);
- else
- sock_write (*sock, "%s", buf);
- }
-@@ -257,7 +257,7 @@
- }
-
- if (!param)
-- fd_write (info.statsfile, buf);
-+ fd_write (info.statsfile, "%s", buf);
- else
- sock_write (*sock, "%s", buf);
-
-@@ -267,7 +267,7 @@
- source->audiocast.mount, source->audiocast.description, source->audiocast.public);
-
- if (!param)
-- fd_write (info.statsfile, buf);
-+ fd_write (info.statsfile, "%s", buf);
- else
- sock_write (*sock, "%s", buf);
-
-@@ -330,7 +330,7 @@
- get_user_agent (con), client->type == listener_e ? "listener" : "relay");
-
- if (!param)
-- fd_write(info.statsfile, buf);
-+ fd_write(info.statsfile, "%s", buf);
- else
- sock_write (*sock, "%s", buf);
- }
diff --git a/audio/icecast/pkg-install b/audio/icecast/pkg-install
index df572c129f2f..e69de29bb2d1 100644
--- a/audio/icecast/pkg-install
+++ b/audio/icecast/pkg-install
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-if [ "$2" = "POST-INSTALL" -o -n "${PACKAGE_BUILDING}" ]; then
- exit 0
-fi
-
-/usr/bin/dialog --yesno "SECURITY NOTE: The icecast software suffered from numerous format string vulnerabilities, which allowed remote attackers to execute arbitrary code as the user running icecast. Most of these have been fixed in the FreeBSD port, but a comprehensive audit has not been conducted, and there are several remaining suspicious cases which need to be carefully checked. It is possible that further security vulnerabilities exist in this software. Do you wish to proceed with the installation of icecast anyway?" 12 70 || /usr/bin/false
-
-
diff --git a/audio/icecast2/Makefile b/audio/icecast2/Makefile
index 1c1192629baf..848536e4f33b 100644
--- a/audio/icecast2/Makefile
+++ b/audio/icecast2/Makefile
@@ -6,14 +6,12 @@
#
PORTNAME= icecast
-PORTVERSION= 1.3.7
-PORTREVISION= 1
+PORTVERSION= 1.3.10
+PORTREVISION= 0
CATEGORIES= audio net
MASTER_SITES= http://www.icecast.org/releases/
-MAINTAINER= chip@eboai.org
-
-FORBIDDEN= "Nope, still insecure..lots of tasty buffer overflows"
+MAINTAINER= zach@pabst.bendnet.com
HAS_CONFIGURE= yes
CONFIGURE_ARGS=--with-libwrap
diff --git a/audio/icecast2/distinfo b/audio/icecast2/distinfo
index 8aaa993cbf06..b61318fd3c22 100644
--- a/audio/icecast2/distinfo
+++ b/audio/icecast2/distinfo
@@ -1 +1 @@
-MD5 (icecast-1.3.7.tar.gz) = 74f78ca33bea3cfd562530bc90d0d214
+MD5 (icecast-1.3.10.tar.gz) = e76e54daf1ad7335b4905e89e387d747
diff --git a/audio/icecast2/files/patch-aa b/audio/icecast2/files/patch-aa
deleted file mode 100644
index bd3c746dfc71..000000000000
--- a/audio/icecast2/files/patch-aa
+++ /dev/null
@@ -1,67 +0,0 @@
---- src/http.c.orig Wed Jul 5 10:41:27 2000
-+++ src/http.c Sat Mar 10 23:03:45 2001
-@@ -710,7 +710,7 @@
- if (fd < 0)
- sock_write (clicon->sock, "%s", out);
- else
-- fd_write (fd, out);
-+ fd_write (fd, "%s", out);
-
- return 1;
- } else {
---- src/utility.c.orig Wed Jul 5 12:52:40 2000
-+++ src/utility.c Sat Mar 10 23:01:37 2001
-@@ -162,7 +162,7 @@
-
- if (!param) {
- fd_write (info.statsfile,
-- buf);
-+ "%s", buf);
- flags2string (admin, NULL);
- fd_write (info.statsfile, "\n");
- } else {
-@@ -198,7 +198,7 @@
- nice_time (get_time () - con->connect_time, timebuf), type);
-
- if (!param)
-- fd_write (info.statsfile, buf);
-+ fd_write (info.statsfile, "%s", buf);
- else
- sock_write (*sock, "%s", buf);
- }
-@@ -223,7 +223,7 @@
- source->num_clients);
-
- if (!param)
-- fd_write (info.statsfile, buf);
-+ fd_write (info.statsfile, "%s", buf);
- else
- sock_write (*sock, "%s", buf);
- }
-@@ -257,7 +257,7 @@
- }
-
- if (!param)
-- fd_write (info.statsfile, buf);
-+ fd_write (info.statsfile, "%s", buf);
- else
- sock_write (*sock, "%s", buf);
-
-@@ -267,7 +267,7 @@
- source->audiocast.mount, source->audiocast.description, source->audiocast.public);
-
- if (!param)
-- fd_write (info.statsfile, buf);
-+ fd_write (info.statsfile, "%s", buf);
- else
- sock_write (*sock, "%s", buf);
-
-@@ -330,7 +330,7 @@
- get_user_agent (con), client->type == listener_e ? "listener" : "relay");
-
- if (!param)
-- fd_write(info.statsfile, buf);
-+ fd_write(info.statsfile, "%s", buf);
- else
- sock_write (*sock, "%s", buf);
- }
diff --git a/audio/icecast2/pkg-install b/audio/icecast2/pkg-install
index df572c129f2f..e69de29bb2d1 100644
--- a/audio/icecast2/pkg-install
+++ b/audio/icecast2/pkg-install
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-if [ "$2" = "POST-INSTALL" -o -n "${PACKAGE_BUILDING}" ]; then
- exit 0
-fi
-
-/usr/bin/dialog --yesno "SECURITY NOTE: The icecast software suffered from numerous format string vulnerabilities, which allowed remote attackers to execute arbitrary code as the user running icecast. Most of these have been fixed in the FreeBSD port, but a comprehensive audit has not been conducted, and there are several remaining suspicious cases which need to be carefully checked. It is possible that further security vulnerabilities exist in this software. Do you wish to proceed with the installation of icecast anyway?" 12 70 || /usr/bin/false
-
-