aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-05-04 02:11:46 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-05-04 02:11:46 +0000
commit2b54287ac4fa596e8b0227fd4a67bcb873f64d13 (patch)
tree3b0513874daa8a74b320828f9fa399e74d49e619
parent74d3d829bc2c788dd7d86d3f868b6356e8fe9a26 (diff)
downloadports-2b54287ac4fa596e8b0227fd4a67bcb873f64d13.tar.gz
ports-2b54287ac4fa596e8b0227fd4a67bcb873f64d13.zip
Add p5-Net-Amazon-AWIS 0.32, use the Amazon Alexa Web Information
Service. PR: ports/112341 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=191521
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Net-Amazon-AWIS/Makefile29
-rw-r--r--www/p5-Net-Amazon-AWIS/distinfo3
-rw-r--r--www/p5-Net-Amazon-AWIS/pkg-descr23
-rw-r--r--www/p5-Net-Amazon-AWIS/pkg-plist8
5 files changed, 64 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4610590a6ab5..a76c90be0c25 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -796,6 +796,7 @@
SUBDIR += p5-Maypole-Component
SUBDIR += p5-MediaWiki
SUBDIR += p5-Net-Akismet
+ SUBDIR += p5-Net-Amazon-AWIS
SUBDIR += p5-Net-Flickr-API
SUBDIR += p5-Net-Flickr-Backup
SUBDIR += p5-Net-Flickr-RDF
diff --git a/www/p5-Net-Amazon-AWIS/Makefile b/www/p5-Net-Amazon-AWIS/Makefile
new file mode 100644
index 000000000000..7d270c510c50
--- /dev/null
+++ b/www/p5-Net-Amazon-AWIS/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Net-Amazon-AWIS
+# Date created: 2007-05-02
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Amazon-AWIS
+PORTVERSION= 0.32
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Use the Amazon Alexa Web Information Service
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/IO/Prompt.pm:${PORTSDIR}/devel/p5-IO-Prompt \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Amazon::AWIS.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Net-Amazon-AWIS/distinfo b/www/p5-Net-Amazon-AWIS/distinfo
new file mode 100644
index 000000000000..10a7966aad31
--- /dev/null
+++ b/www/p5-Net-Amazon-AWIS/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Amazon-AWIS-0.32.tar.gz) = 8f7395f9dbd0ea6951db66d4c0a28e4d
+SHA256 (Net-Amazon-AWIS-0.32.tar.gz) = 41ace1ccf00c465e37955c70df97812217cfc31bbc2b5def82ed319bad432ce0
+SIZE (Net-Amazon-AWIS-0.32.tar.gz) = 8879
diff --git a/www/p5-Net-Amazon-AWIS/pkg-descr b/www/p5-Net-Amazon-AWIS/pkg-descr
new file mode 100644
index 000000000000..df98653e9b9e
--- /dev/null
+++ b/www/p5-Net-Amazon-AWIS/pkg-descr
@@ -0,0 +1,23 @@
+The Net::Amazon::AWIS module allows you to use the Amazon Alexa Web
+Information Service.
+
+The Alexa Web Information Service (AWIS) provides developers with
+programmatic access to the information Alexa Internet (www.alexa.com)
+collects from its Web Crawl, which currently encompasses more than 100
+terabytes of data from over 4 billion Web pages. Developers and Web
+site owners can use AWIS as a platform for finding answers to
+difficult and interesting problems on the Web, and incorporating them
+into their Web applications.
+
+In order to access the Alexa Web Information Service, you will need an
+Amazon Web Services Subscription ID. See
+http://www.amazon.com/gp/aws/landing.html
+
+Registered developers have free access to the Alexa Web Information
+Service during its beta period, but it is limited to 10,000 requests
+per subscription ID per day.
+
+There are some limitations, so be sure to read the The Amazon Alexa
+Web Information Service FAQ.
+
+WWW: http://search.cpan.org/dist/Net-Amazon-AWIS/
diff --git a/www/p5-Net-Amazon-AWIS/pkg-plist b/www/p5-Net-Amazon-AWIS/pkg-plist
new file mode 100644
index 000000000000..79feed4799a7
--- /dev/null
+++ b/www/p5-Net-Amazon-AWIS/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Net/Amazon/AWIS.pm
+%%SITE_PERL%%/mach/auto/Net/Amazon/AWIS/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Net/Amazon/AWIS
+@dirrmtry %%SITE_PERL%%/mach/auto/Net/Amazon
+@dirrmtry %%SITE_PERL%%/mach/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Amazon
+@dirrmtry %%SITE_PERL%%/Net