aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-05-03 19:11:01 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-05-03 19:11:01 +0000
commitb334e18a7a385894a25f7b37ade941a98f0e8bf4 (patch)
tree21adf2b4cdddc2c5388d14ffea757002269762e7
parentfa740df6b29d898de7ffc99e6525f9bcd97c14d0 (diff)
downloadports-b334e18a7a385894a25f7b37ade941a98f0e8bf4.tar.gz
ports-b334e18a7a385894a25f7b37ade941a98f0e8bf4.zip
Correct an NSS initialization error that was causing crashes with certain
protocols. Reported by: mux Obtained from: Pidgin SVN
Notes
Notes: svn path=/head/; revision=191492
-rw-r--r--net-im/finch/Makefile1
-rw-r--r--net-im/libpurple/Makefile2
-rw-r--r--net-im/libpurple/files/patch-libpurple_plugins_ssl_ssl-nss.c11
-rw-r--r--net-im/pidgin/Makefile1
4 files changed, 14 insertions, 1 deletions
diff --git a/net-im/finch/Makefile b/net-im/finch/Makefile
index 421ecbff0ddd..bc1e7e44923f 100644
--- a/net-im/finch/Makefile
+++ b/net-im/finch/Makefile
@@ -7,6 +7,7 @@
#
PORTNAME= finch
+PORTREVISION= 0
MAINTAINER= marcus@FreeBSD.org
COMMENT= Finch multi-protocol messaging client (Console UI)
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 7902fad2de3f..7295b2cd07a9 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -8,7 +8,7 @@
PORTNAME?= libpurple
PORTVERSION= 2.0.0.b7
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net-im
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pidgin
diff --git a/net-im/libpurple/files/patch-libpurple_plugins_ssl_ssl-nss.c b/net-im/libpurple/files/patch-libpurple_plugins_ssl_ssl-nss.c
new file mode 100644
index 000000000000..13e52ccfb4aa
--- /dev/null
+++ b/net-im/libpurple/files/patch-libpurple_plugins_ssl_ssl-nss.c
@@ -0,0 +1,11 @@
+--- libpurple/plugins/ssl/ssl-nss.c.orig Thu May 3 14:58:39 2007
++++ libpurple/plugins/ssl/ssl-nss.c Thu May 3 15:05:59 2007
+@@ -108,7 +108,7 @@ ssl_nss_init_nss(void)
+ {
+ char *lib;
+ PR_Init(PR_SYSTEM_THREAD, PR_PRIORITY_NORMAL, 1);
+- NSS_NoDB_Init(NULL);
++ NSS_NoDB_Init(".");
+
+ /* TODO: Fix this so autoconf does the work trying to find this lib. */
+ #ifndef _WIN32
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index 9f4731210c13..56d90ee92304 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -7,6 +7,7 @@
#
PORTNAME= pidgin
+PORTREVISION= 0
MAINTAINER= marcus@FreeBSD.org
COMMENT= Pidgin multi-protocol messaging client (GTK+ UI)