aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-05-04 00:45:43 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-05-04 00:45:43 +0000
commitbf3990a6a54ba06b831ed356d512a290e88d45b3 (patch)
treec4dee179d51c492423f3a98876a75af3a61d912a
parent6fdb86d270db9c938ae4e16ab191db81d436f213 (diff)
downloadports-bf3990a6a54ba06b831ed356d512a290e88d45b3.tar.gz
ports-bf3990a6a54ba06b831ed356d512a290e88d45b3.zip
sharktorrent is an open source/freeware bittorrent client written in c++. It
uses wxWidgets, libtorrent and boost. WWW: http://sharktorrent.com/
Notes
Notes: svn path=/head/; revision=191507
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/sharktorrent/Makefile27
-rw-r--r--net-p2p/sharktorrent/distinfo3
-rw-r--r--net-p2p/sharktorrent/files/patch-src__Makefile.in11
-rw-r--r--net-p2p/sharktorrent/pkg-descr4
5 files changed, 46 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index aa584308e995..49018f39abdc 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -116,6 +116,7 @@
SUBDIR += rblibtorrent-devel
SUBDIR += rtorrent
SUBDIR += rtorrent-devel
+ SUBDIR += sharktorrent
SUBDIR += squall
SUBDIR += torrent_swapper
SUBDIR += torrentflux
diff --git a/net-p2p/sharktorrent/Makefile b/net-p2p/sharktorrent/Makefile
new file mode 100644
index 000000000000..25579a80a975
--- /dev/null
+++ b/net-p2p/sharktorrent/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: sharktorrent
+# Date created: 2007-04-25
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= sharktorrent
+PORTVERSION= 0.1.1
+CATEGORIES= net-p2p
+MASTER_SITES= SF
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= C++ Bittorrent client using wxWidgets, libtorrent and boost
+
+LIB_DEPENDS= boost_filesystem.3:${PORTSDIR}/devel/boost \
+ torrent.1:${PORTSDIR}/net-p2p/rblibtorrent
+
+USE_WX= 2.6
+WX_CONF_ARGS= absolute
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDLFAGS="-L${LOCALBASE}/lib"
+CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/libtorrent
+
+PLIST_FILES= bin/sharktorrent
+
+.include <bsd.port.mk>
diff --git a/net-p2p/sharktorrent/distinfo b/net-p2p/sharktorrent/distinfo
new file mode 100644
index 000000000000..45ece23f442e
--- /dev/null
+++ b/net-p2p/sharktorrent/distinfo
@@ -0,0 +1,3 @@
+MD5 (sharktorrent-0.1.1.tar.gz) = f1802307e9f3fa78359d28024ebe039d
+SHA256 (sharktorrent-0.1.1.tar.gz) = 618124c1db56fbaf2f1e27a889379e56397b181c2e4f668a531be3f11ff0eece
+SIZE (sharktorrent-0.1.1.tar.gz) = 710540
diff --git a/net-p2p/sharktorrent/files/patch-src__Makefile.in b/net-p2p/sharktorrent/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..3de915b6b621
--- /dev/null
+++ b/net-p2p/sharktorrent/files/patch-src__Makefile.in
@@ -0,0 +1,11 @@
+--- ./src/Makefile.in.orig Sat Dec 16 20:45:49 2006
++++ ./src/Makefile.in Wed Apr 25 23:10:18 2007
+@@ -189,7 +189,7 @@
+ sttorrentmetainfogui.cpp sttorrentslistctrl.cpp stconfigdata.cpp sharktorrentframe.cpp \
+ sttaskbaricon.cpp stfiledroptarget.cpp ststrlong.cpp stpairstrhandle.cpp
+
+-sharktorrent_LDFLAGS = $(WX_LIBS)
++sharktorrent_LDFLAGS = $(WX_LIBS) -lboost_filesystem -ltorrent
+ all: all-am
+
+ .SUFFIXES:
diff --git a/net-p2p/sharktorrent/pkg-descr b/net-p2p/sharktorrent/pkg-descr
new file mode 100644
index 000000000000..a52786ef998a
--- /dev/null
+++ b/net-p2p/sharktorrent/pkg-descr
@@ -0,0 +1,4 @@
+sharktorrent is an open source/freeware bittorrent client written in c++. It
+uses wxWidgets, libtorrent and boost.
+
+WWW: http://sharktorrent.com/