aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-15 23:46:53 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-15 23:46:53 +0000
commit413d190273b34a781f1f79dfc4d81bf422407100 (patch)
treee42cf58d96ef05197cd6a394d2b05a1859b5be3d
parent7657603be65412b1840d0b48180b6fd28b2e6e4e (diff)
downloadports-413d190273b34a781f1f79dfc4d81bf422407100.tar.gz
ports-413d190273b34a781f1f79dfc4d81bf422407100.zip
Update to 0.10.
Adopt.
Notes
Notes: svn path=/head/; revision=336598
-rw-r--r--devel/regexxer/Makefile47
-rw-r--r--devel/regexxer/distinfo4
-rw-r--r--devel/regexxer/files/patch-Makefile.in10
-rw-r--r--devel/regexxer/files/patch-src_fileshared.h11
-rw-r--r--devel/regexxer/files/patch-src_globalstrings.h11
-rw-r--r--devel/regexxer/files/patch-src_translation.h11
-rw-r--r--devel/regexxer/pkg-plist19
7 files changed, 78 insertions, 35 deletions
diff --git a/devel/regexxer/Makefile b/devel/regexxer/Makefile
index c6b5c53f9b4e..0f6f4a3ff821 100644
--- a/devel/regexxer/Makefile
+++ b/devel/regexxer/Makefile
@@ -1,35 +1,22 @@
# Created by: Rui Lopes <rui@ruilopes.com>
# $FreeBSD$
-PORTNAME= regexxer
-PORTVERSION= 0.9
-PORTREVISION= 10
-CATEGORIES= devel textproc gnome
-MASTER_SITES= SF
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An interactive tool for performing search and replace operations
-
-LIB_DEPENDS= gconfmm-2.6:${PORTSDIR}/devel/gconfmm26 \
- glademm-2.4:${PORTSDIR}/devel/libglademm24 \
- pcre.3:${PORTSDIR}/devel/pcre
-
-GNU_CONFIGURE= yes
-USES= pathfix gettext gmake pkgconfig
-USE_GNOME= gnomeprefix intltool intlhack
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-GCONF_SCHEMAS= regexxer.schemas
-INSTALLS_ICONS= regexxer.png
-
-# This target is only meant to be used by the port maintainer.
-NO_STAGE= yes
-x-generate-plist:
- (${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX}|${GREP} regexxer) > temp-pkg-plist
-
-post-patch:
- @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
- ${WRKSRC}/src/globalstrings.h ${WRKSRC}/src/translation.h
+PORTNAME= regexxer
+PORTVERSION= 0.10
+CATEGORIES= devel textproc gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Interactive tool for performing search and replace operations
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomeprefix intltool intlhack gtkmm30 gtksourceviewmm3
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALLS_ICONS= yes
+
+GLIB_SCHEMAS= org.regexxer.gschema.xml
.include <bsd.port.mk>
diff --git a/devel/regexxer/distinfo b/devel/regexxer/distinfo
index 8078f4ce1e30..40236ddae938 100644
--- a/devel/regexxer/distinfo
+++ b/devel/regexxer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (regexxer-0.9.tar.gz) = ec6630745e4a87eb57aa498b5d36f014efb91a18293cc7acd9a5b506b6238479
-SIZE (regexxer-0.9.tar.gz) = 299095
+SHA256 (regexxer-0.10.tar.xz) = 2a7832541a0306b3d4eb63a1cf8978d7bbfc7927e9304473fe801d71fd99736c
+SIZE (regexxer-0.10.tar.xz) = 251544
diff --git a/devel/regexxer/files/patch-Makefile.in b/devel/regexxer/files/patch-Makefile.in
new file mode 100644
index 000000000000..3f0242770028
--- /dev/null
+++ b/devel/regexxer/files/patch-Makefile.in
@@ -0,0 +1,10 @@
+--- Makefile.in.orig 2013-12-16 00:13:47.000000000 +0100
++++ Makefile.in 2013-12-16 00:14:26.000000000 +0100
+@@ -1092,7 +1092,6 @@
+ @INTLTOOL_XML_NOMERGE_RULE@
+
+ install-data-hook: install-update-icon-cache
+- $(GLIB_COMPILE_SCHEMAS) $(gsettingsschemadir)
+ #$(gsettingsupdateschemacache) $(gsettingsschemadir)
+
+ uninstall-hook: uninstall-update-icon-cache
diff --git a/devel/regexxer/files/patch-src_fileshared.h b/devel/regexxer/files/patch-src_fileshared.h
new file mode 100644
index 000000000000..37fda151ff83
--- /dev/null
+++ b/devel/regexxer/files/patch-src_fileshared.h
@@ -0,0 +1,11 @@
+--- src/fileshared.h.orig 2011-10-06 14:50:48.000000000 +0200
++++ src/fileshared.h 2013-12-16 00:09:23.000000000 +0100
+@@ -23,7 +23,7 @@
+
+ #include "sharedptr.h"
+
+-#include <gtkmm/textbuffer.h>
++#include <gtkmm.h>
+ #include <functional>
+ #include <utility>
+ #include <vector>
diff --git a/devel/regexxer/files/patch-src_globalstrings.h b/devel/regexxer/files/patch-src_globalstrings.h
new file mode 100644
index 000000000000..efe030fdbfa5
--- /dev/null
+++ b/devel/regexxer/files/patch-src_globalstrings.h
@@ -0,0 +1,11 @@
+--- src/globalstrings.h.orig 2013-12-16 00:04:58.000000000 +0100
++++ src/globalstrings.h 2013-12-16 00:05:20.000000000 +0100
+@@ -21,7 +21,7 @@
+ #ifndef REGEXXER_GLOBALSTRINGS_H_INCLUDED
+ #define REGEXXER_GLOBALSTRINGS_H_INCLUDED
+
+-#include <glib/gutils.h> /* for G_DIR_SEPARATOR_S */
++#include <glib.h> /* for G_DIR_SEPARATOR_S */
+
+ namespace Regexxer
+ {
diff --git a/devel/regexxer/files/patch-src_translation.h b/devel/regexxer/files/patch-src_translation.h
new file mode 100644
index 000000000000..f017f360cab2
--- /dev/null
+++ b/devel/regexxer/files/patch-src_translation.h
@@ -0,0 +1,11 @@
+--- src/translation.h.orig 2013-12-16 00:04:52.000000000 +0100
++++ src/translation.h 2013-12-16 00:05:10.000000000 +0100
+@@ -21,7 +21,7 @@
+ #ifndef REGEXXER_TRANSLATION_H_INCLUDED
+ #define REGEXXER_TRANSLATION_H_INCLUDED
+
+-#include <glib/gmacros.h>
++#include <glib.h>
+ #include <glibmm/ustring.h>
+
+ #ifndef gettext_noop
diff --git a/devel/regexxer/pkg-plist b/devel/regexxer/pkg-plist
index a78a85198c77..a345c7d9f307 100644
--- a/devel/regexxer/pkg-plist
+++ b/devel/regexxer/pkg-plist
@@ -1,41 +1,54 @@
bin/regexxer
share/applications/regexxer.desktop
-share/regexxer/mainwindow.glade
-share/regexxer/prefdialog.glade
share/icons/hicolor/48x48/apps/regexxer.png
share/locale/ar/LC_MESSAGES/regexxer.mo
share/locale/bg/LC_MESSAGES/regexxer.mo
share/locale/ca/LC_MESSAGES/regexxer.mo
share/locale/cs/LC_MESSAGES/regexxer.mo
+share/locale/da/LC_MESSAGES/regexxer.mo
share/locale/de/LC_MESSAGES/regexxer.mo
share/locale/dz/LC_MESSAGES/regexxer.mo
+share/locale/el/LC_MESSAGES/regexxer.mo
share/locale/en_CA/LC_MESSAGES/regexxer.mo
share/locale/en_GB/LC_MESSAGES/regexxer.mo
share/locale/es/LC_MESSAGES/regexxer.mo
share/locale/eu/LC_MESSAGES/regexxer.mo
share/locale/fi/LC_MESSAGES/regexxer.mo
share/locale/fr/LC_MESSAGES/regexxer.mo
+share/locale/gl/LC_MESSAGES/regexxer.mo
+share/locale/gu/LC_MESSAGES/regexxer.mo
share/locale/hu/LC_MESSAGES/regexxer.mo
share/locale/it/LC_MESSAGES/regexxer.mo
share/locale/ja/LC_MESSAGES/regexxer.mo
+share/locale/nb/LC_MESSAGES/regexxer.mo
share/locale/ne/LC_MESSAGES/regexxer.mo
share/locale/nl/LC_MESSAGES/regexxer.mo
+share/locale/oc/LC_MESSAGES/regexxer.mo
share/locale/pa/LC_MESSAGES/regexxer.mo
share/locale/pl/LC_MESSAGES/regexxer.mo
share/locale/pt/LC_MESSAGES/regexxer.mo
share/locale/pt_BR/LC_MESSAGES/regexxer.mo
+share/locale/ru/LC_MESSAGES/regexxer.mo
share/locale/rw/LC_MESSAGES/regexxer.mo
+share/locale/sk/LC_MESSAGES/regexxer.mo
share/locale/sl/LC_MESSAGES/regexxer.mo
share/locale/sr/LC_MESSAGES/regexxer.mo
-share/locale/sr@Latn/LC_MESSAGES/regexxer.mo
+share/locale/sr@latin/LC_MESSAGES/regexxer.mo
share/locale/sv/LC_MESSAGES/regexxer.mo
+share/locale/ta/LC_MESSAGES/regexxer.mo
share/locale/uk/LC_MESSAGES/regexxer.mo
share/locale/vi/LC_MESSAGES/regexxer.mo
share/locale/zh_CN/LC_MESSAGES/regexxer.mo
share/locale/zh_HK/LC_MESSAGES/regexxer.mo
share/locale/zh_TW/LC_MESSAGES/regexxer.mo
+share/regexxer/mainwindow.ui
+share/regexxer/prefdialog.ui
@dirrm share/regexxer
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/or/LC_MESSAGES
+@dirrmtry share/locale/or
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz