aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2013-12-16 03:23:23 +0000
committerDiane Bruce <db@FreeBSD.org>2013-12-16 03:23:23 +0000
commitcfcf27be656d3696fba4bf823d03a1500e89acdb (patch)
treea79d26fe2b5ea6395bc750ac83ea0e75e64f6dbf
parentb66bb4b69596aac323c8cbeea64d8b7e0ca5889e (diff)
downloadports-cfcf27be656d3696fba4bf823d03a1500e89acdb.tar.gz
ports-cfcf27be656d3696fba4bf823d03a1500e89acdb.zip
- Fix build on 10
- Add stage support - Add LICENSE
Notes
Notes: svn path=/head/; revision=336604
-rw-r--r--comms/hf/Makefile29
-rw-r--r--comms/hf/files/patch-hfkernel_Makefile.in13
-rw-r--r--comms/hf/pkg-plist8
3 files changed, 30 insertions, 20 deletions
diff --git a/comms/hf/Makefile b/comms/hf/Makefile
index b7e403759da3..9729f555de95 100644
--- a/comms/hf/Makefile
+++ b/comms/hf/Makefile
@@ -10,20 +10,20 @@ MASTER_SITES= SF/${PORTNAME}term/${PORTNAME}/${PORTVERSION}
MAINTAINER= db@FreeBSD.org
COMMENT= Amateur Radio soundcard fsk, pactor 1, amtor, gtor, mt63
+LICENSE= GPLv2
+
RUN_DEPENDS= whiptail:${PORTSDIR}/devel/newt
USE_GNOME= gtk12
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX}
+CONFIGURE_ARGS= --prefix=${STAGEDIR}${PREFIX} --sysconfdir=${STAGEDIR}${PREFIX}
MAKE_JOBS_UNSAFE= yes
-MANLANG= "" "de.ISO8859-1"
-MAN1= hf.1 hfterm.1 hfkernel.1
-MAN1_EN= dcf77gen.1 dcf77rx.1
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
CONFLICTS= sysutils/lbl-hf-1.*
-NO_STAGE= yes
post-configure:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|' \
${WRKSRC}/hfkernel/Makefile
@@ -31,18 +31,13 @@ post-configure:
${WRKSRC}/util/reffreq.c ${WRKSRC}/scripts/Makefile
post-install:
- @${ECHO} ""
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for d in ${WRKSRC}/doc/hf-examplefiles/fix.[0-1]*[0-9]* \
${WRKSRC}/doc/hf-examplefiles/gag
- @${INSTALL_DATA} ${WRKSRC}/${d} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${d} ${STAGEDIR}${EXAMPLESDIR}
.endfor
- @${ECHO} "hf examples installed in ${EXAMPLESDIR}"
-.endif
-
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${ECHO} "If examples are installed they will be found in ${EXAMPLESDIR}" >> ${WRKDIR}/pkg-message
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for d in ${WRKSRC}/doc/AUTHORS ${WRKSRC}/doc/ChangeLog \
${WRKSRC}/doc/DE-HF-HOWTO.txt ${WRKSRC}/doc/HF-HOWTO.txt \
${WRKSRC}/doc/INSTALL ${WRKSRC}/doc/LIESMICH \
@@ -52,10 +47,8 @@ post-install:
${WRKSRC}/doc/lfconv.jpg ${WRKSRC}/doc/mt63.txt \
${WRKSRC}/doc/pactor.ps ${WRKSRC}/doc/pactor.txt \
${WRKSRC}/doc/pactor_statediag.fig
- @${INSTALL_DATA} ${WRKSRC}/${d} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${d} ${STAGEDIR}${DOCSDIR}
.endfor
- @${ECHO} "hf docs installed in ${DOCSDIR}"
-.endif
- @${ECHO} ""
+ @${ECHO} "If docs are installed they will be found in ${DOCSDIR}" >> ${WRKDIR}/pkg-message
.include <bsd.port.mk>
diff --git a/comms/hf/files/patch-hfkernel_Makefile.in b/comms/hf/files/patch-hfkernel_Makefile.in
index 218ac448ac04..188fe8df0a12 100644
--- a/comms/hf/files/patch-hfkernel_Makefile.in
+++ b/comms/hf/files/patch-hfkernel_Makefile.in
@@ -1,5 +1,14 @@
---- hfkernel/Makefile.in.orig Sun Apr 15 18:33:50 2007
-+++ hfkernel/Makefile.in Sun Apr 15 18:34:48 2007
+--- hfkernel/Makefile.in.orig 2007-02-06 09:44:30.000000000 -0500
++++ hfkernel/Makefile.in 2013-12-14 21:36:25.710721920 -0500
+@@ -114,7 +114,7 @@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+-LIBS = @LIBS@
++LIBS = @LIBS@ -lm
+ LTLIBOBJS = @LTLIBOBJS@
+ MAKEINFO = @MAKEINFO@
+ OBJEXT = @OBJEXT@
@@ -179,6 +179,7 @@
noinst_HEADERS = main.h msg.h
hfkernel_SOURCES = main.c msg.c
diff --git a/comms/hf/pkg-plist b/comms/hf/pkg-plist
index 8e45558fb223..6fa89f888836 100644
--- a/comms/hf/pkg-plist
+++ b/comms/hf/pkg-plist
@@ -19,6 +19,14 @@ bin/ratetry
bin/reffreq
etc/calibrations.samp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fix.01
+man/de.ISO8859-1/man1/hf.1.gz
+man/de.ISO8859-1/man1/hfkernel.1.gz
+man/de.ISO8859-1/man1/hfterm.1.gz
+man/man1/dcf77gen.1.gz
+man/man1/dcf77rx.1.gz
+man/man1/hf.1.gz
+man/man1/hfkernel.1.gz
+man/man1/hfterm.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fix.02
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fix.03
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fix.04