aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-10-16 05:28:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-10-16 05:28:48 +0000
commit22bffd48a6e415f4f4babe470d383067aac16a5f (patch)
treea4e59b793f4721b4809d3afd5e28efcbe39a061c
parent5f44492ec565f12a175620c986f406a87f1cf2f4 (diff)
downloadports-22bffd48a6e415f4f4babe470d383067aac16a5f.tar.gz
ports-22bffd48a6e415f4f4babe470d383067aac16a5f.zip
MFH: r370967
Update to 1.8.11p1 PR: 194259 Submitted by: cy@ and Yasuhiro KIMURA <yasu@utahime.org>
Notes
Notes: svn path=/branches/2014Q4/; revision=370968
-rw-r--r--security/sudo/Makefile7
-rw-r--r--security/sudo/distinfo4
-rw-r--r--security/sudo/files/patch-install-sh28
-rw-r--r--security/sudo/files/patch-plugins__sudoers__Makefile.in18
-rw-r--r--security/sudo/files/patch-plugins__sudoers__audit.c8
-rw-r--r--security/sudo/pkg-plist8
6 files changed, 53 insertions, 20 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 42405916f197..16398596bb51 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sudo
-DISTVERSION= 1.8.10p3
-PORTREVISION= 1
+DISTVERSION= 1.8.11p1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SUDO}
@@ -15,6 +14,7 @@ LICENSE_NAME= Sudo license
LICENSE_FILE= ${WRKSRC}/doc/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+USES= libtool
GNU_CONFIGURE= yes
LDFLAGS+= -lgcc
LDFLAGS+= -lssp_nonshared
@@ -92,9 +92,10 @@ post-patch:
post-install:
${INSTALL_DATA} ${FILESDIR}/pam.conf ${STAGEDIR}${PREFIX}/etc/pam.d/sudo.default
${TOUCH} ${STAGEDIR}${PREFIX}/etc/sudoers.d/.keep-me
+ ${MV} ${STAGEDIR}${PREFIX}/etc/sudoers ${STAGEDIR}${PREFIX}/etc/sudoers.sample
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sudoreplay
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/visudo
-.for f in group_file.so sudoers.so system_group.so
+.for f in group_file.so libsudo_util.so sudoers.so system_group.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/sudo/${f}
.endfor
diff --git a/security/sudo/distinfo b/security/sudo/distinfo
index 603d58c053f7..fc8996d85d3f 100644
--- a/security/sudo/distinfo
+++ b/security/sudo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sudo-1.8.10p3.tar.gz) = 6eda135fa68163108f1c24de6975de5ddb09d75730bb62d6390bda7b04345400
-SIZE (sudo-1.8.10p3.tar.gz) = 2262370
+SHA256 (sudo-1.8.11p1.tar.gz) = 44c275772595a119185336164bb76b6e08f23d38aa0fe0d6bab48812e75d6a43
+SIZE (sudo-1.8.11p1.tar.gz) = 2402012
diff --git a/security/sudo/files/patch-install-sh b/security/sudo/files/patch-install-sh
new file mode 100644
index 000000000000..74b3a6a11c08
--- /dev/null
+++ b/security/sudo/files/patch-install-sh
@@ -0,0 +1,28 @@
+--- install-sh.orig 2014-09-24 01:40:15.000000000 +0900
++++ install-sh 2014-10-10 07:26:54.000000000 +0900
+@@ -171,12 +171,6 @@
+ if [ ! -d "${DEST}" ] ; then
+ ${MKDIR} "${DEST}" || exit 1
+ fi
+- if ${CHOWNIT} ; then
+- ${CHOWN} "${OWNER}" "${DEST}" || exit 1
+- fi
+- if ${CHGROUPIT} ; then
+- ${CHGRP} "${GROUP}" "${DEST}" || exit 1
+- fi
+ if ${CHMODIT} ; then
+ ${CHMOD} "${MODE}" "${DEST}" || exit 1
+ fi
+@@ -227,12 +221,6 @@
+ if ${STRIPIT} ; then
+ ${STRIP} "${DEST}" || exit 1
+ fi
+-if ${CHOWNIT} ; then
+- ${CHOWN} "${OWNER}" "${DEST}" || exit 1
+-fi
+-if ${CHGROUPIT} ; then
+- ${CHGRP} "${GROUP}" "${DEST}" || exit 1
+-fi
+ if ${CHMODIT} ; then
+ ${CHMOD} "${MODE}" "${DEST}" || exit 1
+ fi
diff --git a/security/sudo/files/patch-plugins__sudoers__Makefile.in b/security/sudo/files/patch-plugins__sudoers__Makefile.in
index 94852a94825f..9584fa81fdf5 100644
--- a/security/sudo/files/patch-plugins__sudoers__Makefile.in
+++ b/security/sudo/files/patch-plugins__sudoers__Makefile.in
@@ -1,14 +1,12 @@
---- ./plugins/sudoers/Makefile.in.orig 2011-04-11 08:28:33.000000000 -0400
-+++ ./plugins/sudoers/Makefile.in 2011-04-17 09:38:29.349385961 -0400
-@@ -358,9 +358,8 @@
+--- plugins/sudoers/Makefile.in.orig 2014-10-08 05:26:20.000000000 +0900
++++ plugins/sudoers/Makefile.in 2014-10-10 07:23:21.000000000 +0900
+@@ -323,8 +323,7 @@
+
install-sudoers: install-dirs
- $(INSTALL) -d -O $(sudoers_uid) -G $(sudoers_gid) -m 0750 \
- $(DESTDIR)$(sudoersdir)/sudoers.d
+ $(INSTALL) -d $(INSTALL_OWNER) -m 0750 $(DESTDIR)$(sudoersdir)/sudoers.d
- test -r $(DESTDIR)$(sudoersdir)/sudoers || \
-- $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -m $(sudoers_mode) \
-- sudoers $(DESTDIR)$(sudoersdir)/sudoers
-+ $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -m $(sudoers_mode) \
-+ sudoers $(DESTDIR)$(sudoersdir)/sudoers.sample
+- $(INSTALL) $(INSTALL_OWNER) -m $(sudoers_mode) sudoers $(DESTDIR)$(sudoersdir)/sudoers
++ $(INSTALL) $(INSTALL_OWNER) -m $(sudoers_mode) sudoers $(DESTDIR)$(sudoersdir)/sudoers
uninstall:
- -rm -f $(DESTDIR)$(plugindir)/sudoers$(soext)
+ -$(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(plugindir)/sudoers.la
diff --git a/security/sudo/files/patch-plugins__sudoers__audit.c b/security/sudo/files/patch-plugins__sudoers__audit.c
index 43e2ebd32cc1..8e4bf09a4f10 100644
--- a/security/sudo/files/patch-plugins__sudoers__audit.c
+++ b/security/sudo/files/patch-plugins__sudoers__audit.c
@@ -1,10 +1,10 @@
---- ./plugins/sudoers/audit.c.orig 2013-06-04 11:48:28.000000000 +0200
-+++ ./plugins/sudoers/audit.c 2013-07-05 13:10:01.000000000 +0200
-@@ -39,6 +39,7 @@
+--- plugins/sudoers/audit.c.orig 2014-09-24 01:40:15.000000000 +0900
++++ plugins/sudoers/audit.c 2014-10-10 07:24:43.000000000 +0900
+@@ -42,6 +42,7 @@
#ifdef HAVE_BSM_AUDIT
# include "bsm_audit.h"
-+# include "gettext.h"
++# include "sudo_gettext.h"
#endif
#ifdef HAVE_LINUX_AUDIT
# include "linux_audit.h"
diff --git a/security/sudo/pkg-plist b/security/sudo/pkg-plist
index 6f06deb28564..51e6aca20f9b 100644
--- a/security/sudo/pkg-plist
+++ b/security/sudo/pkg-plist
@@ -7,6 +7,9 @@ etc/pam.d/sudo.default
@exec if [ ! -f %D/etc/pam.d/sudo ] ; then cp -p %D/%F %B/sudo; fi
include/sudo_plugin.h
libexec/sudo/group_file.so
+libexec/sudo/libsudo_util.so
+libexec/sudo/libsudo_util.so.0
+libexec/sudo/libsudo_util.so.0.0.0
libexec/sudo/sudo_noexec.so
libexec/sudo/sudoers.so
libexec/sudo/system_group.so
@@ -37,12 +40,14 @@ sbin/visudo
%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/schema.iPlanet
%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/schema.ActiveDirectory
%%NLS%%share/locale/ca/LC_MESSAGES/sudo.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/cs/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/cs/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/da/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/da/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/de/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/de/LC_MESSAGES/sudoers.mo
+%%NLS%%share/locale/el/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/eo/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/eo/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/es/LC_MESSAGES/sudo.mo
@@ -59,6 +64,8 @@ sbin/visudo
%%NLS%%share/locale/ja/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/ja/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/lt/LC_MESSAGES/sudoers.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/sudo.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/nl/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/nl/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/pl/LC_MESSAGES/sudo.mo
@@ -80,7 +87,6 @@ sbin/visudo
%%NLS%%share/locale/vi/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/sudoers.mo
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
etc/sudoers.d/.keep-me
@dir /var/db/sudo
@dir /var/run/sudo