aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-10-15 15:45:06 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-10-15 15:45:06 +0000
commit66fed939c776e26147dad65bddb7d3ee634f9fbd (patch)
treef47c39c6c51032e57a1a04ae4e9fab58de663fe9
parent5499c4f24eb2b33dec76e9a2810b0bddf45d14c8 (diff)
downloadports-66fed939c776e26147dad65bddb7d3ee634f9fbd.tar.gz
ports-66fed939c776e26147dad65bddb7d3ee634f9fbd.zip
MFH: r370930
- Allow svnup to work with TLS; SSLv3 is being disabled due to POODLE. PR: 194241 Submitted by: spil.oss@gmail.com Obtained from: Merged in upstream
Notes
Notes: svn path=/branches/2014Q4/; revision=370931
-rw-r--r--net/svnup/Makefile1
-rw-r--r--net/svnup/files/patch-svnup.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/svnup/Makefile b/net/svnup/Makefile
index c2c74578be9f..8b5d3270ace7 100644
--- a/net/svnup/Makefile
+++ b/net/svnup/Makefile
@@ -2,6 +2,7 @@
PORTNAME= svnup
PORTVERSION= 1.06
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://jcm.dsl.visi.com/freebsd/svnup/ \
LOCAL/jgh/net/${PORTNAME}/
diff --git a/net/svnup/files/patch-svnup.c b/net/svnup/files/patch-svnup.c
new file mode 100644
index 000000000000..5c79303d945f
--- /dev/null
+++ b/net/svnup/files/patch-svnup.c
@@ -0,0 +1,11 @@
+--- svnup.c.orig 2014-09-06 03:16:15.000000000 +0200
++++ svnup.c 2014-10-08 15:11:07.593705013 +0200
+@@ -355,7 +355,7 @@
+ SSL_load_error_strings();
+ connection->ctx = SSL_CTX_new(SSLv23_client_method());
+ SSL_CTX_set_mode(connection->ctx, SSL_MODE_AUTO_RETRY);
+- SSL_CTX_set_options(connection->ctx, SSL_OP_ALL | SSL_OP_NO_TICKET | SSL_OP_NO_TLSv1);
++ SSL_CTX_set_options(connection->ctx, SSL_OP_ALL | SSL_OP_NO_TICKET);
+
+ if ((connection->ssl = SSL_new(connection->ctx)) == NULL)
+ err(EXIT_FAILURE, "reset_connection: SSL_new");