aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-09-30 04:17:39 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-09-30 04:17:39 +0000
commitd428de8d5756c3bc49e9e9c39161e0490a5f63e3 (patch)
tree6a629af335f5f199ee95305febcb92bef53e0b9c
parentf538328b8bc12668226a23595bb736314478a570 (diff)
downloadports-d428de8d5756c3bc49e9e9c39161e0490a5f63e3.tar.gz
ports-d428de8d5756c3bc49e9e9c39161e0490a5f63e3.zip
Notes
-rw-r--r--print/cups-base/Makefile13
-rw-r--r--print/cups-base/distinfo6
-rw-r--r--print/cups-base/files/patch-auth.c10
-rw-r--r--print/cups-base/pkg-plist15
-rw-r--r--print/cups/Makefile2
5 files changed, 19 insertions, 27 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 1a2a1e590c1e..f7c104239538 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cups
-PORTVERSION= 1.3.0
-PORTREVISION= 1
+PORTVERSION= 1.3.3
DISTVERSIONSUFFIX= -source
CATEGORIES= print
MASTER_SITES= EASYSW/${PORTNAME}/${DISTVERSION}
@@ -159,11 +158,11 @@ pre-su-install:
if ! pw usershow ${CUPSOWN}; then pw useradd ${CUPSOWN} -g ${CUPSGRP} -u 193 \
-h - -d ${NONEXISTENT} -s /usr/sbin/nologin -c "CUPS Owner"; fi
.if defined(CUPS_OVERWRITE_BASE)
- if test -e /usr/bin/lp; then chmod -h 0 /usr/bin/lp; fi
- if test -e /usr/bin/lpq; then chmod -h 0 /usr/bin/lpq; fi
- if test -e /usr/bin/lpr; then chmod -h 0 /usr/bin/lpr; fi
- if test -e /usr/bin/lprm; then chmod -h 0 /usr/bin/lprm; fi
- if test -e /usr/sbin/lpc; then chmod -h 0 /usr/sbin/lpc; fi
+ if test -e /usr/bin/lp; then ${CHMOD} -h 0 /usr/bin/lp; fi
+ if test -e /usr/bin/lpq; then ${CHMOD} -h 0 /usr/bin/lpq; fi
+ if test -e /usr/bin/lpr; then ${CHMOD} -h 0 /usr/bin/lpr; fi
+ if test -e /usr/bin/lprm; then ${CHMOD} -h 0 /usr/bin/lprm; fi
+ if test -e /usr/sbin/lpc; then ${CHMOD} -h 0 /usr/sbin/lpc; fi
.endif
post-install:
diff --git a/print/cups-base/distinfo b/print/cups-base/distinfo
index 8a961307d0f4..0cabfd917ede 100644
--- a/print/cups-base/distinfo
+++ b/print/cups-base/distinfo
@@ -1,3 +1,3 @@
-MD5 (cups-1.3.0-source.tar.bz2) = ae2855d5d1ab5b5fcbb8a2613cefec14
-SHA256 (cups-1.3.0-source.tar.bz2) = 55f974f3086e4a4cf438e7d69b6f08015ae86f5f208b16feca7614c3ff1b30da
-SIZE (cups-1.3.0-source.tar.bz2) = 4022669
+MD5 (cups-1.3.3-source.tar.bz2) = d4911e68b6979d16bc7a55f68d16cc53
+SHA256 (cups-1.3.3-source.tar.bz2) = 5e9e5670777055293e309cb0cbb2758df9c1275bf648df70478b7389c2d804de
+SIZE (cups-1.3.3-source.tar.bz2) = 4077262
diff --git a/print/cups-base/files/patch-auth.c b/print/cups-base/files/patch-auth.c
deleted file mode 100644
index 08fe6e0dc3fd..000000000000
--- a/print/cups-base/files/patch-auth.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- scheduler/auth.c.orig Sat Aug 11 01:09:45 2007
-+++ scheduler/auth.c Thu Aug 16 20:43:41 2007
-@@ -84,6 +84,7 @@
- # endif /* HAVE_SECBASEPRIV_H */
- #endif /* HAVE_AUTHORIZATION_H */
- #ifdef HAVE_SYS_UCRED_H
-+# include <sys/param.h>
- # include <sys/ucred.h>
- typedef struct xucred cupsd_ucred_t;
- # define CUPSD_UCRED_UID(c) (c).cr_uid
diff --git a/print/cups-base/pkg-plist b/print/cups-base/pkg-plist
index 842b9d026a49..3e6b5df2ddca 100644
--- a/print/cups-base/pkg-plist
+++ b/print/cups-base/pkg-plist
@@ -291,6 +291,7 @@ sbin/reject
%%DATADIR%%/templates/error.tmpl
%%DATADIR%%/templates/es/add-class.tmpl
%%DATADIR%%/templates/es/add-printer.tmpl
+%%DATADIR%%/templates/es/add-rss-subscription.tmpl
%%DATADIR%%/templates/es/admin.tmpl
%%DATADIR%%/templates/es/choose-device.tmpl
%%DATADIR%%/templates/es/choose-make.tmpl
@@ -318,6 +319,7 @@ sbin/reject
%%DATADIR%%/templates/es/job-restart.tmpl
%%DATADIR%%/templates/es/jobs-header.tmpl
%%DATADIR%%/templates/es/jobs.tmpl
+%%DATADIR%%/templates/es/list-available-printers.tmpl
%%DATADIR%%/templates/es/maintenance.tmpl
%%DATADIR%%/templates/es/modify-class.tmpl
%%DATADIR%%/templates/es/modify-printer.tmpl
@@ -349,6 +351,8 @@ sbin/reject
%%DATADIR%%/templates/es/search.tmpl
%%DATADIR%%/templates/es/set-printer-options-header.tmpl
%%DATADIR%%/templates/es/set-printer-options-trailer.tmpl
+%%DATADIR%%/templates/es/subscription-added.tmpl
+%%DATADIR%%/templates/es/subscription-canceled.tmpl
%%DATADIR%%/templates/es/test-page.tmpl
%%DATADIR%%/templates/es/trailer.tmpl
%%DATADIR%%/templates/es/users.tmpl
@@ -952,9 +956,11 @@ sbin/reject
%%DOCSDIR%%/es/images/button-accept-jobs.gif
%%DOCSDIR%%/es/images/button-add-class.gif
%%DOCSDIR%%/es/images/button-add-printer.gif
+%%DOCSDIR%%/es/images/button-add-rss-subscription.gif
%%DOCSDIR%%/es/images/button-add-this-printer.gif
%%DOCSDIR%%/es/images/button-cancel-all-jobs.gif
%%DOCSDIR%%/es/images/button-cancel-job.gif
+%%DOCSDIR%%/es/images/button-cancel-subscription.gif
%%DOCSDIR%%/es/images/button-change-settings.gif
%%DOCSDIR%%/es/images/button-clean-print-heads.gif
%%DOCSDIR%%/es/images/button-clear.gif
@@ -963,6 +969,7 @@ sbin/reject
%%DOCSDIR%%/es/images/button-delete-printer.gif
%%DOCSDIR%%/es/images/button-edit-configuration-file.gif
%%DOCSDIR%%/es/images/button-export-samba.gif
+%%DOCSDIR%%/es/images/button-find-new-printers.gif
%%DOCSDIR%%/es/images/button-help.gif
%%DOCSDIR%%/es/images/button-hold-job.gif
%%DOCSDIR%%/es/images/button-manage-classes.gif
@@ -1295,6 +1302,8 @@ sbin/reject
%%DOCSDIR%%/images/printer-idle.gif
%%DOCSDIR%%/images/printer-processing.gif
%%DOCSDIR%%/images/printer-stopped.gif
+%%DOCSDIR%%/images/raster.png
+%%DOCSDIR%%/images/raster.svg
%%DOCSDIR%%/images/smiley.jpg
%%DOCSDIR%%/images/tab-left.gif
%%DOCSDIR%%/images/tab-right.gif
@@ -1589,7 +1598,6 @@ share/locale/no/cups_no.po
share/locale/pl/cups_pl.po
share/locale/pt/cups_pt.po
share/locale/pt_BR/cups_pt_BR.po
-share/locale/pt_PT/cups_pt_PT.po
share/locale/ru/cups_ru.po
share/locale/sv/cups_sv.po
share/locale/zh/cups_zh.po
@@ -1612,7 +1620,6 @@ share/locale/zh_TW/cups_zh_TW.po
@exec mkdir -p %D/%%DOCSDIR%%/no/images
@exec mkdir -p %D/%%DOCSDIR%%/pt/images
@exec mkdir -p %D/%%DOCSDIR%%/pt_BR/images
-@exec mkdir -p %D/%%DOCSDIR%%/pt_PT/images
@exec mkdir -p %D/%%DOCSDIR%%/ru/images
@exec mkdir -p %D/%%DOCSDIR%%/zh/images
@dirrm %%DOCSDIR%%/zh_TW/images
@@ -1623,8 +1630,6 @@ share/locale/zh_TW/cups_zh_TW.po
@dirrm %%DOCSDIR%%/sv
@dirrm %%DOCSDIR%%/ru/images
@dirrm %%DOCSDIR%%/ru
-@dirrm %%DOCSDIR%%/pt_PT/images
-@dirrm %%DOCSDIR%%/pt_PT
@dirrm %%DOCSDIR%%/pt_BR/images
@dirrm %%DOCSDIR%%/pt_BR
@dirrm %%DOCSDIR%%/pt/images
@@ -1665,14 +1670,12 @@ share/locale/zh_TW/cups_zh_TW.po
@exec mkdir -p %D/%%DATADIR%%/templates/no
@exec mkdir -p %D/%%DATADIR%%/templates/pt
@exec mkdir -p %D/%%DATADIR%%/templates/pt_BR
-@exec mkdir -p %D/%%DATADIR%%/templates/pt_PT
@exec mkdir -p %D/%%DATADIR%%/templates/ru
@exec mkdir -p %D/%%DATADIR%%/templates/zh
@dirrm %%DATADIR%%/templates/zh_TW
@dirrm %%DATADIR%%/templates/zh
@dirrm %%DATADIR%%/templates/ru
@dirrm %%DATADIR%%/templates/sv
-@dirrm %%DATADIR%%/templates/pt_PT
@dirrm %%DATADIR%%/templates/pt_BR
@dirrm %%DATADIR%%/templates/pt
@dirrm %%DATADIR%%/templates/pl
diff --git a/print/cups/Makefile b/print/cups/Makefile
index c7fd1bd2fb84..39010f82fb22 100644
--- a/print/cups/Makefile
+++ b/print/cups/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= cups
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.3
CATEGORIES= print
MASTER_SITES= # empty
DISTFILES= # empty