aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-06-30 21:08:46 +0000
committerSteve Wills <swills@FreeBSD.org>2017-06-30 21:08:46 +0000
commit2342c42b525fd3b7f1d3fbbdf88baf9d692ffe58 (patch)
treed86e870612e56cfc544c2728fa2ec28a8c04fa57
parente8aa9c7dc792aa16281cceb01ee94577328c0b48 (diff)
downloadports-2342c42b525fd3b7f1d3fbbdf88baf9d692ffe58.tar.gz
ports-2342c42b525fd3b7f1d3fbbdf88baf9d692ffe58.zip
Notes
-rw-r--r--databases/Makefile1
-rw-r--r--databases/timescaledb/Makefile28
-rw-r--r--databases/timescaledb/distinfo3
-rw-r--r--databases/timescaledb/pkg-descr4
-rw-r--r--databases/timescaledb/pkg-message4
5 files changed, 40 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b05b841e0eaa..9a444923bd88 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -994,6 +994,7 @@
SUBDIR += tdb
SUBDIR += tdbc
SUBDIR += tile38
+ SUBDIR += timescaledb
SUBDIR += tinycdb
SUBDIR += tokyocabinet
SUBDIR += tokyotyrant
diff --git a/databases/timescaledb/Makefile b/databases/timescaledb/Makefile
new file mode 100644
index 000000000000..76e850d21627
--- /dev/null
+++ b/databases/timescaledb/Makefile
@@ -0,0 +1,28 @@
+# Created by: Kevin Bowling <kbowling@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= timescaledb
+PORTVERSION= 0.1.0
+CATEGORIES= databases
+
+MAINTAINER= kbowling@FreeBSD.org
+COMMENT= Time-series database built on PostgreSQL
+
+LICENSE= APACHE20
+
+USE_GITHUB= YES
+GH_ACCOUNT= timescale
+
+MAKE_ARGS= PG_CONFIG=${LOCALBASE}/bin/pg_config USE_PGXS=1 \
+ install_bin=/usr/bin/install
+USE_LDCONFIG= yes
+USES= gmake pgsql:9.6
+
+PLIST_FILES= lib/postgresql/timescaledb.so \
+ share/postgresql/extension/timescaledb--0.1.0.sql \
+ share/postgresql/extension/timescaledb.control
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/timescaledb.so
+
+.include <bsd.port.mk>
diff --git a/databases/timescaledb/distinfo b/databases/timescaledb/distinfo
new file mode 100644
index 000000000000..057f3a937ad6
--- /dev/null
+++ b/databases/timescaledb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1498714123
+SHA256 (timescale-timescaledb-0.1.0_GH0.tar.gz) = 32ae4548ccbc1baae675c1a20f07495c772686ed3413e28d589250962ba71186
+SIZE (timescale-timescaledb-0.1.0_GH0.tar.gz) = 112651
diff --git a/databases/timescaledb/pkg-descr b/databases/timescaledb/pkg-descr
new file mode 100644
index 000000000000..08331bfb0ce3
--- /dev/null
+++ b/databases/timescaledb/pkg-descr
@@ -0,0 +1,4 @@
+An open-source time-series database optimized for fast ingest and complex
+queries built on PostgreSQL.
+
+WWW: http://www.timescale.com/
diff --git a/databases/timescaledb/pkg-message b/databases/timescaledb/pkg-message
new file mode 100644
index 000000000000..c9225f41f4a0
--- /dev/null
+++ b/databases/timescaledb/pkg-message
@@ -0,0 +1,4 @@
+To activate timescaledb on your PostgreSQL server, add 'timescaledb' to
+shared_preload_libraries in $PGDATA/postgresql.conf. For every database,
+run
+ CREATE EXTENSION IF NOT EXISTS timescaledb CASCADE;