aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-11-03 22:40:07 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-11-03 22:40:07 +0000
commit3be5f33199c190c5d55f1e4a41a65e3e1f4d080d (patch)
treef6afc825d9f74f7d023e053a35a919e9f82d4d6f
parent4cd777dc8ba3fad50de79688f577fdd15d60df64 (diff)
downloadports-3be5f33199c190c5d55f1e4a41a65e3e1f4d080d.tar.gz
ports-3be5f33199c190c5d55f1e4a41a65e3e1f4d080d.zip
Notes
-rw-r--r--audio/liboggz/Makefile8
-rw-r--r--databases/p5-GDBM/Makefile8
-rw-r--r--mail/fdm/Makefile4
-rw-r--r--sysutils/unieject/Makefile1
4 files changed, 17 insertions, 4 deletions
diff --git a/audio/liboggz/Makefile b/audio/liboggz/Makefile
index c4361cdd4124..e022ed3d7db9 100644
--- a/audio/liboggz/Makefile
+++ b/audio/liboggz/Makefile
@@ -27,4 +27,10 @@ post-patch:
@${REINPLACE_CMD} -e '/^install-data-am/s!install-data-local!!' ${WRKSRC}/doc/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-GDBM/Makefile b/databases/p5-GDBM/Makefile
index 42742be9bea1..edfaf6bc0988 100644
--- a/databases/p5-GDBM/Makefile
+++ b/databases/p5-GDBM/Makefile
@@ -29,4 +29,10 @@ MAN3= GDBM_File.3
post-patch:
@${REINPLACE_CMD} -e '/MAN3PODS/s|.*||' ${WRKSRC}/Makefile.PL
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl from ports. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/fdm/Makefile b/mail/fdm/Makefile
index e5af1fbc22ae..3846a55eec59 100644
--- a/mail/fdm/Makefile
+++ b/mail/fdm/Makefile
@@ -30,8 +30,8 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not compile on 4.x
+.if ${OSVERSION} < 601000
+BROKEN= needs strtonum(3)
.endif
.include <bsd.port.post.mk>
diff --git a/sysutils/unieject/Makefile b/sysutils/unieject/Makefile
index 4db33fa9998c..0ae78f6a21c2 100644
--- a/sysutils/unieject/Makefile
+++ b/sysutils/unieject/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= cdio.7:${PORTSDIR}/sysutils/libcdio \
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GETTEXT= yes
+USE_GCC= 3.4+
GNU_CONFIGURE= yes
MAN1= unieject.1
MAN5= unieject.conf.5