aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-04-02 04:21:05 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-04-02 04:21:05 +0000
commit6c69267bffe0ffd7489e23c455be8c655195a28f (patch)
tree2b49f8e9fa9a6fe9b67b6ef8b249019dc0e7a9a1
parentdd61c701b60f528e7faad9dd85eda44c49570f16 (diff)
downloadports-6c69267bffe0ffd7489e23c455be8c655195a28f.tar.gz
ports-6c69267bffe0ffd7489e23c455be8c655195a28f.zip
Notes
-rw-r--r--devel/p5-local-lib/Makefile7
-rw-r--r--devel/p5-local-lib/distinfo6
-rw-r--r--devel/p5-local-lib/files/patch-Makefile.PL30
-rw-r--r--devel/p5-local-lib/pkg-plist3
4 files changed, 33 insertions, 13 deletions
diff --git a/devel/p5-local-lib/Makefile b/devel/p5-local-lib/Makefile
index a1d85038ac32..08025bdaad4e 100644
--- a/devel/p5-local-lib/Makefile
+++ b/devel/p5-local-lib/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= local-lib
-PORTVERSION= 1.005001
+PORTVERSION= 1.006000
CATEGORIES= devel perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= ../../authors/id/A/AP/APEIRON
+MASTER_SITE_SUBDIR= ../../authors/id/M/MS/MSTROUT
PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
@@ -23,6 +23,7 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= local::lib.3
+MAN3= lib::core::only.3 \
+ local::lib.3
.include <bsd.port.mk>
diff --git a/devel/p5-local-lib/distinfo b/devel/p5-local-lib/distinfo
index 680ae544eb03..876fd79bd949 100644
--- a/devel/p5-local-lib/distinfo
+++ b/devel/p5-local-lib/distinfo
@@ -1,3 +1,3 @@
-MD5 (local-lib-1.005001.tar.gz) = 7aea1d6406d65e6dfae2794bb2e866ed
-SHA256 (local-lib-1.005001.tar.gz) = b020bf2e76a030631f58d1f89c96e97b1b3d1a3fa11b64ff0fe5c0d268ce33f7
-SIZE (local-lib-1.005001.tar.gz) = 35281
+MD5 (local-lib-1.006000.tar.gz) = 7f747899983ca9285569cea8f73bb6ba
+SHA256 (local-lib-1.006000.tar.gz) = abd6e24d2dc5187379a8f57c4b82f1e98b2edd1c78c8d26ee2fc9b8409627c03
+SIZE (local-lib-1.006000.tar.gz) = 36674
diff --git a/devel/p5-local-lib/files/patch-Makefile.PL b/devel/p5-local-lib/files/patch-Makefile.PL
index e76c0d449fdb..27632de558db 100644
--- a/devel/p5-local-lib/files/patch-Makefile.PL
+++ b/devel/p5-local-lib/files/patch-Makefile.PL
@@ -1,6 +1,6 @@
---- Makefile.PL.orig 2009-06-18 07:54:34.000000000 +0900
-+++ Makefile.PL 2009-06-18 07:56:03.000000000 +0900
-@@ -125,17 +125,17 @@
+--- Makefile.PL.orig 2010-03-31 23:38:43.000000000 +0900
++++ Makefile.PL 2010-04-02 07:39:02.544869533 +0900
+@@ -201,25 +201,25 @@
# otherwise, if we're running from CPAN then it will be installed soon
# enough, and we'll come back here..
if (!$@) {
@@ -8,19 +8,35 @@
+ #CPAN::HandleConfig->load;
for my $eumm_setting ( qw/makepl_arg make_install_arg/ ) {
- if ($CPAN::Config->{$eumm_setting} =~ /(?:PREFIX|INSTALL_BASE)/) {
-- die "Possibly invalid config detected in $eumm_setting: " . $CPAN::Config->{$eumm_setting};
+- die <<"DEATH";
+-WHOA THERE! It looks like you've got $CPAN::Config->{$eumm_setting} set. This is
+-known to cause problems with local::lib. Please either remove this setting or
+-clear out your .cpan directory.
+-DEATH
- }
+# if ($CPAN::Config->{$eumm_setting} =~ /(?:PREFIX|INSTALL_BASE)/) {
-+# die "Possibly invalid config detected in $eumm_setting: " . $CPAN::Config->{$eumm_setting};
++# die <<"DEATH";
++#WHOA THERE! It looks like you've got $CPAN::Config->{$eumm_setting} set. This is
++#known to cause problems with local::lib. Please either remove this setting or
++#clear out your .cpan directory.
++#DEATH
+# }
}
for my $mb_setting (qw/mbuild_arg mbuild_install_arg mbuildpl_arg/) {
- if ($CPAN::Config->{$mb_setting} =~ /(?:--prefix|--install_base)/) {
-- die "Possibly invalid config detected in $mb_setting: " . $CPAN::Config->{$mb_setting};
+- die <<"DEATH";
+-WHOA THERE! It looks like you've got $CPAN::Config->{$mb_setting} set. This is
+-known to cause problems with local::lib. Please either remove this setting or
+-clear out your .cpan directory.
+-DEATH
- }
+# if ($CPAN::Config->{$mb_setting} =~ /(?:--prefix|--install_base)/) {
-+# die "Possibly invalid config detected in $mb_setting: " . $CPAN::Config->{$mb_setting};
++# die <<"DEATH";
++#WHOA THERE! It looks like you've got $CPAN::Config->{$mb_setting} set. This is
++#known to cause problems with local::lib. Please either remove this setting or
++#clear out your .cpan directory.
++#DEATH
+# }
}
}
diff --git a/devel/p5-local-lib/pkg-plist b/devel/p5-local-lib/pkg-plist
index 61849fba33e1..7d3c9aedb97b 100644
--- a/devel/p5-local-lib/pkg-plist
+++ b/devel/p5-local-lib/pkg-plist
@@ -1,5 +1,8 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/local/lib/.packlist
+%%SITE_PERL%%/lib/core/only.pm
%%SITE_PERL%%/local/lib.pm
@dirrmtry %%SITE_PERL%%/local
+@dirrmtry %%SITE_PERL%%/lib/core
+@dirrmtry %%SITE_PERL%%/lib
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/local/lib
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/local