aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-10-25 16:15:36 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-10-25 16:15:36 +0000
commitce01f38cc12172b564306ef9b2251fe05a30a7bf (patch)
tree83b4013587b07ed88d138efdf4521d6c416b85c2
parenta54dcd491567251f0b06e6599b4b88b77ace1e49 (diff)
Notes
-rw-r--r--audio/sdl2_mixer/Makefile13
-rw-r--r--devel/sdl20/Makefile10
-rw-r--r--devel/sdl20/distinfo4
-rw-r--r--devel/sdl20/files/patch-cmake_sdlchecks.cmake32
-rw-r--r--devel/sdl20/pkg-plist5
-rw-r--r--graphics/sdl2_image/Makefile16
-rw-r--r--graphics/sdl2_ttf/Makefile13
-rw-r--r--net/sdl2_net/Makefile7
8 files changed, 37 insertions, 63 deletions
diff --git a/audio/sdl2_mixer/Makefile b/audio/sdl2_mixer/Makefile
index cf32948206a9..a8b83c73352e 100644
--- a/audio/sdl2_mixer/Makefile
+++ b/audio/sdl2_mixer/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sdl2_mixer
PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL2_mixer-${PORTVERSION}
@@ -13,7 +13,6 @@ COMMENT= A sample multi-channel audio mixer library
LICENSE= ZLIB
USES= gmake pathfix pkgconfig
-NO_STAGE= yes
USE_SDL= sdl2
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
@@ -37,14 +36,18 @@ MIKMOD_CONFIGURE_ENABLE= music-mod-mikmod
MODPLUG_LIB_DEPENDS= libmodplug.so:${PORTSDIR}/audio/libmodplug
MODPLUG_CONFIGURE_ENABLE= music-mod-modplug
-FLAC_LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac
+FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
FLAC_CONFIGURE_ENABLE= music-flac
-FLUIDSYNTH_LIB_DEPENDS= fluidsynth:${PORTSDIR}/audio/fluidsynth
+FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:${PORTSDIR}/audio/fluidsynth
FLUIDSYNTH_CONFIGURE_ON= --enable-music-midi --enable-music-midi-fluidsynth
FLUIDSYNTH_CONFIGURE_OFF= --disable-music-midi --disable-music-midi-fluidsynth
-VORBIS_LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis
+VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
VORBIS_CONFIGURE_ENABLE= music-ogg
+post-patch:
+ @${REINPLACE_CMD} -e 's|$(prefix)/libdata/pkgconfig|$(DESTDIR)$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/devel/sdl20/Makefile b/devel/sdl20/Makefile
index 58218285a78a..7d9bb3dda20d 100644
--- a/devel/sdl20/Makefile
+++ b/devel/sdl20/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= sdl2
-PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTVERSION= 2.0.1
CATEGORIES= devel
MASTER_SITES= http://www.libsdl.org/release/
DISTNAME= SDL2-${PORTVERSION}
@@ -10,6 +9,8 @@ DISTNAME= SDL2-${PORTVERSION}
MAINTAINER= mva@FreeBSD.org
COMMENT= Cross-platform multimedia development API
+LICENSE= ZLIB
+
USES= pathfix cmake:outsource iconv
USE_LDCONFIG= yes
@@ -52,7 +53,6 @@ SDL_VIDEO_DESC= Eanble the SDL Video subsystem
VIDEO_OPENGL_DESC= OpenGL rendering support
VIDEO_X11_DESC= X11 rendering support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MALSA}
@@ -60,7 +60,7 @@ NO_STAGE= yes
IGNORE= option ALSA requires SDL_AUDIO
.endif
CMAKE_ARGS+= -DALSA:BOOL=ON -DALSA_SHARED:BOOL=ON
-LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= libasound.so:${PORTSDIR}/audio/alsa-lib
.else
CMAKE_ARGS+= -DALSA:BOOL=OFF
.endif
@@ -100,7 +100,7 @@ CMAKE_ARGS+= -DMMX:BOOL=OFF -D3DNOW:BOOL=OFF
IGNORE= option NAS requires SDL_AUDIO
.endif
CMAKE_ARGS+= -DNAS:BOOL=ON
-LIB_DEPENDS+= audio:${PORTSDIR}/audio/nas
+LIB_DEPENDS+= libaudio.so:${PORTSDIR}/audio/nas
.else
CMAKE_ARGS+= -DNAS:BOOL=OFF
.endif
diff --git a/devel/sdl20/distinfo b/devel/sdl20/distinfo
index b24ef4d904e2..dfcc01c5f954 100644
--- a/devel/sdl20/distinfo
+++ b/devel/sdl20/distinfo
@@ -1,2 +1,2 @@
-SHA256 (SDL2-2.0.0.tar.gz) = 6f6ac8153d90e06a118474d5400624ae82b3d3e080915505db27cebc52b27178
-SIZE (SDL2-2.0.0.tar.gz) = 3623960
+SHA256 (SDL2-2.0.1.tar.gz) = 0ae7e902a26777614a011fe7053ca7e8b14843db3c42ca117564d208cf6732f0
+SIZE (SDL2-2.0.1.tar.gz) = 3660224
diff --git a/devel/sdl20/files/patch-cmake_sdlchecks.cmake b/devel/sdl20/files/patch-cmake_sdlchecks.cmake
deleted file mode 100644
index e207adcc8ff5..000000000000
--- a/devel/sdl20/files/patch-cmake_sdlchecks.cmake
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -r 6a145dedc972 cmake/sdlchecks.cmake
---- cmake/sdlchecks.cmake Sat Sep 14 11:25:52 2013 -0700
-+++ cmake/sdlchecks.cmake Sun Sep 22 10:16:09 2013 +0200
-@@ -304,6 +304,11 @@
- endif()
- endforeach()
-
-+ find_path(X_INCLUDEDIR X11/Xlib.h)
-+ if(X_INCLUDEDIR)
-+ set(X_CFLAGS "-I${X_INCLUDEDIR}")
-+ endif()
-+
- check_include_file(X11/Xcursor/Xcursor.h HAVE_XCURSOR_H)
- check_include_file(X11/extensions/Xinerama.h HAVE_XINERAMA_H)
- check_include_file(X11/extensions/XInput2.h HAVE_XINPUT_H)
-@@ -345,6 +350,7 @@
- endif(HAVE_SHMAT)
- if(NOT HAVE_SHMAT)
- add_definitions(-DNO_SHARED_MEMORY)
-+ set(X_CFLAGS "${X_CFLAGS} -DNO_SHARED_MEMORY")
- endif(NOT HAVE_SHMAT)
- endif(NOT HAVE_SHMAT)
-
-@@ -367,6 +373,8 @@
- endif(HAVE_X11_SHARED)
- endif(X11_SHARED)
-
-+ set(SDL_CFLAGS "${SDL_CFLAGS} ${X_CFLAGS}")
-+
- set(CMAKE_REQUIRED_LIBRARIES ${X11_LIB} ${X11_LIB})
- check_c_source_compiles("
- #include <X11/Xlib.h>
diff --git a/devel/sdl20/pkg-plist b/devel/sdl20/pkg-plist
index 31c9d8844290..fdf6257277ec 100644
--- a/devel/sdl20/pkg-plist
+++ b/devel/sdl20/pkg-plist
@@ -20,6 +20,7 @@ include/SDL2/SDL_cpuinfo.h
include/SDL2/SDL_endian.h
include/SDL2/SDL_error.h
include/SDL2/SDL_events.h
+include/SDL2/SDL_filesystem.h
include/SDL2/SDL_gamecontroller.h
include/SDL2/SDL_gesture.h
include/SDL2/SDL_haptic.h
@@ -75,8 +76,8 @@ share/aclocal/sdl2.m4
lib/libSDL2.a
lib/libSDL2.so
lib/libSDL2-2.0.so
-lib/libSDL2-2.0.so.0
-lib/libSDL2-2.0.so.0.0.0
+lib/libSDL2-2.0.so.1
+lib/libSDL2-2.0.so.1.0.1
lib/libSDL2main.a
libdata/pkgconfig/sdl2.pc
@dirrm include/SDL2
diff --git a/graphics/sdl2_image/Makefile b/graphics/sdl2_image/Makefile
index b60c34f07c51..9b4d957d4aa7 100644
--- a/graphics/sdl2_image/Makefile
+++ b/graphics/sdl2_image/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sdl2_image
PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
DISTNAME= SDL2_image-${PORTVERSION}
@@ -10,19 +10,19 @@ DISTNAME= SDL2_image-${PORTVERSION}
MAINTAINER= mva@FreeBSD.org
COMMENT= A simple library to load images of various formats as SDL surfaces
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- webp:${PORTSDIR}/graphics/webp
+LICENSE= ZLIB
-USES= pkgconfig:build pathfix
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libwebp.so:${PORTSDIR}/graphics/webp
+
+USES= pkgconfig:build pathfix gmake
USE_AUTOTOOLS= libtool
USE_SDL= sdl2
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lm
USE_LDCONFIG= yes
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/graphics/sdl2_ttf/Makefile b/graphics/sdl2_ttf/Makefile
index 206bacdfff8d..b5e544e3a3e6 100644
--- a/graphics/sdl2_ttf/Makefile
+++ b/graphics/sdl2_ttf/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sdl2_ttf
PORTVERSION= 2.0.12
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_ttf/release/
DISTNAME= SDL2_ttf-${PORTVERSION}
@@ -9,12 +10,13 @@ DISTNAME= SDL2_ttf-${PORTVERSION}
MAINTAINER= mva@FreeBSD.org
COMMENT= A library to use TrueType fonts to render text in SDL applications
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
+LICENSE= ZLIB
-USES= pkgconfig:build pathfix
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+
+USES= pkgconfig:build pathfix gmake
USE_SDL= sdl2
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -22,7 +24,6 @@ USE_LDCONFIG= yes
OPTIONS_DEFINE= OPENGL
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENGL}
@@ -30,7 +31,7 @@ USE_GL= yes
.endif
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/.libs/glfont ${PREFIX}/bin/sdl2-glfont
- ${INSTALL_PROGRAM} ${WRKSRC}/.libs/showfont ${PREFIX}/bin/sdl2-showfont
+ ${INSTALL_PROGRAM} ${WRKSRC}/.libs/glfont ${STAGEDIR}${PREFIX}/bin/sdl2-glfont
+ ${INSTALL_PROGRAM} ${WRKSRC}/.libs/showfont ${STAGEDIR}${PREFIX}/bin/sdl2-showfont
.include <bsd.port.mk>
diff --git a/net/sdl2_net/Makefile b/net/sdl2_net/Makefile
index b4da29d835a5..d19717eb8ea1 100644
--- a/net/sdl2_net/Makefile
+++ b/net/sdl2_net/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sdl2_net
PORTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.libsdl.org/projects/SDL_net/release/
DISTNAME= SDL2_net-${PORTVERSION}
@@ -9,14 +10,14 @@ DISTNAME= SDL2_net-${PORTVERSION}
MAINTAINER= mva@FreeBSD.org
COMMENT= A small sample cross-platform networking library
+LICENSE= ZLIB
+
USE_AUTOTOOLS= libtool
USE_SDL= sdl2
-USES= pathfix pkgconfig:build
-USE_GMAKE= yes
+USES= pathfix pkgconfig:build gmake
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS+=--disable-gui
-NO_STAGE= yes
.include <bsd.port.mk>