aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-08-05 21:47:10 +0000
committerPatrick Li <pat@FreeBSD.org>2002-08-05 21:47:10 +0000
commite391fbaf7ca5b4785fd22da51223501d3ec53a3e (patch)
treebbbf5a0cf187a1303e17e3f66cce9b5399b9d837
parente231b42d6a44648134cfd6e9d1b11b2f4727b608 (diff)
downloadports-e391fbaf7ca5b4785fd22da51223501d3ec53a3e.tar.gz
ports-e391fbaf7ca5b4785fd22da51223501d3ec53a3e.zip
Add new port wmtunlo: A dockapp that displays a zooming 2D tunnel
PR: ports/41223 Submitted by: Adam Weinberger <adam@vectors.cx>
Notes
Notes: svn path=/head/; revision=64072
-rw-r--r--misc/Makefile1
-rw-r--r--misc/wmtunlo/Makefile33
-rw-r--r--misc/wmtunlo/distinfo1
-rw-r--r--misc/wmtunlo/files/patch-Makefile22
-rw-r--r--misc/wmtunlo/pkg-comment1
-rw-r--r--misc/wmtunlo/pkg-descr6
-rw-r--r--misc/wmtunlo/pkg-plist7
7 files changed, 71 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 87f52b0959e6..e50dfcf15aa8 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -305,6 +305,7 @@
SUBDIR += wmpal
SUBDIR += wmproxyper
SUBDIR += wmstock
+ SUBDIR += wmtunlo
SUBDIR += wmweather
SUBDIR += wmwork
SUBDIR += wmx10
diff --git a/misc/wmtunlo/Makefile b/misc/wmtunlo/Makefile
new file mode 100644
index 000000000000..b718fde55885
--- /dev/null
+++ b/misc/wmtunlo/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: wmtunlo
+# Date created: 27 July 2002
+# Whom: Adam Weinberger <adam@vectors.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmtunlo
+PORTVERSION= 0.1.1
+CATEGORIES= misc windowmaker
+MASTER_SITES= http://clay.ll.pl/download/
+
+MAINTAINER= adam@vectors.cx
+
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+post-patch:
+.for i in 1 2 3 4 5
+ @${REINPLACE_CMD} -e 's|./wmtunlo|${PREFIX}/bin/wmtunlo|g' \
+ ${WRKSRC}/example${i}
+.endfor
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/wmtunlo ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+.for i in 1 2 3 4 5
+ @${INSTALL_SCRIPT} ${WRKSRC}/example${i} \
+ ${EXAMPLESDIR}/wmtunlo.example${i}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/misc/wmtunlo/distinfo b/misc/wmtunlo/distinfo
new file mode 100644
index 000000000000..2f3fc4d72ff9
--- /dev/null
+++ b/misc/wmtunlo/distinfo
@@ -0,0 +1 @@
+MD5 (wmtunlo-0.1.1.tar.gz) = b42e51207da0d483dec02e2b7a7ba117
diff --git a/misc/wmtunlo/files/patch-Makefile b/misc/wmtunlo/files/patch-Makefile
new file mode 100644
index 000000000000..97161b5eca84
--- /dev/null
+++ b/misc/wmtunlo/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Sat Jul 20 04:32:12 2002
++++ Makefile Sat Jul 27 02:18:29 2002
+@@ -1,14 +1,15 @@
+
+ wmTunlo: wmtunlo.o wmgeneral.o
+- gcc wmgeneral.o wmtunlo.o -o wmtunlo -L/usr/X11R6/lib -lXpm -lX11 -lXext -lm
++ ${CC} wmgeneral.o wmtunlo.o -o wmtunlo \
++ -L${X11BASE}/lib -lXpm -lX11 -lXext -lm
+
+ wmtunlo.o: wmtunlo.c wmgeneral.c wmgeneral.h dock-master.xpm dock-mask.xbm
+- gcc -O3 -Wall -c wmtunlo.c
++ ${CC} $(CFLAGS) -c wmtunlo.c -I${X11BASE}/include
+
+ wmgeneral.o: wmgeneral.c wmgeneral.h
+- gcc -O3 -Wall -c wmgeneral.c -I/usr/X11R6/include/X11
++ ${CC} $(CFLAGS) -c wmgeneral.c -I${X11BASE}/include
+
+ clean:
+ rm -f *~ *.o wmtunlo
+
+-
++all: wmTunlo
diff --git a/misc/wmtunlo/pkg-comment b/misc/wmtunlo/pkg-comment
new file mode 100644
index 000000000000..d07b6b69ff46
--- /dev/null
+++ b/misc/wmtunlo/pkg-comment
@@ -0,0 +1 @@
+A bo(O)oooring 2d tunnel in wmaker dock
diff --git a/misc/wmtunlo/pkg-descr b/misc/wmtunlo/pkg-descr
new file mode 100644
index 000000000000..7663735cb544
--- /dev/null
+++ b/misc/wmtunlo/pkg-descr
@@ -0,0 +1,6 @@
+This is a WindowMaker dockapp that displays a zooming 2-D tunnel.
+The visualization is highly customizable, using 14 arguments. 5
+example customizations are provided as shell scripts, named
+wmtunlo.example1 through wmtunlo.example5.
+
+- Adam Weinberger adam@vectors.cx
diff --git a/misc/wmtunlo/pkg-plist b/misc/wmtunlo/pkg-plist
new file mode 100644
index 000000000000..85e1ed75fd1d
--- /dev/null
+++ b/misc/wmtunlo/pkg-plist
@@ -0,0 +1,7 @@
+bin/wmtunlo
+share/examples/wmtunlo/wmtunlo.example1
+share/examples/wmtunlo/wmtunlo.example2
+share/examples/wmtunlo/wmtunlo.example3
+share/examples/wmtunlo/wmtunlo.example4
+share/examples/wmtunlo/wmtunlo.example5
+@dirrm share/examples/wmtunlo