aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-10-31 01:25:31 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-10-31 01:25:31 +0000
commitf0c95bb34b085a69fb42f259f37f4ced510390ab (patch)
tree3eabfc16ea6e4d608c5a2403865ad97575bd6408
parentb67ef76469fd334a4080ca82454ffb4a5d3a0f7d (diff)
downloadports-f0c95bb34b085a69fb42f259f37f4ced510390ab.tar.gz
ports-f0c95bb34b085a69fb42f259f37f4ced510390ab.zip
Notes
-rw-r--r--chinese/mldonkey-core/Makefile8
-rw-r--r--chinese/mldonkey-core/files/patch-driverControlers.ml6
2 files changed, 6 insertions, 8 deletions
diff --git a/chinese/mldonkey-core/Makefile b/chinese/mldonkey-core/Makefile
index cd765ae9e72b..84f5ec36de15 100644
--- a/chinese/mldonkey-core/Makefile
+++ b/chinese/mldonkey-core/Makefile
@@ -13,14 +13,12 @@ CATEGORIES= chinese
MAINTAINER= piaip@csie.ntu.edu.tw
COMMENT= Client 'core' for MLDonkey with Traditional Chinese (Big5) support
-BROKEN= Fails to patch
-
WITHOUT_GUI= yes
MASTERDIR= ${.CURDIR}/../../net-p2p/mldonkey
EXTRA_PATCHES= ${.CURDIR}/files/patch-driverControlers.ml
-WRAPPERPREFIX= ${.CURDIR}/files/wrapper-prefix
-WRAPPER= ${WRKDIR}/wrapper.sh
+WRAPPERPREFIX= ${.CURDIR}/files/wrapper-prefix
+WRAPPER= ${WRKDIR}/wrapper.sh
# build our own wrapper script
post-patch-script:
@@ -31,4 +29,4 @@ post-patch-script:
# I know this will lead portlint to fail,
# but we have to do so.
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}tw-
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}tw-
diff --git a/chinese/mldonkey-core/files/patch-driverControlers.ml b/chinese/mldonkey-core/files/patch-driverControlers.ml
index c42ca67f565b..f113df98783b 100644
--- a/chinese/mldonkey-core/files/patch-driverControlers.ml
+++ b/chinese/mldonkey-core/files/patch-driverControlers.ml
@@ -5,8 +5,8 @@
+let iac_will_8bit = "\255\253\000"
- let iac_will_naws = "\255\253\031"
-
+ let iac_will_naws = "\255\253\031"
+
let user_reader o telnet sock nread =
@@ -348,7 +349,7 @@
@@ -14,7 +14,7 @@
telnet.telnet_iac <- false;
- let is_normal_char = i > 31 && i < 127 in
+ let is_normal_char = i > 31 (*&& i < 127*) in
-
+
if telnet.telnet_wait = 1 then begin
Buffer.add_char telnet.telnet_buffer c;
@@ -469,6 +470,7 @@