aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-07-05 18:22:32 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-07-05 18:22:32 +0000
commit1a651092680cbb8bc2f4f97eb233634439e2b804 (patch)
tree84584067311b0b8967aa3151548aeb9e913e0b5c
parent06f837722a8d22db8976112ee97a4cdea998676e (diff)
downloadports-1a651092680cbb8bc2f4f97eb233634439e2b804.tar.gz
ports-1a651092680cbb8bc2f4f97eb233634439e2b804.zip
Notes
-rw-r--r--x11-toolkits/Makefile2
-rw-r--r--x11-toolkits/py-wxPython-common/Makefile8
-rw-r--r--x11-toolkits/py-wxPython-common/pkg-plist4
-rw-r--r--x11-toolkits/py-wxPython28-common/Makefile3
-rw-r--r--x11-toolkits/py-wxPython28-common/pkg-plist3
-rw-r--r--x11-toolkits/py-wxPython28-unicode/Makefile1
-rw-r--r--x11-toolkits/py-wxPython28/Makefile54
-rw-r--r--x11-toolkits/py-wxPython28/pkg-plist3
-rw-r--r--x11-toolkits/py-wxPython30/Makefile69
-rw-r--r--x11-toolkits/py-wxPython30/distinfo2
-rw-r--r--x11-toolkits/py-wxPython30/files/patch-setup.py12
-rw-r--r--x11-toolkits/py-wxPython30/pkg-descr7
12 files changed, 126 insertions, 42 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 39133c929595..8481ee0aae3c 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -200,9 +200,11 @@
SUBDIR += py-traitsgui
SUBDIR += py-vte
SUBDIR += py-wax
+ SUBDIR += py-wxPython-common
SUBDIR += py-wxPython28
SUBDIR += py-wxPython28-common
SUBDIR += py-wxPython28-unicode
+ SUBDIR += py-wxPython30
SUBDIR += py-xlib
SUBDIR += qt4-declarative
SUBDIR += qt4-gui
diff --git a/x11-toolkits/py-wxPython-common/Makefile b/x11-toolkits/py-wxPython-common/Makefile
new file mode 100644
index 000000000000..79db0d145fa2
--- /dev/null
+++ b/x11-toolkits/py-wxPython-common/Makefile
@@ -0,0 +1,8 @@
+# $FreeBSD$
+WITH_WXVERSION_ONLY= yes
+
+MASTERDIR= ${.CURDIR}/../py-wxPython30
+
+PLIST= ${.CURDIR}/pkg-plist
+
+.include "${MASTERDIR}/Makefile"
diff --git a/x11-toolkits/py-wxPython-common/pkg-plist b/x11-toolkits/py-wxPython-common/pkg-plist
new file mode 100644
index 000000000000..168c937a154f
--- /dev/null
+++ b/x11-toolkits/py-wxPython-common/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/wx.pth
+%%PYTHON_SITELIBDIR%%/wxversion.py
+%%PYTHON_SITELIBDIR%%/wxversion.pyc
+%%PYTHON_SITELIBDIR%%/wxversion.pyo
diff --git a/x11-toolkits/py-wxPython28-common/Makefile b/x11-toolkits/py-wxPython28-common/Makefile
index 412c01a4dd2a..314b66fc686a 100644
--- a/x11-toolkits/py-wxPython28-common/Makefile
+++ b/x11-toolkits/py-wxPython28-common/Makefile
@@ -1,7 +1,7 @@
# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 3
+PORTREVISION= 4
WITH_COMMON_ONLY= yes
@@ -9,5 +9,4 @@ MASTERDIR= ${.CURDIR}/../py-wxPython28
PLIST= ${.CURDIR}/pkg-plist
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-toolkits/py-wxPython28-common/pkg-plist b/x11-toolkits/py-wxPython28-common/pkg-plist
index 6af49914e171..56488d580e85 100644
--- a/x11-toolkits/py-wxPython28-common/pkg-plist
+++ b/x11-toolkits/py-wxPython28-common/pkg-plist
@@ -1286,9 +1286,6 @@ include/wx-%%WX_VERSION%%/wx/wxPython/wxPython_int.h
%%PYTHON_SITELIBDIR%%/wxPython/demo/widgetTest.pyc
%%PYTHON_SITELIBDIR%%/wxPython/demo/widgetTest.pyo
%%PYTHON_SITELIBDIR%%/wxPython/demo/wxpdemo.ico
-%%PYTHON_SITELIBDIR%%/wxversion.py
-%%PYTHON_SITELIBDIR%%/wxversion.pyc
-%%PYTHON_SITELIBDIR%%/wxversion.pyo
@dirrm %%PYTHON_SITELIBDIR%%/wxPython/demo/snippets
@dirrm %%PYTHON_SITELIBDIR%%/wxPython/demo/dllwidget
@dirrm %%PYTHON_SITELIBDIR%%/wxPython/demo/data/locale/it/LC_MESSAGES
diff --git a/x11-toolkits/py-wxPython28-unicode/Makefile b/x11-toolkits/py-wxPython28-unicode/Makefile
index 0b4aec7e851e..138651b6bc49 100644
--- a/x11-toolkits/py-wxPython28-unicode/Makefile
+++ b/x11-toolkits/py-wxPython28-unicode/Makefile
@@ -5,5 +5,4 @@ WITH_WXPYTHON_UNICODE= yes
MASTERDIR= ${.CURDIR}/../py-wxPython28
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/x11-toolkits/py-wxPython28/Makefile b/x11-toolkits/py-wxPython28/Makefile
index 5dfaa9b49e89..4499368468ac 100644
--- a/x11-toolkits/py-wxPython28/Makefile
+++ b/x11-toolkits/py-wxPython28/Makefile
@@ -3,14 +3,14 @@
PORTNAME= wxPython
PORTVERSION= 2.8.12.1
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= x11-toolkits python
MASTER_SITES= SF/wxpython/wxPython/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PKGNAMESUFFIX= 28
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
-MAINTAINER= neal@nelson.name
+MAINTAINER= python@FreeBSD.org
COMMENT= Python bindings for the wxWidgets/GTK GUI toolkit
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl
@@ -18,11 +18,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl
WRKSRC= ${WRKDIR}/${DISTNAME}/wxPython
DIST_SUBDIR= python
-USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_SUB= PYTHON_VER=${PYTHON_VER}
-USES= gettext gmake pkgconfig
+USES= gettext gmake pkgconfig tar:bzip2
PYDISTUTILS_BUILDARGS= \
WX_CONFIG="${WX_CONFIG}" \
@@ -37,7 +36,6 @@ WXPORT= gtk2
CONFIGURE_ARGS+= --enable-aui
-NO_STAGE= yes
post-extract:
# only keep the scripts we need
@${RM} ${WRKSRC}/scripts/*.py
@@ -58,7 +56,7 @@ pre-configure:
post-build:
# Shared amongst ansi/unicode installations
.if defined(WITH_COMMON_ONLY)
-. for dir in demo wxversion
+. for dir in demo
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/${dir}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/${dir}
. endfor
@@ -79,7 +77,8 @@ PYDISTUTILS_BUILDARGS+= \
INSTALL_MULTIVERSION=1
.else
## These are shared
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/wxversion.py:${PORTSDIR}/x11-toolkits/py-wxPython28-common
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}wxPython28-common>0:${PORTSDIR}/x11-toolkits/py-wxPython28-common \
+ ${PYTHON_SITELIBDIR}/wxversion.py:${PORTSDIR}/x11-toolkits/py-wxPython-common
PYDISTUTILS_BUILDARGS+= \
NO_HEADERS=1 \
@@ -114,43 +113,32 @@ PYDISTUTILS_INSTALLARGS:= ${PYDISTUTILS_INSTALLARGS} ${PYDISTUTILS_BUILDARGS}
.if defined(WITH_COMMON_ONLY)
do-install:
# DEMO
- @${MKDIR} ${DEMO_DIR}
- @cd ${WRKSRC}/demo && ${COPYTREE_SHARE} . ${DEMO_DIR}
+ @${MKDIR} ${STAGEDIR}${DEMO_DIR}
+ cd ${WRKSRC}/demo && ${COPYTREE_SHARE} . ${STAGEDIR}${DEMO_DIR}
# header files
- @${MKDIR} ${PREFIX}/include/wx-${WX_VERSION}/wx/wxPython/i_files
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/wx-${WX_VERSION}/wx/wxPython/i_files
.for glob in *.i *.py
- @${INSTALL_DATA} ${WRKSRC}/src/${glob} \
- ${PREFIX}/include/wx-${WX_VERSION}/wx/wxPython/i_files
+ ${INSTALL_DATA} ${WRKSRC}/src/${glob} \
+ ${STAGEDIR}${PREFIX}/include/wx-${WX_VERSION}/wx/wxPython/i_files
.endfor
- @${INSTALL_DATA} ${WRKSRC}/include/wx/wxPython/*.h \
- ${PREFIX}/include/wx-${WX_VERSION}/wx/wxPython
+ ${INSTALL_DATA} ${WRKSRC}/include/wx/wxPython/*.h \
+ ${STAGEDIR}${PREFIX}/include/wx-${WX_VERSION}/wx/wxPython
# scripts
- @${INSTALL_SCRIPT} ${WRKSRC}/scripts/* ${PREFIX}/bin
-## wxversion
- @${MKDIR} ${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}
-# wxversion script
- @${INSTALL_DATA} ${WRKSRC}/wxversion/* \
- ${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}
+ @${INSTALL_SCRIPT} ${WRKSRC}/scripts/* ${STAGEDIR}${PREFIX}/bin
.endif # defined(WITH_COMMON_ONLY)
post-install:
.if !defined(WITH_COMMON_ONLY)
+ @${ECHO_CMD} "@unexec ${REINPLACE_CMD} -i '' -e '\,${WX_PYTHON_DIR}$$,d' ${PYTHON_SITELIBDIR}/wx.pth 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec echo ${WX_PYTHON_DIR} >> ${PYTHON_SITELIBDIR}/wx.pth 2>/dev/null || true" >> ${TMPPLIST}
# fix installation permissions
${CHMOD} -R a+rX \
- ${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}/${WX_PYTHON_DIR}
+ ${STAGEDIR}${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}/${WX_PYTHON_DIR}
# Remove unwanted .egg-info
- ${RM} -rf ${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}/wxPython_common-*.egg-info
- ${RM} -rf ${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}/${WX_PYTHON_DIR}/*.egg-info
-.endif
-##
-# wxversion wxPython available list
-##
-.if !defined(WITH_COMMON_ONLY)
-# add ansi/unicode to the available list
- @${ECHO_CMD} ${WX_PYTHON_DIR} >> \
- ${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}/wx.pth
- @${CHMOD} ${SHAREMODE} \
- ${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}/wx.pth
+ ${RM} -rf ${STAGEDIR}${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}/wxPython_common-*.egg-info
+ ${RM} -rf ${STAGEDIR}${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}/wx.pth
+ ${RM} -rf ${STAGEDIR}${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}/wxversion*
+ ${RM} -rf ${STAGEDIR}${PYTHON_SITELIBDIR:C@^${LOCALBASE}@${PREFIX}@}/${WX_PYTHON_DIR}/*.egg-info
.endif
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/py-wxPython28/pkg-plist b/x11-toolkits/py-wxPython28/pkg-plist
index 4cffd6c61a4c..a4e3ee6f0941 100644
--- a/x11-toolkits/py-wxPython28/pkg-plist
+++ b/x11-toolkits/py-wxPython28/pkg-plist
@@ -2545,6 +2545,3 @@
@dirrm %%PYTHON_SITELIBDIR%%/%%WX_PYTHON_DIR%%/wx/build
@dirrm %%PYTHON_SITELIBDIR%%/%%WX_PYTHON_DIR%%/wx
@dirrm %%PYTHON_SITELIBDIR%%/%%WX_PYTHON_DIR%%
-@exec echo %%WX_PYTHON_DIR%% >> %D/%%PYTHON_SITELIBDIR%%/wx.pth 2>/dev/null || true
-@exec chmod 0444 %D/%%PYTHON_SITELIBDIR%%/wx.pth 2>/dev/null || true
-@unexec sed -i '' -e /%%WX_PYTHON_DIR%%/d %D/%%PYTHON_SITELIBDIR%%/wx.pth; if [ ! -s %D/%%PYTHON_SITELIBDIR%%/wx.pth ]; then rm %D/%%PYTHON_SITELIBDIR%%/wx.pth; fi
diff --git a/x11-toolkits/py-wxPython30/Makefile b/x11-toolkits/py-wxPython30/Makefile
new file mode 100644
index 000000000000..f8ebbc49a964
--- /dev/null
+++ b/x11-toolkits/py-wxPython30/Makefile
@@ -0,0 +1,69 @@
+# $FreeBSD$
+
+PORTNAME= wxPython
+PORTVERSION= 3.0.0.0
+CATEGORIES= x11-toolkits python
+MASTER_SITES= SF/wxpython/wxPython/${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 30
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= GUI toolkit for the Python programming language
+
+DIST_SUBDIR= python
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/wxPython
+
+USES= tar:bzip2
+USE_PYTHON= yes
+
+.if defined(WITH_WXVERSION_ONLY)
+
+PKGNAMESUFFIX= -common
+
+PYTHON_PY3K_PLIST_HACK= yes
+
+do-build:
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/wxversion
+ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/wxversion
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/wxversion/wxversion.py* ${STAGEDIR}${PYTHON_SITELIBDIR}/
+ ${TOUCH} ${STAGEDIR}${PYTHON_SITELIBDIR}/wx.pth
+
+.else
+
+WXPORT= gtk2
+WX_PYTHON_DIR= wx-${WX_VERSION}-${WXPORT}
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wxPython-common>0:${PORTSDIR}/x11-toolkits/py-wxPython-common
+
+USES+= gettext pkgconfig
+USE_WX= 3.0
+WANT_UNICODE= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+PYDISTUTILS_BUILDARGS= WX_CONFIG="${WX_CONFIG}" \
+ WXPORT="${WXPORT}" \
+ NO_HEADERS=1 \
+ NO_SCRIPTS=1 \
+ INSTALL_MULTIVERSION=1
+PYDISTUTILS_CONFIGUREARGS+= ${PYDISTUTILS_BUILDARGS}
+PYDISTUTILS_INSTALLARGS+= ${PYDISTUTILS_BUILDARGS}
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,distutils\.command\.install\.install\),setuptools.command.install.install),g' \
+ -e 's,distutils\.command\.install$$,setuptools.command.install,g' \
+ -e 's,distutils\.command\.install\.install\.,setuptools.command.install.install.,g' \
+ ${WRKSRC}/config.py
+
+post-install:
+ @${ECHO_CMD} "@unexec ${REINPLACE_CMD} -i '' -e '\,${WX_PYTHON_DIR}$$,d' ${PYTHON_SITELIBDIR}/wx.pth 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec echo ${WX_PYTHON_DIR} >> ${PYTHON_SITELIBDIR}/wx.pth 2>/dev/null || true" >> ${TMPPLIST}
+
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-wxPython30/distinfo b/x11-toolkits/py-wxPython30/distinfo
new file mode 100644
index 000000000000..7d5ffcfcde8f
--- /dev/null
+++ b/x11-toolkits/py-wxPython30/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python/wxPython-src-3.0.0.0.tar.bz2) = af88695e820dd914e8375dc91ecb736f6fb605979bb38460ace61bbea494dc11
+SIZE (python/wxPython-src-3.0.0.0.tar.bz2) = 57831792
diff --git a/x11-toolkits/py-wxPython30/files/patch-setup.py b/x11-toolkits/py-wxPython30/files/patch-setup.py
new file mode 100644
index 000000000000..b8ed58859882
--- /dev/null
+++ b/x11-toolkits/py-wxPython30/files/patch-setup.py
@@ -0,0 +1,12 @@
+--- setup.py.orig 2014-06-23 12:08:27.268192923 -0300
++++ setup.py 2014-06-23 12:07:08.925198614 -0300
+ BUILD_OPTIONS = { 'build_base' : BUILD_BASE }
+@@ -1011,7 +1006,7 @@
+ if not PREP_ONLY:
+
+ if not EGGing:
+- if INSTALL_MULTIVERSION:
++ if False:
+ setup(name = 'wxPython-common',
+ version = VERSION,
+ description = DESCRIPTION,
diff --git a/x11-toolkits/py-wxPython30/pkg-descr b/x11-toolkits/py-wxPython30/pkg-descr
new file mode 100644
index 000000000000..027967687f5c
--- /dev/null
+++ b/x11-toolkits/py-wxPython30/pkg-descr
@@ -0,0 +1,7 @@
+wxPython is a GUI toolkit for the Python programming language. It allows Python
+programmers to create programs with a robust, highly functional graphical user
+interface, simply and easily. It is implemented as a Python extension module
+(native code) that wraps the popular wxWidgets cross platform GUI library, which
+is written in C++.
+
+WWW: http://www.wxpython.org