aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-31 22:58:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-31 22:58:51 +0000
commit304a74ffe92f4f14b1f69dd01876a970a3d9fa6a (patch)
treedc23dc1349fea9fc2fa6264ad3641f5f7217c73a
parentfb5eba2512bc14feadaa3e4f935b71a194c5e7a3 (diff)
import-pictures copies or moves pictures from one directory (for example
from a mounted camera) to another directory. You can choose date ranges from within to copy the images. For example you can just choose the pictures from one day of the event in one directory and after that you can move the other day into another directory. WWW: http://www.formorer.de/code/import-pictures/import-pictures.html PR: ports/123488 Submitted by: Alexander Kuehn
Notes
Notes: svn path=/head/; revision=214067
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/import-pictures/Makefile34
-rw-r--r--graphics/import-pictures/distinfo3
-rw-r--r--graphics/import-pictures/files/patch-Makefile9
-rw-r--r--graphics/import-pictures/pkg-descr7
-rw-r--r--graphics/import-pictures/pkg-plist3
6 files changed, 57 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 819edb58c972..539c74401f40 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -304,6 +304,7 @@
SUBDIR += imlib
SUBDIR += imlib2
SUBDIR += imlib2_loaders
+ SUBDIR += import-pictures
SUBDIR += inkscape
SUBDIR += intergif
SUBDIR += inventor
diff --git a/graphics/import-pictures/Makefile b/graphics/import-pictures/Makefile
new file mode 100644
index 000000000000..98d66aa8df93
--- /dev/null
+++ b/graphics/import-pictures/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: import-pictures
+# Date created: 7 May 2008
+# Whom: Alexander Kuehn
+#
+# $FreeBSD$
+#
+
+PORTNAME= import-pictures
+PORTVERSION= 1.4
+CATEGORIES= graphics
+MASTER_SITES= http://www.nagilum.org/unix/
+
+MAINTAINER= freebsd@nagilum.org
+COMMENT= Utility to copy/move pictures from a directory
+
+RUN_DEPENDS= p5-Image-ExifTool>=7.0:${PORTSDIR}/graphics/p5-Image-ExifTool \
+ p5-TimeDate>=1.10:${PORTSDIR}/devel/p5-TimeDate \
+ p5-Time-modules>=2006:${PORTSDIR}/devel/p5-Time-modules
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5= yes
+
+MAN1= import-pictures.1
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/import-pictures ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/import-pictures.1 ${MANPREFIX}/man/man1/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/import-pictures.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/import-pictures/distinfo b/graphics/import-pictures/distinfo
new file mode 100644
index 000000000000..893d35fad3c7
--- /dev/null
+++ b/graphics/import-pictures/distinfo
@@ -0,0 +1,3 @@
+MD5 (import-pictures-1.4.tar.bz2) = 35c199a39a757187b350a7faf85b4030
+SHA256 (import-pictures-1.4.tar.bz2) = 1769f6585c247badb889397f340be3e93764f664b5df798355879712ab449b30
+SIZE (import-pictures-1.4.tar.bz2) = 9670
diff --git a/graphics/import-pictures/files/patch-Makefile b/graphics/import-pictures/files/patch-Makefile
new file mode 100644
index 000000000000..845f725ab62f
--- /dev/null
+++ b/graphics/import-pictures/files/patch-Makefile
@@ -0,0 +1,9 @@
+--- ../../import-pictures-1.4/Makefile 2007-02-18 22:14:32.000000000 +0100
++++ Makefile 2008-05-07 10:38:19.000000000 +0200
+@@ -3,3 +3,6 @@
+
+
+ all: import-pictures.1 import-pictures.html
++
++install:
++
diff --git a/graphics/import-pictures/pkg-descr b/graphics/import-pictures/pkg-descr
new file mode 100644
index 000000000000..f74fc7d8c81e
--- /dev/null
+++ b/graphics/import-pictures/pkg-descr
@@ -0,0 +1,7 @@
+import-pictures copies or moves pictures from one directory (for example
+from a mounted camera) to another directory. You can choose date ranges from
+within to copy the images. For example you can just choose the pictures from
+one day of the event in one directory and after that you can move the other day
+into another directory.
+
+WWW: http://www.formorer.de/code/import-pictures/import-pictures.html
diff --git a/graphics/import-pictures/pkg-plist b/graphics/import-pictures/pkg-plist
new file mode 100644
index 000000000000..06b36bd10d93
--- /dev/null
+++ b/graphics/import-pictures/pkg-plist
@@ -0,0 +1,3 @@
+bin/import-pictures
+%%PORTDOCS%%%%DOCSDIR%%/import-pictures.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%