aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-03-21 02:22:05 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-03-21 02:22:05 +0000
commit37aa89307a6b78292288304bebb96af1cf611e15 (patch)
tree52f0c93918212ab038cf5a0be2ebb889715f64a8
parent7c0753983eda9f27f68c4196619eab60079fb385 (diff)
downloadports-37aa89307a6b78292288304bebb96af1cf611e15.tar.gz
ports-37aa89307a6b78292288304bebb96af1cf611e15.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Roles/Makefile26
-rw-r--r--devel/p5-Class-Roles/distinfo2
-rw-r--r--devel/p5-Class-Roles/pkg-descr7
-rw-r--r--devel/p5-Class-Roles/pkg-plist2
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1ce94265a339..fadd34d30b38 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -597,6 +597,7 @@
SUBDIR += p5-Class-ObjectTemplate-DB
SUBDIR += p5-Class-ParmList
SUBDIR += p5-Class-ReturnValue
+ SUBDIR += p5-Class-Roles
SUBDIR += p5-Class-Singleton
SUBDIR += p5-Class-Tangram
SUBDIR += p5-Class-Tom
diff --git a/devel/p5-Class-Roles/Makefile b/devel/p5-Class-Roles/Makefile
new file mode 100644
index 000000000000..9c0373355ccb
--- /dev/null
+++ b/devel/p5-Class-Roles/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Class-Roles
+# Date Created: 17 Feb, 2004
+# Whom: Alex Kapranoff <kappa@freebsd.org.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Roles
+PORTVERSION= 0.30
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@freebsd.org
+COMMENT= Provides a role-based system of OOP (emulates Perl6)
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Class::Roles.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Roles/distinfo b/devel/p5-Class-Roles/distinfo
new file mode 100644
index 000000000000..11201db7102a
--- /dev/null
+++ b/devel/p5-Class-Roles/distinfo
@@ -0,0 +1,2 @@
+MD5 (Class-Roles-0.30.tar.gz) = f9c3badc7aaf2c1af52e2d50f4a2a6b8
+SIZE (Class-Roles-0.30.tar.gz) = 6146
diff --git a/devel/p5-Class-Roles/pkg-descr b/devel/p5-Class-Roles/pkg-descr
new file mode 100644
index 000000000000..56a1779bd804
--- /dev/null
+++ b/devel/p5-Class-Roles/pkg-descr
@@ -0,0 +1,7 @@
+Class::Roles provides a Perl 5 implementation of Perl 6 roles.
+
+Roles are named collections of reusable behavior. They provide a
+mechanism to mark that a class performs certain behaviors and to reuse
+the code that performs those behaviors.
+
+WWW: http://search.cpan.org/dist/Class-Roles/
diff --git a/devel/p5-Class-Roles/pkg-plist b/devel/p5-Class-Roles/pkg-plist
new file mode 100644
index 000000000000..08aaf32ebbb4
--- /dev/null
+++ b/devel/p5-Class-Roles/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Class/Roles.pm
+@unexec rmdir %D/%%SITE_PERL%%/Class 2>/dev/null || true