aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-04-04 15:57:13 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-04-04 15:57:13 +0000
commit429c394555548022bea77b4375125a5a305d922a (patch)
treea9b0bb32c103e6672b39525b93fa28cafb10acdd
parent041a28e5218b8a640acb2be4c438c3d7b70afb9c (diff)
downloadports-429c394555548022bea77b4375125a5a305d922a.tar.gz
ports-429c394555548022bea77b4375125a5a305d922a.zip
Notes
-rw-r--r--graphics/p5-ming/Makefile8
-rw-r--r--irc/onis/Makefile8
-rw-r--r--irc/p5-IRC/Makefile12
-rw-r--r--japanese/kcode/Makefile10
-rw-r--r--japanese/wikicker/Makefile3
5 files changed, 6 insertions, 35 deletions
diff --git a/graphics/p5-ming/Makefile b/graphics/p5-ming/Makefile
index 442cb29e5bfa..ac6164e4f394 100644
--- a/graphics/p5-ming/Makefile
+++ b/graphics/p5-ming/Makefile
@@ -38,12 +38,6 @@ MAN3= SWF.3 \
SWF::TextField.3 \
SWF::VideoStream.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= Perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try again.
-.endif
-
post-patch:
@${ECHO_CMD} -n > ${WRKSRC}/../configure.in
@${LN} -sf ${LOCALBASE}/include/ming ${WRKSRC}/../src
@@ -54,4 +48,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/examples/*.* ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/onis/Makefile b/irc/onis/Makefile
index 4727a3e45b35..f2548ea2ce5f 100644
--- a/irc/onis/Makefile
+++ b/irc/onis/Makefile
@@ -16,16 +16,10 @@ COMMENT= A script that converts IRC logfiles into an HTML statistics page
NO_BUILD= YES
USE_PERL5= YES
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE=This port requires perl 5.6.x or later. Install lang/perl5 and try again.
-.endif
-
do-install:
@if [ ! -d ${DATADIR} ]; then \
${MKDIR} ${DATADIR}; \
fi
${CP} -R ${WRKSRC}/* ${DATADIR}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/p5-IRC/Makefile b/irc/p5-IRC/Makefile
index 903690fd3b80..ef0f89daefbb 100644
--- a/irc/p5-IRC/Makefile
+++ b/irc/p5-IRC/Makefile
@@ -22,14 +22,4 @@ MAN3= Net::Connection.3 \
Net::Event.3 \
Net::IRC.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Socket/INET.pm:${PORTSDIR}/devel/p5-IO
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Socket/INET.pm:${PORTSDIR}/devel/p5-IO
-post-patch:
- @${PERL} -pi -e '$$_ = "" if /(use|no) warnings/' ${WRKSRC}/EventQueue.pm
- @${PERL} -pi -e 's/^our (\S+);/use vars qw($$1);/' ${WRKSRC}/Event.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/kcode/Makefile b/japanese/kcode/Makefile
index f9874248516a..cb94ca119966 100644
--- a/japanese/kcode/Makefile
+++ b/japanese/kcode/Makefile
@@ -15,8 +15,6 @@ EXTRACT_ONLY= ${DISTFILES}
MAINTAINER= ports@FreeBSD.org
COMMENT= A handy utility to show codepoint information of given characters
-RUN_DEPENDS= ${_RUN_DEPENDS}
-
USE_PERL5= yes
NO_WRKSUBDIR= yes
@@ -28,12 +26,10 @@ MANCOMPRESSED= no
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-IGNORE= This port requires perl 5.6.0 or later
-.elif ${PERL_LEVEL} < 500800
-_RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
.else
-_RUN_DEPENDS= ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+RUN_DEPENDS= ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
.endif
do-extract:
diff --git a/japanese/wikicker/Makefile b/japanese/wikicker/Makefile
index 00c582ad39cc..fc28887902bd 100644
--- a/japanese/wikicker/Makefile
+++ b/japanese/wikicker/Makefile
@@ -46,9 +46,6 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-I
RUN_DEPENDS+= ${SITE_PERL}/DB_File/Lock.pm:${PORTSDIR}/devel/p5-DB_File-Lock
.endif
.if !defined(WITHOUT_WIKICKER_MEMCACHED)
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires Perl 5.6 or newer to run. Either install new Perl or define WITHOUT_WIKICKER_MEMCACHED
-.endif
RUN_DEPENDS+= ${SITE_PERL}/Cache/Memcached.pm:${PORTSDIR}/databases/p5-Cache-Memcached
.endif