aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-07-03 14:48:28 +0000
committerChris Rees <crees@FreeBSD.org>2011-07-03 14:48:28 +0000
commit4d5be5f77ffed1926d173fdcca6048ffec498194 (patch)
treed55a78d3af3bf46e381bcd8ba0ab22660e4549d2
parentbb40875b2da38677fc67cd008c37ddbe1354e6f0 (diff)
Notes
-rw-r--r--audio/shoutcast/Makefile5
-rw-r--r--audio/shoutcast/pkg-deinstall16
-rw-r--r--audio/shoutcast/pkg-install50
3 files changed, 2 insertions, 69 deletions
diff --git a/audio/shoutcast/Makefile b/audio/shoutcast/Makefile
index 7e6dcf7ca783..cc7d1546bbd1 100644
--- a/audio/shoutcast/Makefile
+++ b/audio/shoutcast/Makefile
@@ -21,6 +21,8 @@ RESTRICTED= Redistribution of the software is not allowed
CONFLICTS= linux-shoutcast-[0-9]*
+USERS= ${PORTNAME}
+GROUPS= ${USERS}
USE_RC_SUBR= shoutcast.sh
PORTDOCS= README.TXT
WRKSRC= ${WRKDIR}
@@ -46,7 +48,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}
.endif
-post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.mk>
diff --git a/audio/shoutcast/pkg-deinstall b/audio/shoutcast/pkg-deinstall
deleted file mode 100644
index 21bac56cda91..000000000000
--- a/audio/shoutcast/pkg-deinstall
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-if [ "$2" != "POST-DEINSTALL" ]; then
- exit 0
-fi
-
-SC_GROUP=shoutcast
-SC_USER=shoutcast
-SC_SHELL=/bin/sh
-SC_HOME=/nonexistent
-PW=/usr/sbin/pw
-
-pw groupdel shoutcast >/dev/null 2>&1
-pw userdel shoutcast >/dev/null 2>&1
-
-exit 0
diff --git a/audio/shoutcast/pkg-install b/audio/shoutcast/pkg-install
deleted file mode 100644
index 2b6c96b93a64..000000000000
--- a/audio/shoutcast/pkg-install
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/sh
-
-if [ "$2" != "POST-INSTALL" ]; then
- exit 0
-fi
-
-SC_GROUP=shoutcast
-SC_USER=shoutcast
-SC_SHELL=/bin/sh
-SC_HOME=/nonexistent
-PW="/usr/sbin/pw"
-
-if ! ${PW} show group ${SC_GROUP} -q >/dev/null; then
- gid=210
- while ${PW} show group -g ${gid} -q >/dev/null; do
- gid=`expr ${gid} + 1`
- done
- if ! ${PW} add group ${SC_GROUP} -g ${gid}; then
- e=$?
- echo "*** Failed to add group \`${SC_GROUP}'. Please add it manually."
- exit ${e}
- fi
- echo "*** Added group \`${SC_GROUP}' (id ${gid})"
-else
- gid=`${PW} show group ${SC_GROUP} 2>/dev/null | cut -d: -f3`
-fi
-
-if ! ${PW} show user ${SC_USER} -q >/dev/null; then
- uid=210
- while ${PW} show user -u ${uid} -q >/dev/null; do
- uid=`expr ${uid} + 1`
- done
- if ! ${PW} add user ${SC_USER} -u ${uid} -g ${gid} -d "${SC_HOME}" \
- -c "Shoutcast sandbox" -s "${SC_SHELL}" -p "*" \
- ; then
- e=$?
- echo "*** Failed to add user \`${SC_USER}'. Please add it manually."
- exit ${e}
- fi
- echo "*** Added user \`${SC_USER}' (id ${uid})"
-else
- if ! ${PW} mod user ${SC_USER} -g ${gid} -d "${SC_HOME}" \
- -c "Shoutcast sandbox" -s "${SC_SHELL}" -p "*" \
- ; then
- e=$?
- echo "*** Failed to update user \`${SC_USER}'."
- exit ${e}
- fi
- echo "*** Updated user \`${SC_USER}'."
-fi