aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-04-02 17:54:43 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-04-02 17:54:43 +0000
commit5382b797798cc96be201ca78248d644ac5b3b00a (patch)
treefe83ab31c4e9d97d9055c23592d46eae2d27198b
parent551fded38f17dae9a22c4621b1eee090e543099b (diff)
downloadports-5382b797798cc96be201ca78248d644ac5b3b00a.tar.gz
ports-5382b797798cc96be201ca78248d644ac5b3b00a.zip
Notes
-rw-r--r--chinese/p5-Lingua-ZH-Summarize/Makefile9
-rw-r--r--databases/WWWdb/Makefile10
-rw-r--r--databases/gnatsweb4/Makefile8
-rw-r--r--databases/mysql2pgsql/Makefile8
-rw-r--r--databases/p5-DBD-Excel/Makefile15
-rw-r--r--databases/p5-DBD-RAM/Makefile17
-rw-r--r--databases/p5-DBD-Sybase/Makefile14
-rw-r--r--databases/p5-DBI-Shell/Makefile19
-rw-r--r--databases/p5-DBIx-AnyDBD/Makefile15
-rw-r--r--databases/p5-DBIx-Password/Makefile15
-rw-r--r--databases/p5-DBIx-XML_RDB/Makefile15
-rw-r--r--databases/p5-Mysql/Makefile15
-rw-r--r--databases/p5-T2/Makefile8
-rw-r--r--deskutils/taskjuggler/Makefile4
-rw-r--r--devel/p5-Algorithm-MarkovChain/Makefile8
-rw-r--r--devel/p5-Devel-StealthDebug/Makefile9
-rw-r--r--devel/p5-File-Remove/Makefile8
-rw-r--r--devel/p5-VCP-autrijus/Makefile4
-rw-r--r--finance/p5-Business-WorldPay-Junior/Makefile15
-rw-r--r--french/plgrenouille/Makefile12
20 files changed, 45 insertions, 183 deletions
diff --git a/chinese/p5-Lingua-ZH-Summarize/Makefile b/chinese/p5-Lingua-ZH-Summarize/Makefile
index e7329f07ebf3..7c997ef89b99 100644
--- a/chinese/p5-Lingua-ZH-Summarize/Makefile
+++ b/chinese/p5-Lingua-ZH-Summarize/Makefile
@@ -23,11 +23,4 @@ PERL_CONFIGURE= yes
MAN3= Lingua::ZH::Summarize.3
-.include <bsd.port.pre.mk>
-
-# chinese/p5-Lingua-ZH-Toke needs 5.6.x
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/WWWdb/Makefile b/databases/WWWdb/Makefile
index 4350ecbdf545..0a5cbf639cc3 100644
--- a/databases/WWWdb/Makefile
+++ b/databases/WWWdb/Makefile
@@ -18,12 +18,6 @@ PERL_CONFIGURE= yes
MAN3= WWWdb::Base.3 WWWdb::DbSession.3 WWWdb::List.3 \
WWWdb::Session.3 WWWdb::Plugin.3 WWWdb::Hash.3 \
- WWWdb::HTML.3
+ WWWdb::HTML.3 WWWdb::ConfigFile.3 WWWdb::ConfigPool.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 500600
-MAN3+= WWWdb::ConfigFile.3 WWWdb::ConfigPool.3
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/gnatsweb4/Makefile b/databases/gnatsweb4/Makefile
index 3d52495f7306..dce9ce83aadd 100644
--- a/databases/gnatsweb4/Makefile
+++ b/databases/gnatsweb4/Makefile
@@ -54,10 +54,4 @@ do-install:
done
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-RUN_DEPENDS+= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/mysql2pgsql/Makefile b/databases/mysql2pgsql/Makefile
index c95d81218f4f..abc32c6aaf31 100644
--- a/databases/mysql2pgsql/Makefile
+++ b/databases/mysql2pgsql/Makefile
@@ -17,13 +17,7 @@ EXTRACT_ONLY= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert a MySQL dump to a PostgreSQL dump
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg-13
-.else
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
-.endif
PATCH_WRKSRC= ${WRKDIR}
PLIST_FILES= bin/mysql2pgsql
@@ -37,4 +31,4 @@ do-extract:
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/mysql2pgsql ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-Excel/Makefile b/databases/p5-DBD-Excel/Makefile
index 4aac2b6530b8..a39babad05e0 100644
--- a/databases/p5-DBD-Excel/Makefile
+++ b/databases/p5-DBD-Excel/Makefile
@@ -17,7 +17,8 @@ COMMENT= A class for DBI drivers that acts on Excel files
BUILD_DEPENDS= ${SITE_PERL}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement \
${SITE_PERL}/Spreadsheet/ParseExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-ParseExcel \
- ${SITE_PERL}/Spreadsheet/WriteExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-WriteExcel
+ ${SITE_PERL}/Spreadsheet/WriteExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-WriteExcel \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
EXAMPLESDIR?= ${PREFIX}/share/examples/${PORTNAME}
@@ -31,14 +32,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-RAM/Makefile b/databases/p5-DBD-RAM/Makefile
index bb09bb3bf7a4..40f4961d6982 100644
--- a/databases/p5-DBD-RAM/Makefile
+++ b/databases/p5-DBD-RAM/Makefile
@@ -16,21 +16,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= DBI driver for files and data structures
-BUILD_DEPENDS+= ${SITE_PERL}/DBD/File.pm:${PORTSDIR}/databases/p5-DBD-File
-RUN_DEPENDS+= ${SITE_PERL}/DBD/File.pm:${PORTSDIR}/databases/p5-DBD-File
+BUILD_DEPENDS= ${SITE_PERL}/DBD/File.pm:${PORTSDIR}/databases/p5-DBD-File \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= DBD::RAM.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-Sybase/Makefile b/databases/p5-DBD-Sybase/Makefile
index 6a73cbe86212..07593aa59db9 100644
--- a/databases/p5-DBD-Sybase/Makefile
+++ b/databases/p5-DBD-Sybase/Makefile
@@ -16,6 +16,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A Sybase DBI driver for Perl 5
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= ct.4:${PORTSDIR}/databases/freetds
PERL_CONFIGURE= yes
@@ -29,14 +31,4 @@ USE_GETTEXT= yes
MAN3= DBD::Sybase.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBI-Shell/Makefile b/databases/p5-DBI-Shell/Makefile
index 94984930210f..b13274855ba6 100644
--- a/databases/p5-DBI-Shell/Makefile
+++ b/databases/p5-DBI-Shell/Makefile
@@ -16,21 +16,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive command shell for the DBI
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS+= ${SITE_PERL}/Text/Reform.pm:${PORTSDIR}/textproc/p5-Text-Reform \
+ ${SITE_PERL}/IO/Tee.pm:${PORTSDIR}/devel/p5-IO-Tee
+
PERL_CONFIGURE= yes
MAN1= dbish.1
MAN3= DBI::Format.3 DBI::Format::SQLMinus.3 DBI::Shell.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-RUN_DEPENDS+= ${SITE_PERL}/Text/Reform.pm:${PORTSDIR}/textproc/p5-Text-Reform
-RUN_DEPENDS+= ${SITE_PERL}/IO/Tee.pm:${PORTSDIR}/devel/p5-IO-Tee
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-AnyDBD/Makefile b/databases/p5-DBIx-AnyDBD/Makefile
index 6e011cb42e5d..3969e46b5c3b 100644
--- a/databases/p5-DBIx-AnyDBD/Makefile
+++ b/databases/p5-DBIx-AnyDBD/Makefile
@@ -15,18 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= DBD independant class
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= DBIx::AnyDBD.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Password/Makefile b/databases/p5-DBIx-Password/Makefile
index e87fd77c9d1e..2b37eca5bacd 100644
--- a/databases/p5-DBIx-Password/Makefile
+++ b/databases/p5-DBIx-Password/Makefile
@@ -16,6 +16,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Allows you to create a global password file for DB passwords
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= DBIx::Password.3
@@ -24,14 +27,4 @@ MAN3= DBIx::Password.3
EXTRA_PATCHES+= ${FILESDIR}/batch.patch
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-XML_RDB/Makefile b/databases/p5-DBIx-XML_RDB/Makefile
index 67919fc38587..b54a1b24892b 100644
--- a/databases/p5-DBIx-XML_RDB/Makefile
+++ b/databases/p5-DBIx-XML_RDB/Makefile
@@ -15,21 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl extension for creating XML from existing DBI datasources
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= DBIx::XML_RDB.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-Mysql/Makefile b/databases/p5-Mysql/Makefile
index e33b6e033414..c5def43af3d4 100644
--- a/databases/p5-Mysql/Makefile
+++ b/databases/p5-Mysql/Makefile
@@ -16,7 +16,8 @@ DISTNAME= Msql-Mysql-modules-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl5 modules for accessing MySQL databases
-BUILD_DEPENDS= ${SITE_PERL}/Data/ShowTable.pm:${PORTSDIR}/devel/p5-Data-ShowTable
+BUILD_DEPENDS= ${SITE_PERL}/Data/ShowTable.pm:${PORTSDIR}/devel/p5-Data-ShowTable \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
CONFLICTS= p5-DBD-mysql-* p5-DBD-mysql4[0-9]-* p5-DBD-mysql5[0-9]-*
@@ -37,14 +38,4 @@ MAN3= Bundle::DBD::mysql.3 \
pre-configure:
@${PERL} -p -i -e 's| -lgz||' ${WRKSRC}/lib/DBD/mysql/Install.pm
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-T2/Makefile b/databases/p5-T2/Makefile
index 10f36bd82098..81f5587dc1e7 100644
--- a/databases/p5-T2/Makefile
+++ b/databases/p5-T2/Makefile
@@ -27,10 +27,4 @@ PERL_CONFIGURE= yes
MAN3= T2.3 T2::Association.3 T2::Attribute.3 T2::Class.3 \
T2::DBSetup.3 T2::Schema.3 T2::Storage.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires Perl 5.6 or newer. Install lang/perl5.8 and try again.
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/taskjuggler/Makefile b/deskutils/taskjuggler/Makefile
index cd535029ad0b..e5a0ddc21cfe 100644
--- a/deskutils/taskjuggler/Makefile
+++ b/deskutils/taskjuggler/Makefile
@@ -55,10 +55,6 @@ CONFIGURE_ARGS+=--with-kde-support=no
PLIST_SUB+= WITH_KDE="@comment "
.endif
-.if ${PERL_LEVEL} < 500600
-IGNORE= Perl > 5.6 is required
-.endif
-
.if defined(SESSION_MANAGER)
BROKEN= please unset SESSION_MANAGER
.endif
diff --git a/devel/p5-Algorithm-MarkovChain/Makefile b/devel/p5-Algorithm-MarkovChain/Makefile
index f6c2d1d3f6f9..7455e1dd680d 100644
--- a/devel/p5-Algorithm-MarkovChain/Makefile
+++ b/devel/p5-Algorithm-MarkovChain/Makefile
@@ -22,10 +22,4 @@ PERL_MODBUILD= yes
MAN3= Algorithm::MarkovChain.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= "needs at least perl 5.6.1 to build"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Devel-StealthDebug/Makefile b/devel/p5-Devel-StealthDebug/Makefile
index 409f29067172..9b93f178ecd5 100644
--- a/devel/p5-Devel-StealthDebug/Makefile
+++ b/devel/p5-Devel-StealthDebug/Makefile
@@ -23,11 +23,4 @@ INSTALL_TARGET= pure_install
MAN3= Devel::StealthDebug.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-post-patch:
- @${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' ${WRKSRC}/StealthDebug.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Remove/Makefile b/devel/p5-File-Remove/Makefile
index cd9b745ccb9f..fff03a4b4d69 100644
--- a/devel/p5-File-Remove/Makefile
+++ b/devel/p5-File-Remove/Makefile
@@ -20,10 +20,4 @@ PERL_CONFIGURE= YES
MAN3= File::Remove.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires File::Glob, which is only available in perl 5.6.0 or above
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-VCP-autrijus/Makefile b/devel/p5-VCP-autrijus/Makefile
index 98dac35a85e1..bbd4cf8482a5 100644
--- a/devel/p5-VCP-autrijus/Makefile
+++ b/devel/p5-VCP-autrijus/Makefile
@@ -38,10 +38,6 @@ RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
PERL_CONFIGURE= yes
-.if ${PERL_LEVEL} < 500600
-BROKEN= "Does not compile with perl ${PERL_VERSION}"
-.endif
-
MAN1= vcp.1
MAN3= RevML::Doctype.3 \
RevML::Writer.3 \
diff --git a/finance/p5-Business-WorldPay-Junior/Makefile b/finance/p5-Business-WorldPay-Junior/Makefile
index 8439e0cf662c..40693b709ff1 100644
--- a/finance/p5-Business-WorldPay-Junior/Makefile
+++ b/finance/p5-Business-WorldPay-Junior/Makefile
@@ -16,7 +16,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module to handle WorldPay Junior for payment services
BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+ ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -29,14 +30,4 @@ post-patch:
-e '$$_="" if /use warnings/;' \
${WRKSRC}/Junior.pm
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/french/plgrenouille/Makefile b/french/plgrenouille/Makefile
index 71f914a4d93b..b598a19f6443 100644
--- a/french/plgrenouille/Makefile
+++ b/french/plgrenouille/Makefile
@@ -17,14 +17,8 @@ COMMENT= Un client pour determiner votre bande passante a un raccordement large
LIB_DEPENDS= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
RUN_DEPENDS= ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-RUN_DEPENDS+= ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP3
-.else
-RUN_DEPENDS+= ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP
-.endif
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP
.if !defined(BATCH)
IS_INTERACTIVE= yes
@@ -84,4 +78,4 @@ post-install:
@${ECHO_MSG}
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>