aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-12 12:56:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-12 12:56:55 +0000
commit5435e516040233db1fccc87d5e2adf323b970022 (patch)
treed2b58f428410b1afbcb17433458ccf58b41a9898
parent55ba256801596fcb9eab9cf18947375277d8f689 (diff)
downloadports-5435e516040233db1fccc87d5e2adf323b970022.tar.gz
ports-5435e516040233db1fccc87d5e2adf323b970022.zip
Notes
-rw-r--r--shells/Makefile1
-rw-r--r--shells/ibsh/Makefile41
-rw-r--r--shells/ibsh/distinfo3
-rw-r--r--shells/ibsh/files/patch-Makefile21
-rw-r--r--shells/ibsh/files/pkg-message.in9
-rw-r--r--shells/ibsh/pkg-descr9
-rw-r--r--shells/ibsh/pkg-plist7
7 files changed, 91 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 92536872b82c..a88c08d103d7 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -13,6 +13,7 @@
SUBDIR += fd
SUBDIR += flash
SUBDIR += gscommander
+ SUBDIR += ibsh
SUBDIR += ksh93
SUBDIR += mudsh
SUBDIR += nologinmsg
diff --git a/shells/ibsh/Makefile b/shells/ibsh/Makefile
new file mode 100644
index 000000000000..9d1c3ef657e1
--- /dev/null
+++ b/shells/ibsh/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ibsh
+# Date created: 1 Oct 2005
+# Whom: Vaida Bogdan
+#
+# $FreeBSD$
+#
+
+PORTNAME= ibsh
+PORTVERSION= 0.3e
+CATEGORIES= shells
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= vaida.bogdan@gmail.com
+COMMENT= Restricted unix shell
+
+USE_GMAKE= yes
+ALL_TARGET= ibsh
+INSTALL_TARGET= ibsh_install
+
+SUB_FILES= pkg-message
+USE_REINPLACE= yes
+PORTDOCS= AUTHORS BUGS CONTRIBUTORS COPYING COPYRIGHT ChangeLog \
+ INSTALL README TODO VERSION
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|PATH_MAX|PATH_MAXb|g' ${WRKSRC}/delbadfiles.c ${WRKSRC}/ibsh.h
+ @${REINPLACE_CMD} -e 's|/etc/ibsh|${PREFIX}/etc/ibsh|g' ${WRKSRC}/ibsh.h
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+
+.include <bsd.port.post.mk>
diff --git a/shells/ibsh/distinfo b/shells/ibsh/distinfo
new file mode 100644
index 000000000000..6f3f4bbd5c31
--- /dev/null
+++ b/shells/ibsh/distinfo
@@ -0,0 +1,3 @@
+MD5 (ibsh-0.3e.tar.gz) = 41ea08a03c6bd805dff1a5ff25ea1d5b
+SHA256 (ibsh-0.3e.tar.gz) = 4c40d0841527c76fc75ccc27d32b575543d02d661973fc3561004efb6033206d
+SIZE (ibsh-0.3e.tar.gz) = 20475
diff --git a/shells/ibsh/files/patch-Makefile b/shells/ibsh/files/patch-Makefile
new file mode 100644
index 000000000000..6168d71f5751
--- /dev/null
+++ b/shells/ibsh/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig Fri Jun 3 15:47:32 2005
++++ Makefile Sat Nov 12 13:47:53 2005
+@@ -30,12 +30,12 @@
+ ${CC} -c delbadfiles.c
+
+ ibsh_install:
+- cp ./ibsh /bin/
+- mkdir /etc/ibsh
+- mkdir /etc/ibsh/cmds
+- mkdir /etc/ibsh/xtns
+- cp ./globals.cmds /etc/ibsh/
+- cp ./globals.xtns /etc/ibsh/
++ cp ./ibsh ${PREFIX}/bin/
++ mkdir ${PREFIX}/etc/ibsh
++ mkdir ${PREFIX}/etc/ibsh/cmds
++ mkdir ${PREFIX}/etc/ibsh/xtns
++ cp ./globals.cmds ${PREFIX}/etc/ibsh/
++ cp ./globals.xtns ${PREFIX}/etc/ibsh/
+
+ ibsh_uninstall:
+ rm -rf /etc/ibsh/globals.cmds
diff --git a/shells/ibsh/files/pkg-message.in b/shells/ibsh/files/pkg-message.in
new file mode 100644
index 000000000000..00278e259d6d
--- /dev/null
+++ b/shells/ibsh/files/pkg-message.in
@@ -0,0 +1,9 @@
+==========================================================================
+
+To use the shell:
+
+# echo %%PREFIX%%/bin/ibsh >> /etc/shells
+
+Also check %%PREFIX%%/etc/ibsh
+
+==========================================================================
diff --git a/shells/ibsh/pkg-descr b/shells/ibsh/pkg-descr
new file mode 100644
index 000000000000..725e5fdc28df
--- /dev/null
+++ b/shells/ibsh/pkg-descr
@@ -0,0 +1,9 @@
+Iron Bars Shell is a restricted Unix shell. The user can not step out of, nor
+access files outside the home directory. It is written in C for Linux. No
+libraries used. It is small, fast, secure. Two ascii configuration files for
+more control.
+
+WWW: http://ibsh.sourceforge.net/
+
+- Vaida Bogdan
+vaida.bogdan@gmail.com
diff --git a/shells/ibsh/pkg-plist b/shells/ibsh/pkg-plist
new file mode 100644
index 000000000000..ef76a8a4823e
--- /dev/null
+++ b/shells/ibsh/pkg-plist
@@ -0,0 +1,7 @@
+bin/ibsh
+etc/ibsh/globals.cmds
+etc/ibsh/globals.xtns
+
+@dirrm /etc/ibsh/cmds
+@dirrm /etc/ibsh/xtns
+@dirrm /etc/ibsh