aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2003-12-12 13:20:29 +0000
committerMark Pulford <markp@FreeBSD.org>2003-12-12 13:20:29 +0000
commit5b15f0f853c4b884deb1391c85ed0b0954d2fe39 (patch)
tree06353aaac076061e019814dacac5e83e2e985e92
parent34ee0c9925168ed417f1714bd51913c40059fa31 (diff)
downloadports-5b15f0f853c4b884deb1391c85ed0b0954d2fe39.tar.gz
ports-5b15f0f853c4b884deb1391c85ed0b0954d2fe39.zip
Notes
-rw-r--r--sysutils/tmpwatch/Makefile13
-rw-r--r--sysutils/tmpwatch/distinfo2
-rw-r--r--sysutils/tmpwatch/files/patch-tmpwatch.c26
3 files changed, 9 insertions, 32 deletions
diff --git a/sysutils/tmpwatch/Makefile b/sysutils/tmpwatch/Makefile
index c6d94450d669..9a19f8b08b78 100644
--- a/sysutils/tmpwatch/Makefile
+++ b/sysutils/tmpwatch/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= tmpwatch
-PORTVERSION= 2.8.1
-PORTREVISION= 1
+PORTVERSION= 2.9.0
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
-MASTER_SITE_SUBDIR= updates/7.2/en/os/SRPMS
-EXTRACT_SUFX= -1.src.rpm
+MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
+MASTER_SITE_SUBDIR= fedora/fedora/1/i386/SRPMS.os
+EXTRACT_SUFX= -2.src.rpm
MAINTAINER= markp@FreeBSD.org
COMMENT= A utility for removing files based on when they were last accessed
@@ -19,6 +18,7 @@ COMMENT= A utility for removing files based on when they were last accessed
BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
USE_GETOPT_LONG=yes
+USE_REINPLACE= yes
CPIO?= /usr/bin/cpio
CFLAGS+= ${CPPFLAGS} -DVERSION=\"${PORTVERSION}\"
@@ -32,6 +32,9 @@ do-extract:
cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${WRKDIR}/${DISTNAME}.tar.gz ${EXTRACT_AFTER_ARGS}
+post-patch:
+ ${REINPLACE_CMD} -E "s/^#include.+mntent.h.+//g" ${WRKSRC}/tmpwatch.c
+
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} ${LDFLAGS} -o tmpwatch tmpwatch.c
diff --git a/sysutils/tmpwatch/distinfo b/sysutils/tmpwatch/distinfo
index 2995d3dbc471..5e23a61c53ba 100644
--- a/sysutils/tmpwatch/distinfo
+++ b/sysutils/tmpwatch/distinfo
@@ -1 +1 @@
-MD5 (tmpwatch-2.8.1-1.src.rpm) = 27cb65abf996a15030045aff656f82a5
+MD5 (tmpwatch-2.9.0-2.src.rpm) = abb05f027dd3fe2531e16f82832a6c44
diff --git a/sysutils/tmpwatch/files/patch-tmpwatch.c b/sysutils/tmpwatch/files/patch-tmpwatch.c
deleted file mode 100644
index cd7c55ebbe9a..000000000000
--- a/sysutils/tmpwatch/files/patch-tmpwatch.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- tmpwatch.c.orig Wed Feb 20 22:42:57 2002
-+++ tmpwatch.c Wed Feb 20 23:14:48 2002
-@@ -28,7 +28,6 @@
- #include <utime.h>
- #include <unistd.h>
- #include <paths.h>
--#include <mntent.h>
-
- #define LOG_REALDEBUG 1
- #define LOG_DEBUG 2
-@@ -324,6 +323,7 @@
- if (*significant_time >= killTime)
- continue;
-
-+#if 0
- /* check if it is an ext3 journal file */
- if ((strcmp(ent->d_name, ".journal") == 0) &&
- (sb.st_uid == 0)) {
-@@ -352,6 +352,7 @@
- continue;
- }
- }
-+#endif
-
- if ((flags & FLAG_ALLFILES) ||
- S_ISREG(sb.st_mode) ||