aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-11-24 18:13:00 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-11-24 18:13:00 +0000
commit5c4987ca2dad487b0d722a851ff4da4d108086b2 (patch)
treea371755b0af984e0fda945ed3a673baa64026eb4
parent7a5868e5cbfc037bb1470ec92a4490f31f937368 (diff)
downloadports-5c4987ca2dad487b0d722a851ff4da4d108086b2.tar.gz
ports-5c4987ca2dad487b0d722a851ff4da4d108086b2.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/etoile-coreobject/Makefile39
-rw-r--r--devel/etoile-coreobject/distinfo3
-rw-r--r--devel/etoile-coreobject/pkg-descr11
-rw-r--r--devel/etoile-coreobject/pkg-plist41
5 files changed, 95 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 09ccadfd831d..3c84d1b5fb69 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -319,6 +319,7 @@
SUBDIR += esvn
SUBDIR += etl
SUBDIR += etoile-collectionkit
+ SUBDIR += etoile-coreobject
SUBDIR += etoile-foundation
SUBDIR += etoile-serialize
SUBDIR += etoile-unitkit
diff --git a/devel/etoile-coreobject/Makefile b/devel/etoile-coreobject/Makefile
new file mode 100644
index 000000000000..dcea4d4da442
--- /dev/null
+++ b/devel/etoile-coreobject/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: etoile-coreobject
+# Date created: 23 Nov 2008
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= coreobject
+PORTVERSION= 0.4.0
+CATEGORIES= devel gnustep
+MASTER_SITES= http://download.gna.org/etoile/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project CoreObject framework
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+USE_GNUSTEP_LOCAL_LIBS+= EtoileFoundation:${FOUNDATION_PORT}
+USE_GNUSTEP_LOCAL_LIBS+= EtoileSerialize:${SERIALIZE_PORT}
+USE_PGSQL= yes
+
+DEFAULT_LIBVERSION= 0.4
+WRKSRC= ${WRKDIR}/Etoile-${PORTVERSION}
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/CoreObject
+DEFAULT_LIBVERSION2= 0.1
+PLIST_SUB+= LIBVERSION2=${DEFAULT_LIBVERSION2}
+PLIST_SUB+= MAJORLIBVERSION2=${DEFAULT_LIBVERSION2:C/([0-9]).*/\1/1}
+
+FOUNDATION_PORT?= devel/etoile-foundation
+SERIALIZE_PORT?= devel/etoile-serialize
+
+.include <bsd.port.mk>
diff --git a/devel/etoile-coreobject/distinfo b/devel/etoile-coreobject/distinfo
new file mode 100644
index 000000000000..2c1e8a612c54
--- /dev/null
+++ b/devel/etoile-coreobject/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile-0.4.0.tar.bz2) = 7c33baf8ec3a708d0d419b1e137452de
+SHA256 (etoile-0.4.0.tar.bz2) = 05b5f01932aaad2ae6251ae01a1ad5376d29c984ee83d9fb62688c8d4a20237a
+SIZE (etoile-0.4.0.tar.bz2) = 8225128
diff --git a/devel/etoile-coreobject/pkg-descr b/devel/etoile-coreobject/pkg-descr
new file mode 100644
index 000000000000..9a89faab549c
--- /dev/null
+++ b/devel/etoile-coreobject/pkg-descr
@@ -0,0 +1,11 @@
+*CoreObject* is a framework for describing and organizing model objects, with
+automatic persistence and versioning by recording messages sent to objects. It
+offers a flexible versioning scheme where both individual objects and their
+entire object graph can be versioned separately. The built-in object model is a
+generalization of the property model used by the AddressBook framework. Foreign
+model objects can be also integrated by wrapping them with a special proxy.
+CoreObject uses the EtoileSerialize framework which, in many cases, allows
+objects and messages to be automatically serialized with no extra code being
+written.
+
+WWW: http://www.etoile-project.org/
diff --git a/devel/etoile-coreobject/pkg-plist b/devel/etoile-coreobject/pkg-plist
new file mode 100644
index 000000000000..9458fb19e4c1
--- /dev/null
+++ b/devel/etoile-coreobject/pkg-plist
@@ -0,0 +1,41 @@
+Local/Library/Frameworks/CoreObject.framework/CoreObject
+Local/Library/Frameworks/CoreObject.framework/CoreObject.framework
+Local/Library/Frameworks/CoreObject.framework/Headers
+Local/Library/Frameworks/CoreObject.framework/Resources
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/CoreObject
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COCollection.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COCoreObjectProtocol.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/CODeserializer.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/CODirectory.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COFile.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COFileObject.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COGroup.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COMetadataServer.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COMultiValue.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COObject.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COObjectContext.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COObjectServer.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COPersistentPool.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COPropertyType.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COProxy.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COSerializer.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COSmartGroup.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/COUtility.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/CoreObject.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/GNUstep.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers/NSObject+CoreObject.h
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Resources/Info-gnustep.plist
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/libCoreObject.so
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/libCoreObject.so.%%MAJORVERSION%%
+Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/libCoreObject.so.%%LIBVERSION%%
+Local/Library/Frameworks/CoreObject.framework/Versions/Current
+Local/Library/Frameworks/CoreObject.framework/libCoreObject.so
+Local/Library/Headers/CoreObject
+Local/Library/Libraries/libCoreObject.so
+Local/Library/Libraries/libCoreObject.so.%%MAJORVERSION%%
+Local/Library/Libraries/libCoreObject.so.%%LIBVERSION%%
+@dirrm Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Resources
+@dirrm Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%/Headers
+@dirrm Local/Library/Frameworks/CoreObject.framework/Versions/%%MAJORVERSION%%
+@dirrm Local/Library/Frameworks/CoreObject.framework/Versions
+@dirrm Local/Library/Frameworks/CoreObject.framework