aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-07-26 15:44:15 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-07-26 15:44:15 +0000
commit5eb1381a24f03d08b1f0a1c9d8966da186c20c2e (patch)
tree80d06bbd8e13fb5888512a6e94f9016b6b6a7ef8
parent1bd446561d121576eeb00d326fe8f73605e22a97 (diff)
downloadports-5eb1381a24f03d08b1f0a1c9d8966da186c20c2e.tar.gz
ports-5eb1381a24f03d08b1f0a1c9d8966da186c20c2e.zip
Notes
-rw-r--r--converters/p5-Unicode-MapUTF8/Makefile12
-rw-r--r--japanese/another-htmllint/Makefile12
-rw-r--r--japanese/wikicker/Makefile8
-rw-r--r--www/fswiki/Makefile12
4 files changed, 37 insertions, 7 deletions
diff --git a/converters/p5-Unicode-MapUTF8/Makefile b/converters/p5-Unicode-MapUTF8/Makefile
index 8e9b08199a85..fe4b4d35a363 100644
--- a/converters/p5-Unicode-MapUTF8/Makefile
+++ b/converters/p5-Unicode-MapUTF8/Makefile
@@ -17,7 +17,7 @@ COMMENT= Perl class that implements conversion between arbitrary charsets
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unicode/Map.pm:${PORTSDIR}/converters/p5-Unicode-Map \
${SITE_PERL}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String \
${SITE_PERL}/${PERL_ARCH}/Unicode/Map8.pm:${PORTSDIR}/converters/p5-Unicode-Map8 \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -25,4 +25,12 @@ PERL_CONFIGURE= yes
MAN3= Unicode::MapUTF8.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/another-htmllint/Makefile b/japanese/another-htmllint/Makefile
index 5c73272a915c..0f75570113a5 100644
--- a/japanese/another-htmllint/Makefile
+++ b/japanese/another-htmllint/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Another HTML-lint (all messages are written in Japanese)
RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
USE_ZIP= YES
WRKSRC= ${WRKDIR}
@@ -50,4 +50,12 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/wikicker/Makefile b/japanese/wikicker/Makefile
index 6780753a0e2b..1ff7c9e4b8ee 100644
--- a/japanese/wikicker/Makefile
+++ b/japanese/wikicker/Makefile
@@ -29,7 +29,7 @@ RUN_DEPENDS+= \
${SITE_PERL}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String \
${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
@@ -54,6 +54,12 @@ IGNORE= requires Perl 5.6 or newer to run. Either install new Perl or define WIT
RUN_DEPENDS+= ${SITE_PERL}/Cache/Memcached.pm:${PORTSDIR}/databases/p5-Cache-Memcached
.endif
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
PERL_CONFIGURE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
WIKIAUTO= ${SITE_PERL}/auto/${PORTNAME}
diff --git a/www/fswiki/Makefile b/www/fswiki/Makefile
index 104f94b5f904..4fd348a6adb8 100644
--- a/www/fswiki/Makefile
+++ b/www/fswiki/Makefile
@@ -15,7 +15,7 @@ DISTNAME= wiki${PORTVERSION:S|.|_|g}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= FreeStyle Wiki (perl based wiki clone)
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
+RUN_DEPENDS= ${JCODE}:${PORTSDIR}/japanese/p5-Jcode \
${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template
USE_ZIP= yes
@@ -39,4 +39,12 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/wiki.cgi ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/setup.sh ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>