aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-30 12:00:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-30 12:00:08 +0000
commit638f5776d3ddae75ad55a952f83f244dbd1a9257 (patch)
treeda06148f36fe11f9e624fecf8a2b616bd81f9cf9
parent04eecb2f577a47b6030c737ffd1bc818b6dc1c4a (diff)
downloadports-638f5776d3ddae75ad55a952f83f244dbd1a9257.tar.gz
ports-638f5776d3ddae75ad55a952f83f244dbd1a9257.zip
Notes
-rw-r--r--sysutils/moreutils/Makefile12
-rw-r--r--sysutils/moreutils/distinfo6
-rw-r--r--sysutils/moreutils/files/isutf8.125
3 files changed, 29 insertions, 14 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
index be16c62cf119..ef87462f2be8 100644
--- a/sysutils/moreutils/Makefile
+++ b/sysutils/moreutils/Makefile
@@ -2,16 +2,16 @@
# $FreeBSD$
PORTNAME= moreutils
-PORTVERSION= 0.59
-DISTVERSIONSUFFIX= .orig
+PORTVERSION= 0.61
CATEGORIES= sysutils
-MASTER_SITES= DEBIAN_POOL
-DISTNAME= ${PORTNAME}_${DISTVERSIONFULL}
+MASTER_SITES= https://git.joeyh.name/index.cgi/moreutils.git/snapshot/ \
+ LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Additional Unix utilities
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= p5-IPC-Run>=0:devel/p5-IPC-Run
@@ -21,8 +21,7 @@ OPTIONS_SUB= yes
ALL_TARGET= errnos.h ${CANNED_MANPAGES:R}
MAKE_JOBS_UNSAFE= yes
-USES= perl5 shebangfix
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSIONFULL}
+USES= gmake perl5 shebangfix
CANNED_MANPAGES=errno.1 \
ifdata.1 \
@@ -50,6 +49,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|parallel|moreutils-&|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|__APPLE__|__${OPSYS}__|' ${WRKSRC}/ifdata.c
+ @${REINPLACE_CMD} -e '/^CC = gcc/d' ${WRKSRC}/is_utf8/Makefile
@cd ${FILESDIR}/ && ${CP} ${CANNED_MANPAGES} ${WRKSRC}/
post-build:
diff --git a/sysutils/moreutils/distinfo b/sysutils/moreutils/distinfo
index c1c3ffabcc60..1c64aff62e08 100644
--- a/sysutils/moreutils/distinfo
+++ b/sysutils/moreutils/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1466837939
-SHA256 (moreutils_0.59.orig.tar.gz) = a48e11c3197bf79a7bfaa121423e64626e3381d9fedc91d606e9724ae498d1b4
-SIZE (moreutils_0.59.orig.tar.gz) = 47248
+TIMESTAMP = 1493551321
+SHA256 (moreutils-0.61.tar.gz) = eb47d33251715a8638c2309ab69b23e9023f7fd2fe2c101c9574230e91ff308b
+SIZE (moreutils-0.61.tar.gz) = 91205
diff --git a/sysutils/moreutils/files/isutf8.1 b/sysutils/moreutils/files/isutf8.1
index 79049b8f5dfb..c9730bbc5458 100644
--- a/sysutils/moreutils/files/isutf8.1
+++ b/sysutils/moreutils/files/isutf8.1
@@ -1,13 +1,13 @@
'\" t
.\" Title: isutf8
-.\" Author: Lars Wirzenius
+.\" Author: Lars Wirzenius <liw@iki.fi>
.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
-.\" Date: 2006-02-19
+.\" Date: 04/30/2017
.\" Manual: moreutils
.\" Source: moreutils
.\" Language: English
.\"
-.TH "ISUTF8" "1" "2006\-02\-19" "moreutils" "moreutils"
+.TH "ISUTF8" "1" "04/30/2017" "moreutils" "moreutils"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
@@ -31,7 +31,7 @@
isutf8 \- check whether files are valid UTF\-8
.SH "SYNOPSIS"
.HP \w'\fBisutf8\fR\ 'u
-\fBisutf8\fR [\fB\-hq\fR] [\fB\-\-help\fR] [\fB\-\-quiet\fR] [[\fIfile\fR...]]
+\fBisutf8\fR [\fB\-hqliv\fR] [\fB\-\-help\fR] [\fB\-\-quiet\fR] [\fB\-\-list\fR] [\fB\-\-invert\fR] [\fB\-\-verbose\fR] [[\fIfile\fR...]]
.SH "DESCRIPTION"
.PP
\fBisutf8\fR
@@ -47,12 +47,27 @@ Print out a help summary\&.
.RS 4
Don\*(Aqt print messages telling which files are invalid UTF\-8, merely indicate it with the exit status\&.
.RE
+.PP
+\fB\-l\fR, \fB\-\-list\fR
+.RS 4
+Print only the names of files containing invalid UTF\-8\&.
+.RE
+.PP
+\fB\-i\fR, \fB\-\-invert\fR
+.RS 4
+Invert the selection: list UTF\-8 compatible files\&.
+.RE
+.PP
+\fB\-v\fR, \fB\-\-verbose\fR
+.RS 4
+Also print an hexdump\-like view of the error and some context\&.
+.RE
.SH "EXIT STATUS"
.PP
If the file is valid UTF\-8, the exit status is zero\&. If the file is not valid UTF\-8, or there is some error, the exit status is non\-zero\&.
.SH "AUTHOR"
.PP
-Lars Wirzenius
+Lars Wirzenius, Julien Palard
.SH "SEE ALSO"
.PP