aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-02 05:08:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-02 05:08:54 +0000
commitad7ed5c1421efd0dab61c874245aadf5e10bc175 (patch)
tree272e726d0b8f9940d3ebb8a10891e5a658371b62
parente0ee990960c2cfa38e40f4e8db33356923ca610c (diff)
downloadports-ad7ed5c1421efd0dab61c874245aadf5e10bc175.tar.gz
ports-ad7ed5c1421efd0dab61c874245aadf5e10bc175.zip
Notes
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/acidrip/Makefile50
-rw-r--r--multimedia/acidrip/distinfo2
-rw-r--r--multimedia/acidrip/pkg-descr14
-rw-r--r--multimedia/acidrip/pkg-plist8
5 files changed, 75 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 084fec3514a1..3e9ca1e12c79 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -1,5 +1,6 @@
# $FreeBSD$
#
+ SUBDIR += acidrip
SUBDIR += acme
SUBDIR += avidemux
SUBDIR += avidemux2
diff --git a/multimedia/acidrip/Makefile b/multimedia/acidrip/Makefile
new file mode 100644
index 000000000000..d8ef880607ca
--- /dev/null
+++ b/multimedia/acidrip/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: acidrip
+# Date created: 2004-03-31
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= acidrip
+PORTVERSION= 0.12
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ahze@ahze.net
+COMMENT= GTK2::Perl wrapper for MPlayer and MEncoder for ripping DVD's
+
+BUILD_DEPENDS= lsdvd:${PORTSDIR}/multimedia/lsdvd \
+ mencoder:${PORTSDIR}/multimedia/mplayer \
+ ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_REINPLACE= yes
+PERL_CONFIGURE= yes
+MAN1= acidrip.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DVD_DEVICE)
+DEFAULT_DVD_DEVICE=${WITH_DVD_DEVICE}
+.else
+.if ${OSVERSION} < 500000
+DEFAULT_DVD_DEVICE=/dev/acd0c
+.else
+DEFAULT_DVD_DEVICE=/dev/acd0
+.endif
+.endif
+
+pre-everything::
+.if !defined(WITH_DVD_DEVICE)
+ @${ECHO_MSG} "===> The default DVD device is ${DEFAULT_DVD_DEVICE}"
+ @${ECHO_MSG} "===> Define WITH_DVD_DEVICE if you want to change the default"
+ @${ECHO_MSG} "===> For example, 'make WITH_DVD_DEVICE=\"/dev/somedevice\"'"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
+ ${WRKSRC}/AcidRip/acidrip.pm
+ @${RM} ${WRKSRC}/AcidRip/*.bak
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/acidrip/distinfo b/multimedia/acidrip/distinfo
new file mode 100644
index 000000000000..2acf8dd8bad9
--- /dev/null
+++ b/multimedia/acidrip/distinfo
@@ -0,0 +1,2 @@
+MD5 (acidrip-0.12.tar.gz) = ba88de14f7460416da1908fb3f972043
+SIZE (acidrip-0.12.tar.gz) = 90113
diff --git a/multimedia/acidrip/pkg-descr b/multimedia/acidrip/pkg-descr
new file mode 100644
index 000000000000..be558ade6103
--- /dev/null
+++ b/multimedia/acidrip/pkg-descr
@@ -0,0 +1,14 @@
+AcidRip is a Gtk2::Perl application for ripping and encoding DVD's.
+It neatly wraps MPlayer and MEncoder, seeing as MPlayer is by far the best
+bit of video playing kit around for Linux (and FreeBSD). As well as creating
+a simple Graphical Interface for those scared of getting down and dirty with
+MEncoders command line interface, It also automates the process in a number of
+ways:
+
+ o Parses DVD into contents tree
+ o Finds longest title
+ o Calculate video bitrate for given filesize
+ o Finds black bands and crops them
+ o Gives suggestions for improved performance
+
+WWW: http://acidrip.thirtythreeandathird.net/
diff --git a/multimedia/acidrip/pkg-plist b/multimedia/acidrip/pkg-plist
new file mode 100644
index 000000000000..7c6ada24b8a0
--- /dev/null
+++ b/multimedia/acidrip/pkg-plist
@@ -0,0 +1,8 @@
+bin/acidrip
+%%SITE_PERL%%/AcidRip/acidrip.pm
+%%SITE_PERL%%/AcidRip/interface.pm
+%%SITE_PERL%%/AcidRip/logo.png
+%%SITE_PERL%%/AcidRip/signals.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AcidRip/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/AcidRip
+@dirrm %%SITE_PERL%%/AcidRip