aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-01-17 16:54:52 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-01-17 16:54:52 +0000
commitd3f99a4e7a4c877f64f6bfe9dd41178b3f742714 (patch)
tree9124b17ec29c8ec2165b030c313a3808036ff09b
parente069ca2802eacd45e40d5c991621e1e650cba376 (diff)
- Add new port sysutils/realsync
realsync daemon with rsync and python: - config support /usr/local/etc/realsync.cfg - e-mail stats support - threads support - threads wait support PR: ports/185774 Submitted by: Krasimir Nachev <krasi@it-sys.org>
Notes
Notes: svn path=/head/; revision=340070
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/realsync/Makefile39
-rw-r--r--sysutils/realsync/distinfo2
-rw-r--r--sysutils/realsync/files/pkg-message.in13
-rw-r--r--sysutils/realsync/pkg-descr7
5 files changed, 62 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index aee0b3f43afc..9abb89b3420e 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -774,6 +774,7 @@
SUBDIR += rdiff-backup-devel
SUBDIR += rdup
SUBDIR += readlink
+ SUBDIR += realsync
SUBDIR += recoverdm
SUBDIR += reed
SUBDIR += rej
diff --git a/sysutils/realsync/Makefile b/sysutils/realsync/Makefile
new file mode 100644
index 000000000000..0f645115e3f3
--- /dev/null
+++ b/sysutils/realsync/Makefile
@@ -0,0 +1,39 @@
+# Created by: Krasimir Nachev krasi@it-sys.org
+# $FreeBSD$
+
+PORTNAME= realsync
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.it-sys.org/distfiles/
+
+MAINTAINER= krasi@it-sys.org
+COMMENT= Parallel synchronization daemon for rsync
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync \
+ sudo:${PORTSDIR}/security/sudo
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+SUB_FILES= pkg-message
+
+PLIST_FILES= sbin/realsync \
+ etc/rc.d/realsync \
+ etc/realsync.cfg.example \
+ man/man8/realsync.8.gz
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 804000
+IGNORE= does not work on FreeBSD < 8.4
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/realsync ${STAGEDIR}${PREFIX}/sbin/realsync
+ ${INSTALL_MAN} ${WRKSRC}/man8/realsync.8 ${STAGEDIR}${PREFIX}/man/man8/realsync.8
+ ${INSTALL_SCRIPT} ${WRKSRC}/rc.d/realsync ${STAGEDIR}${PREFIX}/etc/rc.d/realsync
+ ${INSTALL_DATA} ${WRKSRC}/config/${PORTNAME}.cfg.example ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.cfg.example
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/realsync/distinfo b/sysutils/realsync/distinfo
new file mode 100644
index 000000000000..dd2da8cef804
--- /dev/null
+++ b/sysutils/realsync/distinfo
@@ -0,0 +1,2 @@
+SHA256 (realsync-0.1.tar.gz) = c0c78ef72d1a086f65d44020b345f430accf7f942bce5f3649f6113fea1e137f
+SIZE (realsync-0.1.tar.gz) = 6052
diff --git a/sysutils/realsync/files/pkg-message.in b/sysutils/realsync/files/pkg-message.in
new file mode 100644
index 000000000000..b5a5fdd966ed
--- /dev/null
+++ b/sysutils/realsync/files/pkg-message.in
@@ -0,0 +1,13 @@
+-------------------------------------------------------------------------------------------
+Author: Krasimir Nachev e-mail: krasi@it-sys.org
+Please:
+ 1. Edit %%PREFIX%%/etc/realsync.cfg
+ 2. Genenerate a ssh key with the command below:
+ ssh-keygen -b 4048 -t rsa -C "realsync automatic sync"
+ 3. Copy the key to some remote nodes:
+ scp ~/.ssh/id_rsa.pub someuser@remote.node1.domain.org:.ssh/authorized_keys
+ 4. Set realsync_enable="YES" in /etc/rc.conf
+Start the program: %%PREFIX%%/etc/rc.d/realsync start
+That's all!
+-------------------------------------------------------------------------------------------
+
diff --git a/sysutils/realsync/pkg-descr b/sysutils/realsync/pkg-descr
new file mode 100644
index 000000000000..f348b1767dbb
--- /dev/null
+++ b/sysutils/realsync/pkg-descr
@@ -0,0 +1,7 @@
+realsync daemon with rsync and python:
+- config support /usr/local/etc/realsync.cfg
+- e-mail stats support
+- threads support
+- threads wait support
+
+WWW: http://www.it-sys.org/realsync