aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 04:33:24 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 04:33:24 +0000
commite5092d6e1b5c6d1cb69e3b1b1fcf8efc9face152 (patch)
treea9cae432ef148b56ba12e4b61dceb01f16925ce0
parent78864e8862e2a5f17e83a7d35397c1779e0a7e8e (diff)
downloadports-e5092d6e1b5c6d1cb69e3b1b1fcf8efc9face152.tar.gz
ports-e5092d6e1b5c6d1cb69e3b1b1fcf8efc9face152.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-Filter/Makefile26
-rw-r--r--www/p5-Apache-Filter/distinfo1
-rw-r--r--www/p5-Apache-Filter/files/patch-Makefile.PL16
-rw-r--r--www/p5-Apache-Filter/pkg-comment1
-rw-r--r--www/p5-Apache-Filter/pkg-descr20
-rw-r--r--www/p5-Apache-Filter/pkg-plist7
7 files changed, 72 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4438deb47cd8..06529a11e6d0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -155,6 +155,7 @@
SUBDIR += p5-Apache-AuthenURL
SUBDIR += p5-Apache-AutoIndex
SUBDIR += p5-Apache-DBI
+ SUBDIR += p5-Apache-Filter
SUBDIR += p5-Apache-Icon
SUBDIR += p5-Apache-Language
SUBDIR += p5-Apache-MP3
diff --git a/www/p5-Apache-Filter/Makefile b/www/p5-Apache-Filter/Makefile
new file mode 100644
index 000000000000..05bf7531737d
--- /dev/null
+++ b/www/p5-Apache-Filter/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Apache-Filter
+# Date created: March 30th 2001
+# Whom: Alex Kapranoff <kapr@crosswinds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Filter
+PORTVERSION= 1.016
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kapr@crosswinds.net
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+
+PERL_CONFIGURE= yes
+INSTALL_TARGET= pure_install
+
+MAN3= Apache::Filter.3 Apache::PerlRunFilter.3 \
+ Apache::RegistryFilter.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Filter/distinfo b/www/p5-Apache-Filter/distinfo
new file mode 100644
index 000000000000..dd09d5447e38
--- /dev/null
+++ b/www/p5-Apache-Filter/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-Filter-1.016.tar.gz) = bff9089882d3f9834fafa1822a4f37f6
diff --git a/www/p5-Apache-Filter/files/patch-Makefile.PL b/www/p5-Apache-Filter/files/patch-Makefile.PL
new file mode 100644
index 000000000000..0bb031f28800
--- /dev/null
+++ b/www/p5-Apache-Filter/files/patch-Makefile.PL
@@ -0,0 +1,16 @@
+--- Makefile.PL.orig Mon Apr 2 16:06:30 2001
++++ Makefile.PL Mon Apr 2 16:06:59 2001
+@@ -1,13 +1,4 @@
+ use ExtUtils::MakeMaker;
+-use lib 't/lib'; # distributed here until changes are incorporated into the real version
+-use Apache::test;
+-
+-my %params = Apache::test->get_test_params();
+-chomp (my $cwd = `pwd`);
+-Apache::test->write_httpd_conf
+- (%params,
+- include => do {local $/; <DATA>});
+-*MY::test = sub { Apache::test->MM_test(%params) };
+
+ my $module = 'Apache::Filter';
+ my ($name, $dir);
diff --git a/www/p5-Apache-Filter/pkg-comment b/www/p5-Apache-Filter/pkg-comment
new file mode 100644
index 000000000000..4f0a4bd18e89
--- /dev/null
+++ b/www/p5-Apache-Filter/pkg-comment
@@ -0,0 +1 @@
+Perl module to alter the output of previous handlers
diff --git a/www/p5-Apache-Filter/pkg-descr b/www/p5-Apache-Filter/pkg-descr
new file mode 100644
index 000000000000..24b158d80c1a
--- /dev/null
+++ b/www/p5-Apache-Filter/pkg-descr
@@ -0,0 +1,20 @@
+This module lets you stack handlers so that the next one will handle
+or "filter" the output of previous one.
+
+From README:
+ When you've got this module, you can use the same handler both as a
+ stand-alone handler, and as an element in a chain. Just make sure that
+ whenever you're chaining, all the handlers in the chain are "Filter-
+ aware," i.e. they each call $r->filter_register() exactly once, before
+ they start printing to STDOUT. There should be almost no overhead for
+ doing this when there's only one element in the chain.
+
+ Currently the following public modules are Filter-aware.
+
+ Apache::Registry (using Apache::RegistryFilter, included here)
+ Apache::SSI
+ Apache::ASP
+ HTML::Mason
+ Apache::SimpleReplace
+
+-- Alex Kapranoff <kapr@crosswinds.net>
diff --git a/www/p5-Apache-Filter/pkg-plist b/www/p5-Apache-Filter/pkg-plist
new file mode 100644
index 000000000000..60c3b5552e76
--- /dev/null
+++ b/www/p5-Apache-Filter/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/Apache/PerlRunFilter.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/Filter.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/RegistryFilter.pm
+@unexec rmdir lib/perl5/site_perl/%%PERL_VER%%/Apache 2>/dev/null || true
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Filter/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Filter
+@unexec rmdir lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true