aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2009-10-16 07:28:19 +0000
committerAndrej Zverev <az@FreeBSD.org>2009-10-16 07:28:19 +0000
commite6fca33a6a3ebab261a7009087e15c8a90699fd0 (patch)
tree0d0a2359cbafa69e476787ea8d7f3be6a0154e80
parentb404d7fd272b6c476e475f5ceee54a72cd051cee (diff)
downloadports-e6fca33a6a3ebab261a7009087e15c8a90699fd0.tar.gz
ports-e6fca33a6a3ebab261a7009087e15c8a90699fd0.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Load/Makefile21
-rw-r--r--devel/p5-Class-Load/distinfo3
-rw-r--r--devel/p5-Class-Load/pkg-descr11
-rw-r--r--devel/p5-Class-Load/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d144c835059e..ce4f6ad9c379 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1112,6 +1112,7 @@
SUBDIR += p5-Class-InsideOut
SUBDIR += p5-Class-Inspector
SUBDIR += p5-Class-Interfaces
+ SUBDIR += p5-Class-Load
SUBDIR += p5-Class-Loader
SUBDIR += p5-Class-MOP
SUBDIR += p5-Class-MakeMethods
diff --git a/devel/p5-Class-Load/Makefile b/devel/p5-Class-Load/Makefile
new file mode 100644
index 000000000000..13f55e948bff
--- /dev/null
+++ b/devel/p5-Class-Load/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Class-Load
+# Date created: 2009-10-16
+# Whom: Andrej Zverev <az@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Load
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= az@FreeBSD.org
+COMMENT= A working (require Class::Name) and more
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Load.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Load/distinfo b/devel/p5-Class-Load/distinfo
new file mode 100644
index 000000000000..8709bf8724d1
--- /dev/null
+++ b/devel/p5-Class-Load/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Load-0.05.tar.gz) = 5144494bc35bc5680427d068db04df7a
+SHA256 (Class-Load-0.05.tar.gz) = b81b2f295c04715050629c087f988ffb5f8dde71bff21b61e3cc1c85d0919bc3
+SIZE (Class-Load-0.05.tar.gz) = 17119
diff --git a/devel/p5-Class-Load/pkg-descr b/devel/p5-Class-Load/pkg-descr
new file mode 100644
index 000000000000..edbbba14a455
--- /dev/null
+++ b/devel/p5-Class-Load/pkg-descr
@@ -0,0 +1,11 @@
+require EXPR only accepts Class/Name.pm style module names, not Class::Name.
+How frustrating! For that, we provide load_class 'Class::Name'.
+It's often useful to test whether a module can be loaded, instead of throwing
+an error when it's not available. For that, we provide try_load_class
+'Class::Name'.
+Finally, sometimes we need to know whether a particular class has been loaded.
+Asking %INC is an option, but that will miss inner packages and any class for
+which the filename does not correspond to the package name. For that,
+we provide is_class_loaded 'Class::Name'.
+
+WWW: http://search.cpan.org/~sartak/Class-Load/
diff --git a/devel/p5-Class-Load/pkg-plist b/devel/p5-Class-Load/pkg-plist
new file mode 100644
index 000000000000..be69a6b75178
--- /dev/null
+++ b/devel/p5-Class-Load/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Class/Load.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Load/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Load
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
+@dirrmtry %%SITE_PERL%%/Class