aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Moolenaar <marcel@FreeBSD.org>2001-12-06 05:09:21 +0000
committerMarcel Moolenaar <marcel@FreeBSD.org>2001-12-06 05:09:21 +0000
commiteb9f710310c163d0f62eeb8be7e5de99f5686401 (patch)
tree28dcf0c8eaec526a0ac71d061bc805d26e0f3f92
parent5c449f4cf4522d40877456fe1af25bc438d11f94 (diff)
Fix -current breakage caused by a type change of pt_entry_t.
Note that the OSVERSION test is inexact. The type change happened after 500027, but since there's no 500028 yet and making one specifically for this port is considered overkill we hope to get away with it. Submitted by: Munehiro Matsuda <haro@h4.dion.ne.jp> Approved by: Vladimir N. Silyaev <vsilyaev@mindspring.com> Coordinated by: Mark Santcroos <marks@ripe.net> :-)
Notes
Notes: svn path=/head/; revision=51107
-rw-r--r--emulators/vmware2/Makefile3
-rw-r--r--emulators/vmware2/files/pmap.patch11
-rw-r--r--emulators/vmware3/Makefile3
-rw-r--r--emulators/vmware3/files/pmap.patch11
4 files changed, 28 insertions, 0 deletions
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index 66bcf43a7aa9..4a4ace5aefcd 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -88,6 +88,9 @@ post-patch:
.if ${OSVERSION} >= 500023
cat ${FILESDIR}/kse.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
.endif
+.if ${OSVERSION} >= 500027
+ cat ${FILESDIR}/pmap.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
+.endif
${CP} ${FILESDIR}/Makefile ${WRKSRC}
${CP} ${FILESDIR}/Makefile.vmmon ${WRKSRC}/vmmon-only/Makefile
${RM} -rf ${WRKSRC}/vmmon-only/linux/
diff --git a/emulators/vmware2/files/pmap.patch b/emulators/vmware2/files/pmap.patch
new file mode 100644
index 000000000000..2a914e47c047
--- /dev/null
+++ b/emulators/vmware2/files/pmap.patch
@@ -0,0 +1,11 @@
+--- vmmon-only/freebsd/hostif.c.orig Tue Dec 4 20:49:08 2001
++++ vmmon-only/freebsd/hostif.c Tue Dec 4 20:49:44 2001
+@@ -170,7 +170,7 @@
+ {
+ #define DEB(x)
+ caddr_t addr = (caddr_t)VPN_2_VA(ppn);
+- pt_entry_t pteptr = (pt_entry_t)vtopte(addr);
++ pt_entry_t *pteptr = vtopte(addr);
+ PTE pte;
+
+ DEB(printf("FindMPN: for page %d address %p(phys %p) pteptr %p", ppn, addr, (caddr_t)vtophys(addr), pteptr));
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index 66bcf43a7aa9..4a4ace5aefcd 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -88,6 +88,9 @@ post-patch:
.if ${OSVERSION} >= 500023
cat ${FILESDIR}/kse.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
.endif
+.if ${OSVERSION} >= 500027
+ cat ${FILESDIR}/pmap.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
+.endif
${CP} ${FILESDIR}/Makefile ${WRKSRC}
${CP} ${FILESDIR}/Makefile.vmmon ${WRKSRC}/vmmon-only/Makefile
${RM} -rf ${WRKSRC}/vmmon-only/linux/
diff --git a/emulators/vmware3/files/pmap.patch b/emulators/vmware3/files/pmap.patch
new file mode 100644
index 000000000000..2a914e47c047
--- /dev/null
+++ b/emulators/vmware3/files/pmap.patch
@@ -0,0 +1,11 @@
+--- vmmon-only/freebsd/hostif.c.orig Tue Dec 4 20:49:08 2001
++++ vmmon-only/freebsd/hostif.c Tue Dec 4 20:49:44 2001
+@@ -170,7 +170,7 @@
+ {
+ #define DEB(x)
+ caddr_t addr = (caddr_t)VPN_2_VA(ppn);
+- pt_entry_t pteptr = (pt_entry_t)vtopte(addr);
++ pt_entry_t *pteptr = vtopte(addr);
+ PTE pte;
+
+ DEB(printf("FindMPN: for page %d address %p(phys %p) pteptr %p", ppn, addr, (caddr_t)vtophys(addr), pteptr));