aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-08 18:05:08 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-08 18:05:08 +0000
commit00946f47bf96760be20aa031da52a6eee02ff972 (patch)
treedd2b045be0979a0a466d64b126b3ce8b6326f6fe
parente23f270fd33a695725babed2b36f66f55224ef07 (diff)
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/zniper/Makefile28
-rw-r--r--net/zniper/distinfo3
-rw-r--r--net/zniper/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index fb7cc23d58c8..b0ecb1d6b8c8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -939,6 +939,7 @@
SUBDIR += zebra
SUBDIR += zebra-server
SUBDIR += zillion
+ SUBDIR += zniper
SUBDIR += zsync
SUBDIR += ztelnet
diff --git a/net/zniper/Makefile b/net/zniper/Makefile
new file mode 100644
index 000000000000..81d155f92eba
--- /dev/null
+++ b/net/zniper/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: zniper
+# Date created: 8 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zniper
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= CENKES
+# Unversioned distfile available from:
+# http://www.signedness.org/tools/zniper.tgz
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Display and reset active TCP connections
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ARGS= CFLAGS="${CFLAGS}" CC="${CC}"
+ALL_TARGET= fbsd_x86
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/net/zniper/distinfo b/net/zniper/distinfo
new file mode 100644
index 000000000000..76aff8570824
--- /dev/null
+++ b/net/zniper/distinfo
@@ -0,0 +1,3 @@
+MD5 (zniper-1.0.tar.gz) = d388de20580e4308052e5cf43dd3fe02
+SHA256 (zniper-1.0.tar.gz) = 317b115f0060252706e151936603b344119f0a547816d4bbf19d3808b8823e3f
+SIZE (zniper-1.0.tar.gz) = 20324
diff --git a/net/zniper/pkg-descr b/net/zniper/pkg-descr
new file mode 100644
index 000000000000..f865c5efb54c
--- /dev/null
+++ b/net/zniper/pkg-descr
@@ -0,0 +1,6 @@
+Zniper displays active TCP connections seen by the selected interface.
+The spotted connections can be killed by injecting RST packets into the
+stream.
+
+WWW: http://www.signedness.org/tools/
+Author: Claes M. Nyberg <md0claes@mdstud.chalmers.se>