aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-06-23 05:28:33 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-06-23 05:28:33 +0000
commit0c9df415d199d56904b290e5b0c21dc7403b724c (patch)
treecb8a499603d5a4c0096febc2e8ac6bc66c0b7e69
parent2b2737e54baa0d12baaac872267c3a46f08cc13f (diff)
downloadports-0c9df415d199d56904b290e5b0c21dc7403b724c.tar.gz
ports-0c9df415d199d56904b290e5b0c21dc7403b724c.zip
Notes
-rw-r--r--misc/dnetc/Makefile4
-rw-r--r--multimedia/vcdgear/Makefile3
-rw-r--r--net/queso/Makefile8
-rw-r--r--net/tdetect/Makefile6
-rw-r--r--security/slush/Makefile7
-rw-r--r--sysutils/cd-write/Makefile8
-rw-r--r--sysutils/gkrellm/Makefile4
-rw-r--r--sysutils/gkrellm2/Makefile4
-rw-r--r--sysutils/pkill/Makefile9
9 files changed, 4 insertions, 49 deletions
diff --git a/misc/dnetc/Makefile b/misc/dnetc/Makefile
index f503c4dd450a..3c5792a355ca 100644
--- a/misc/dnetc/Makefile
+++ b/misc/dnetc/Makefile
@@ -56,10 +56,6 @@ VERSION= 2.9011.496
VERSION= 2.9012.497
.endif
-.if ${OSVERSION} < 300000
-IGNORE= requires FreeBSD 3.X or greater
-.endif
-
do-configure:
@if [ ! -f ${PREFIX}/dnetc.ini ]; then \
${INSTALL} -c -m 644 ${FILESDIR}/dnetc.ini ${WRKSRC}; \
diff --git a/multimedia/vcdgear/Makefile b/multimedia/vcdgear/Makefile
index 89e38d8740eb..36174e2c278a 100644
--- a/multimedia/vcdgear/Makefile
+++ b/multimedia/vcdgear/Makefile
@@ -16,9 +16,6 @@ COMMENT= A tool to convert VCDs from cue/bin format to mpeg
ONLY_FOR_ARCHS= alpha i386 amd64
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 300004
-IGNORE= "Only an ELF binary is distributed; requires FreeBSD 3.1 or later"
-.endif
.if ${ARCH} == i386 || ${ARCH} == amd64
DISTNAME= ${PORTNAME}16d_i386_freebsd42
diff --git a/net/queso/Makefile b/net/queso/Makefile
index 873bbba93171..30a299971ba7 100644
--- a/net/queso/Makefile
+++ b/net/queso/Makefile
@@ -18,12 +18,6 @@ COMMENT= Determine the remote OS using simple tcp packets
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 300004
-LIB_DEPENDS= pcap.2:${PORTSDIR}/net/libpcap
-.endif
-
post-install:
#${INSTALL_PROGRAM} ${WRKSRC}/queso ${PREFIX}/sbin
#${INSTALL_DATA} ${WRKSRC}/queso.conf ${PREFIX}/etc
@@ -32,4 +26,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Documentation.txt ${PREFIX}/share/doc/queso
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/tdetect/Makefile b/net/tdetect/Makefile
index e9b288354aa5..f96f765863e0 100644
--- a/net/tdetect/Makefile
+++ b/net/tdetect/Makefile
@@ -13,13 +13,9 @@ MASTER_SITES= # disappeared
MAINTAINER= shipley@dis.org
COMMENT= Utility for detecting traceroutes and reporting them via syslog
-.include <bsd.port.pre.mk>
-
pre-configure:
${REINPLACE_CMD} -e 's/trdetect/tdetect/g' ${WRKSRC}/config.h
-.if ${OSVERSION} > 330002
${REINPLACE_CMD} -e 's/LOG_AUTHPRIV/LOG_SECURITY/g' ${WRKSRC}/config.h
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tdetect ${PREFIX}/sbin/tdetect
@@ -31,4 +27,4 @@ post-install:
${SED} -e 's,/usr/local,${PREFIX},g' ${PKGMESSAGE}; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/slush/Makefile b/security/slush/Makefile
index a073489cead7..701d142a3a03 100644
--- a/security/slush/Makefile
+++ b/security/slush/Makefile
@@ -18,11 +18,6 @@ COMMENT= A telnet-like application which uses a secure SSL channel
GNU_CONFIGURE= yes
USE_OPENSSL= yes
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} <= 300000
-BROKEN= does not build
-.endif
-
do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -32,4 +27,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/slush ${PREFIX}/bin/slush
${INSTALL_PROGRAM} ${WRKSRC}/slushd ${PREFIX}/sbin/slushd
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/cd-write/Makefile b/sysutils/cd-write/Makefile
index 9e0b133475bc..a1883de5fe9b 100644
--- a/sysutils/cd-write/Makefile
+++ b/sysutils/cd-write/Makefile
@@ -19,12 +19,6 @@ USE_PERL5_BUILD= yes
WRKSRC= ${WRKDIR}/cd-write
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 300000
-IGNORE= "FreeBSD 3.X or greater is required to support this port"
-.endif
-
PLIST_FILES= bin/cd-write
pre-build:
@@ -39,4 +33,4 @@ pre-build:
post-install:
@PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/gkrellm/Makefile b/sysutils/gkrellm/Makefile
index 7273bf68bad2..d3531685665e 100644
--- a/sysutils/gkrellm/Makefile
+++ b/sysutils/gkrellm/Makefile
@@ -42,11 +42,7 @@ PORTDOCS= COPYRIGHT README Themes.html
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 300000
-ALL_TARGET= freebsd2
-.else
ALL_TARGET= freebsd
-.endif
BINGRP= kmem
.if defined(WITH_SENSOR)
diff --git a/sysutils/gkrellm2/Makefile b/sysutils/gkrellm2/Makefile
index ed5a1a181119..65d70dca6c31 100644
--- a/sysutils/gkrellm2/Makefile
+++ b/sysutils/gkrellm2/Makefile
@@ -81,11 +81,7 @@ MAN1PREFIX= ${X11BASE}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 300000
-ALL_TARGET= freebsd2
-.else
ALL_TARGET= freebsd
-.endif
INSTALL_TARGET= install_freebsd
MAKE_ENV+= INSTALLROOT=${X11BASE} INSTALLDIR=${X11BASE}/bin \
diff --git a/sysutils/pkill/Makefile b/sysutils/pkill/Makefile
index c7a11c9a8e26..5953fd5ff44d 100644
--- a/sysutils/pkill/Makefile
+++ b/sysutils/pkill/Makefile
@@ -31,17 +31,8 @@ IGNORE= "is included in the base system"
DISTNAME= ${PORTNAME}-current-${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}-current
.else
-. if ${OSVERSION} <= 300000
-MAKE_ENV+= NEED_KMEM=1
-. endif
DISTNAME= ${PORTNAME}-stable-${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}-stable
.endif
-post-install:
-.if ${OSVERSION} <= 300000
- @${CHGRP} kmem ${PREFIX}/bin/pkill
- @${CHMOD} 2555 ${PREFIX}/bin/pkill
-.endif
-
.include <bsd.port.post.mk>