aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-07 13:41:00 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-07 13:41:00 +0000
commit314fa7a3d9e6a99b19be00339e9bcb109703d857 (patch)
treed6d78f2e42c0ad615e545c88c4b7c9e18855723a
parenta20733af4435f458f88ac9305185e098232882e0 (diff)
Notes
-rw-r--r--www/jakarta-tomcat4/Makefile2
-rw-r--r--www/jakarta-tomcat4/files/tomcat4.sh.in9
-rw-r--r--www/jakarta-tomcat41/Makefile2
-rw-r--r--www/jakarta-tomcat41/files/tomcat41.sh.in9
-rw-r--r--www/jakarta-tomcat5/Makefile2
-rw-r--r--www/jakarta-tomcat5/files/tomcat50.sh.in9
-rw-r--r--www/tomcat41/Makefile2
-rw-r--r--www/tomcat41/files/tomcat41.sh.in9
-rw-r--r--www/tomcat55/Makefile2
-rw-r--r--www/tomcat55/files/tomcat55.sh.in9
-rw-r--r--www/tomcat6/Makefile2
-rw-r--r--www/tomcat6/files/tomcat55.sh.in9
-rw-r--r--www/tomcat7/Makefile2
-rw-r--r--www/tomcat7/files/tomcat55.sh.in9
14 files changed, 63 insertions, 14 deletions
diff --git a/www/jakarta-tomcat4/Makefile b/www/jakarta-tomcat4/Makefile
index 51a75f801937..61872bf11189 100644
--- a/www/jakarta-tomcat4/Makefile
+++ b/www/jakarta-tomcat4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jakarta-tomcat
PORTVERSION= 4.0.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www java
MASTER_SITES= http://distfiles.coredump.cn/ \
ftp://local-distfiles.freebsd.org.cn/pub/china-ports/liukang/
diff --git a/www/jakarta-tomcat4/files/tomcat4.sh.in b/www/jakarta-tomcat4/files/tomcat4.sh.in
index dac2e79731df..105bcae155c7 100644
--- a/www/jakarta-tomcat4/files/tomcat4.sh.in
+++ b/www/jakarta-tomcat4/files/tomcat4.sh.in
@@ -105,7 +105,14 @@ java_command="%%LOCALBASE%%/bin/java \
log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
2>> ${tomcat%%TOMCAT_VERSION%%_stderr_log} "
-procname="*java"
+# Subvert the check_pid_file procname check.
+if [ -f $pidfile ]; then
+ read rc_pid junk < $pidfile
+ if [ ! -z "$rc_pid" ]; then
+ procname=`ps -o command= $rc_pid | cut -d ' ' -f 1`
+ fi
+fi
+
required_files="${tomcat%%TOMCAT_VERSION%%_catalina_home}/conf/server.xml"
command="/usr/sbin/daemon"
diff --git a/www/jakarta-tomcat41/Makefile b/www/jakarta-tomcat41/Makefile
index db7b44a561c5..c099ddd51f16 100644
--- a/www/jakarta-tomcat41/Makefile
+++ b/www/jakarta-tomcat41/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jakarta-tomcat
PORTVERSION= 4.1.31
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-4/v${PORTVERSION}/bin
diff --git a/www/jakarta-tomcat41/files/tomcat41.sh.in b/www/jakarta-tomcat41/files/tomcat41.sh.in
index dac2e79731df..105bcae155c7 100644
--- a/www/jakarta-tomcat41/files/tomcat41.sh.in
+++ b/www/jakarta-tomcat41/files/tomcat41.sh.in
@@ -105,7 +105,14 @@ java_command="%%LOCALBASE%%/bin/java \
log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
2>> ${tomcat%%TOMCAT_VERSION%%_stderr_log} "
-procname="*java"
+# Subvert the check_pid_file procname check.
+if [ -f $pidfile ]; then
+ read rc_pid junk < $pidfile
+ if [ ! -z "$rc_pid" ]; then
+ procname=`ps -o command= $rc_pid | cut -d ' ' -f 1`
+ fi
+fi
+
required_files="${tomcat%%TOMCAT_VERSION%%_catalina_home}/conf/server.xml"
command="/usr/sbin/daemon"
diff --git a/www/jakarta-tomcat5/Makefile b/www/jakarta-tomcat5/Makefile
index a2026fbe6eff..5e129832d988 100644
--- a/www/jakarta-tomcat5/Makefile
+++ b/www/jakarta-tomcat5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jakarta-tomcat
PORTVERSION= 5.0.30
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
diff --git a/www/jakarta-tomcat5/files/tomcat50.sh.in b/www/jakarta-tomcat5/files/tomcat50.sh.in
index dac2e79731df..105bcae155c7 100644
--- a/www/jakarta-tomcat5/files/tomcat50.sh.in
+++ b/www/jakarta-tomcat5/files/tomcat50.sh.in
@@ -105,7 +105,14 @@ java_command="%%LOCALBASE%%/bin/java \
log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
2>> ${tomcat%%TOMCAT_VERSION%%_stderr_log} "
-procname="*java"
+# Subvert the check_pid_file procname check.
+if [ -f $pidfile ]; then
+ read rc_pid junk < $pidfile
+ if [ ! -z "$rc_pid" ]; then
+ procname=`ps -o command= $rc_pid | cut -d ' ' -f 1`
+ fi
+fi
+
required_files="${tomcat%%TOMCAT_VERSION%%_catalina_home}/conf/server.xml"
command="/usr/sbin/daemon"
diff --git a/www/tomcat41/Makefile b/www/tomcat41/Makefile
index db7b44a561c5..c099ddd51f16 100644
--- a/www/tomcat41/Makefile
+++ b/www/tomcat41/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jakarta-tomcat
PORTVERSION= 4.1.31
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-4/v${PORTVERSION}/bin
diff --git a/www/tomcat41/files/tomcat41.sh.in b/www/tomcat41/files/tomcat41.sh.in
index dac2e79731df..105bcae155c7 100644
--- a/www/tomcat41/files/tomcat41.sh.in
+++ b/www/tomcat41/files/tomcat41.sh.in
@@ -105,7 +105,14 @@ java_command="%%LOCALBASE%%/bin/java \
log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
2>> ${tomcat%%TOMCAT_VERSION%%_stderr_log} "
-procname="*java"
+# Subvert the check_pid_file procname check.
+if [ -f $pidfile ]; then
+ read rc_pid junk < $pidfile
+ if [ ! -z "$rc_pid" ]; then
+ procname=`ps -o command= $rc_pid | cut -d ' ' -f 1`
+ fi
+fi
+
required_files="${tomcat%%TOMCAT_VERSION%%_catalina_home}/conf/server.xml"
command="/usr/sbin/daemon"
diff --git a/www/tomcat55/Makefile b/www/tomcat55/Makefile
index 0ace200106e2..7616322cf390 100644
--- a/www/tomcat55/Makefile
+++ b/www/tomcat55/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
diff --git a/www/tomcat55/files/tomcat55.sh.in b/www/tomcat55/files/tomcat55.sh.in
index dac2e79731df..105bcae155c7 100644
--- a/www/tomcat55/files/tomcat55.sh.in
+++ b/www/tomcat55/files/tomcat55.sh.in
@@ -105,7 +105,14 @@ java_command="%%LOCALBASE%%/bin/java \
log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
2>> ${tomcat%%TOMCAT_VERSION%%_stderr_log} "
-procname="*java"
+# Subvert the check_pid_file procname check.
+if [ -f $pidfile ]; then
+ read rc_pid junk < $pidfile
+ if [ ! -z "$rc_pid" ]; then
+ procname=`ps -o command= $rc_pid | cut -d ' ' -f 1`
+ fi
+fi
+
required_files="${tomcat%%TOMCAT_VERSION%%_catalina_home}/conf/server.xml"
command="/usr/sbin/daemon"
diff --git a/www/tomcat6/Makefile b/www/tomcat6/Makefile
index 0ace200106e2..7616322cf390 100644
--- a/www/tomcat6/Makefile
+++ b/www/tomcat6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
diff --git a/www/tomcat6/files/tomcat55.sh.in b/www/tomcat6/files/tomcat55.sh.in
index dac2e79731df..105bcae155c7 100644
--- a/www/tomcat6/files/tomcat55.sh.in
+++ b/www/tomcat6/files/tomcat55.sh.in
@@ -105,7 +105,14 @@ java_command="%%LOCALBASE%%/bin/java \
log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
2>> ${tomcat%%TOMCAT_VERSION%%_stderr_log} "
-procname="*java"
+# Subvert the check_pid_file procname check.
+if [ -f $pidfile ]; then
+ read rc_pid junk < $pidfile
+ if [ ! -z "$rc_pid" ]; then
+ procname=`ps -o command= $rc_pid | cut -d ' ' -f 1`
+ fi
+fi
+
required_files="${tomcat%%TOMCAT_VERSION%%_catalina_home}/conf/server.xml"
command="/usr/sbin/daemon"
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index 0ace200106e2..7616322cf390 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
diff --git a/www/tomcat7/files/tomcat55.sh.in b/www/tomcat7/files/tomcat55.sh.in
index dac2e79731df..105bcae155c7 100644
--- a/www/tomcat7/files/tomcat55.sh.in
+++ b/www/tomcat7/files/tomcat55.sh.in
@@ -105,7 +105,14 @@ java_command="%%LOCALBASE%%/bin/java \
log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
2>> ${tomcat%%TOMCAT_VERSION%%_stderr_log} "
-procname="*java"
+# Subvert the check_pid_file procname check.
+if [ -f $pidfile ]; then
+ read rc_pid junk < $pidfile
+ if [ ! -z "$rc_pid" ]; then
+ procname=`ps -o command= $rc_pid | cut -d ' ' -f 1`
+ fi
+fi
+
required_files="${tomcat%%TOMCAT_VERSION%%_catalina_home}/conf/server.xml"
command="/usr/sbin/daemon"