aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2012-05-31 17:14:00 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2012-05-31 17:14:00 +0000
commit76bb805690a45734136285abeed865efb7b0ccba (patch)
treea2fa83c4b35fab13905168fc8ba46ac32035d0b5
parent8b053f764ac67e3114e9dbda5e3795da8738e46c (diff)
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/bulk_extractor/Makefile34
-rw-r--r--sysutils/bulk_extractor/distinfo2
-rw-r--r--sysutils/bulk_extractor/files/patch-configure.ac17
-rw-r--r--sysutils/bulk_extractor/files/patch-src_scan_net.cpp21
-rw-r--r--sysutils/bulk_extractor/pkg-descr9
6 files changed, 84 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c78687275433..1700d593d7e3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -86,6 +86,7 @@
SUBDIR += bsdstats
SUBDIR += bubblemon-dockapp
SUBDIR += bubblemon2
+ SUBDIR += bulk_extractor
SUBDIR += burn
SUBDIR += busybox
SUBDIR += byobu
diff --git a/sysutils/bulk_extractor/Makefile b/sysutils/bulk_extractor/Makefile
new file mode 100644
index 000000000000..1574ac14b568
--- /dev/null
+++ b/sysutils/bulk_extractor/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: bulk_extractor
+# Date created: 31 May 2012
+# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bulk_extractor
+PORTVERSION= 1.2.2
+CATEGORIES= sysutils
+MASTER_SITES= http://cloud.github.com/downloads/simsong/bulk_extractor/
+
+MAINTAINER= nobutaka@FreeBSD.org
+COMMENT= A program that scans a disk image and extracts useful information
+
+LICENSE= PD
+LICENSE_NAME= public domain
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
+
+LIB_DEPENDS= afflib:${PORTSDIR}/sysutils/afflib \
+ ewf:${PORTSDIR}/devel/libewf \
+ exiv2:${PORTSDIR}/graphics/exiv2 \
+ expat:${PORTSDIR}/textproc/expat2
+
+USE_AUTOTOOLS= autoconf
+USE_OPENSSL= yes
+USE_PYTHON= yes
+
+MAN1= bulk_extractor.1
+
+PLIST_FILES= bin/bulk_extractor
+
+.include <bsd.port.mk>
diff --git a/sysutils/bulk_extractor/distinfo b/sysutils/bulk_extractor/distinfo
new file mode 100644
index 000000000000..be9fa7d3e475
--- /dev/null
+++ b/sysutils/bulk_extractor/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bulk_extractor-1.2.2.tar.gz) = d53cd3586d7a980fbf8e37eeb7b332a6a1f70f126bd4b2c831be6377b33412cb
+SIZE (bulk_extractor-1.2.2.tar.gz) = 2348436
diff --git a/sysutils/bulk_extractor/files/patch-configure.ac b/sysutils/bulk_extractor/files/patch-configure.ac
new file mode 100644
index 000000000000..ed13124c0e31
--- /dev/null
+++ b/sysutils/bulk_extractor/files/patch-configure.ac
@@ -0,0 +1,17 @@
+--- configure.ac.orig 2012-04-30 02:24:19.000000000 +0900
++++ configure.ac 2012-04-30 02:24:27.000000000 +0900
+@@ -371,12 +371,14 @@
+ AC_CHECK_LIB([expat],[XML_ParserCreate])
+ fi
+
++AC_LANG_PUSH(C++)
+ if test "${exiv2}" != "no" ; then
+ dnl check to see if we have the relevant headers
+ AC_CHECK_HEADER([exiv2/image.hpp])
+ AC_CHECK_HEADER([exiv2/exif.hpp])
+ AC_CHECK_HEADER([exiv2/error.hpp])
+ fi
++AC_LANG_POP()
+
+ AC_TRY_COMPILE([#pragma GCC diagnostic ignored "-Wshadow"],[],
+ [AC_DEFINE(GNUC_HAS_DIAGNOSTIC_PRAGMA,1,[define 1 if GCC supports #pragma GCC diagnostic])]
diff --git a/sysutils/bulk_extractor/files/patch-src_scan_net.cpp b/sysutils/bulk_extractor/files/patch-src_scan_net.cpp
new file mode 100644
index 000000000000..ac0e3e961760
--- /dev/null
+++ b/sysutils/bulk_extractor/files/patch-src_scan_net.cpp
@@ -0,0 +1,21 @@
+--- src/scan_net.cpp.orig 2012-04-30 02:52:53.000000000 +0900
++++ src/scan_net.cpp 2012-04-30 02:53:04.000000000 +0900
+@@ -28,6 +28,7 @@
+ #include <tr1/unordered_set>
+
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <ctype.h>
+@@ -233,8 +234,8 @@
+ u_int8_t ip_ttl; /* time to live */
+ u_int8_t ip_p; /* protocol */
+ u_short ip_sum; /* checksum */
+- uint32_t ip_src;
+- uint32_t ip_dst; /* source and dest address */
++ struct in_addr ip_src;
++ struct in_addr ip_dst; /* source and dest address */
+ };
+ #endif
+
diff --git a/sysutils/bulk_extractor/pkg-descr b/sysutils/bulk_extractor/pkg-descr
new file mode 100644
index 000000000000..fffed144d105
--- /dev/null
+++ b/sysutils/bulk_extractor/pkg-descr
@@ -0,0 +1,9 @@
+bulk_extractor is a C++ program that scans a disk image, a file,
+or a directory of files and extracts useful information without
+parsing the file system or file system structures. The results are
+stored in feature files that can be easily inspected, parsed, or
+processed with automated tools. bulk_extractor also creates
+histograms of features that it finds, as features that are more
+common tend to be more important.
+
+WWW: https://github.com/simsong/bulk_extractor