aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2007-08-21 07:45:44 +0000
committerAndrej Zverev <az@FreeBSD.org>2007-08-21 07:45:44 +0000
commit7ab398f130fb6e4ad8fb6ca983fe2b75e89bf570 (patch)
tree9b1c02856aca7252ca7f6080cad0894a2288c8f2
parent8f002b6c5df8ec2548d2bd2bf05abaddefa2b6cd (diff)
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cvs-syncmail/Makefile49
-rw-r--r--devel/cvs-syncmail/distinfo3
-rw-r--r--devel/cvs-syncmail/pkg-descr6
4 files changed, 59 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 147b99197e01..5491e2847965 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -197,6 +197,7 @@
SUBDIR += cut
SUBDIR += cutils
SUBDIR += cvs+ipv6
+ SUBDIR += cvs-syncmail
SUBDIR += cvs2cl
SUBDIR += cvs2darcs
SUBDIR += cvs2html
diff --git a/devel/cvs-syncmail/Makefile b/devel/cvs-syncmail/Makefile
new file mode 100644
index 000000000000..7c15c6ebf1b1
--- /dev/null
+++ b/devel/cvs-syncmail/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: cvs-syncmail
+# Date created: 13 August 2007
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvs-syncmail
+PORTVERSION= 2.1
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= syncmail
+EXTRACT_SUFX=
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= CVS notification tool
+
+.if defined(WITH_CVSNT)
+# Use the CVSNT binary when generating diffs instead of the system CVS
+RUN_DEPENDS= ${LOCALBASE}/bin/cvsnt:${PORTSDIR}/devel/cvsnt
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PYTHON= 2.0+
+
+PLIST_FILES= bin/${DISTNAME}
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+do-patch:
+ @${REINPLACE_CMD} -e "s| /usr/bin/python|${PYTHON_CMD}|" \
+ ${WRKSRC}/${DISTNAME}
+
+ @${REINPLACE_CMD} -e "s|cvs -fn update|/usr/bin/cvs -fn update|" \
+ ${WRKSRC}/${DISTNAME}
+
+.if defined(WITH_CVSNT)
+ @${REINPLACE_CMD} -e "s|/usr/bin/cvs|${LOCALBASE}/bin/cvsnt|" \
+ ${WRKSRC}/${DISTNAME}
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${DISTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/cvs-syncmail/distinfo b/devel/cvs-syncmail/distinfo
new file mode 100644
index 000000000000..113d6d1a18ba
--- /dev/null
+++ b/devel/cvs-syncmail/distinfo
@@ -0,0 +1,3 @@
+MD5 (syncmail) = 103292e14c12a7cf2ac5d75e6681546f
+SHA256 (syncmail) = f86a6cc92420a3dcdfbdea05874974fd2af6c178afac96ad84e3a91844811f3a
+SIZE (syncmail) = 13734
diff --git a/devel/cvs-syncmail/pkg-descr b/devel/cvs-syncmail/pkg-descr
new file mode 100644
index 000000000000..c428fa188031
--- /dev/null
+++ b/devel/cvs-syncmail/pkg-descr
@@ -0,0 +1,6 @@
+Syncmail is a CVS notification tool which can provide a diff for every
+change to a CVS repository, mailed to specified email addresses.
+This tool is useful for large communities to monitor activity,
+and is used for Python and many other active projects.
+
+WWW: http://sourceforge.net/projects/cvs-syncmail