aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-06-12 15:14:18 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-06-12 15:14:18 +0000
commit7cef57ebd9e6eec97668e258ba3e82ce6e59dab5 (patch)
tree629e5401a7376dcaf5f46ab8fba04a8b03aab549
parenta6ff76fde01700e1ee5524c36e0883ef2c49b584 (diff)
Notes
-rw-r--r--devel/Makefile2
-rw-r--r--devel/libpeas/Makefile52
-rw-r--r--devel/libpeas/files/patch-Makefile.in6
-rw-r--r--devel/libpeas/files/patch-loaders_python3_Makefile.in20
-rw-r--r--devel/libpeas/files/patch-loaders_python_Makefile.in20
-rw-r--r--devel/libpeas/pkg-plist5
-rw-r--r--devel/py-libpeas/Makefile22
-rw-r--r--devel/py-libpeas/pkg-plist1
-rw-r--r--devel/py3-libpeas/Makefile22
-rw-r--r--devel/py3-libpeas/pkg-plist1
-rw-r--r--editors/gedit-plugins/Makefile5
-rw-r--r--editors/gedit/Makefile4
-rw-r--r--graphics/entangle/Makefile7
-rw-r--r--graphics/eog-plugins/Makefile2
-rw-r--r--multimedia/totem/Makefile5
15 files changed, 144 insertions, 30 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 49addfe4ae27..baceb05d703e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3946,6 +3946,7 @@
SUBDIR += py-lazy
SUBDIR += py-levenshtein
SUBDIR += py-liblarch
+ SUBDIR += py-libpeas
SUBDIR += py-libplist
SUBDIR += py-libvirt
SUBDIR += py-ll-core
@@ -4284,6 +4285,7 @@
SUBDIR += py-zope.viewlet
SUBDIR += py3-dbus
SUBDIR += py3-gobject3
+ SUBDIR += py3-libpeas
SUBDIR += py3-xdg
SUBDIR += py_static_check
SUBDIR += pybugz
diff --git a/devel/libpeas/Makefile b/devel/libpeas/Makefile
index 215e737e4e10..d5ca70809512 100644
--- a/devel/libpeas/Makefile
+++ b/devel/libpeas/Makefile
@@ -1,21 +1,28 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/devel/libpeas/Makefile 19947 2014-10-15 05:54:00Z gusi $
PORTNAME= libpeas
PORTVERSION= 1.12.1
-PORTREVISION= 1
+PORTREVISION?= 2
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
-MAINTAINER= kwm@FreeBSD.org
-COMMENT= Next evolution of the Gedit plugins engine
+MAINTAINER= gnome@FreeBSD.org
+COMMENT?= Next evolution of the Gedit plugins engine
BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
-USES= gettext gmake libtool pathfix pkgconfig \
- python:3 tar:xz
+LIBPEAS_SLAVE?= no
+
+.if ${LIBPEAS_SLAVE} == no
+PORTSCOUT= limitw:1,even
+.else
+LIB_DEPENDS+= libpeas-1.0.so:${PORTSDIR}/devel/libpeas
+PORTSCOUT= ignore:1
+.endif
+
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
USE_GNOME= gtk30 intlhack introspection:build
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
@@ -23,18 +30,35 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-CONFIGURE_ARGS+=--disable-glade-catalog \
- --disable-python2
+CONFIGURE_ARGS+=--disable-glade-catalog
+PLIST= ${.CURDIR}/pkg-plist
+.if ${LIBPEAS_SLAVE} == no
OPTIONS_SUB= yes
-OPTIONS_DEFINE= PYTHON SEED
-OPTIONS_DEFAULT=PYTHON SEED
+OPTIONS_DEFINE= SEED
+OPTIONS_DEFAULT=SEED
SEED_DESC= JavaScript support based on webkit-gtk3
SEED_LIB_DEPENDS= libseed-gtk3.so:${PORTSDIR}/devel/seed
-SEED_CONFIGURE_ENABLE= seed
-PYTHON_USE= GNOME=py3gobject3
-PYTHON_CONFIGURE_ENABLE= python3
+SEED_CONFIGURE_ENABLE= seed
+.else
+CONFIGURE_ARGS+= --disable-seed
+.endif
+
+.if ${LIBPEAS_SLAVE} == python2
+USES+= python:2
+USE_GNOME+= pygobject3
+.else
+CONFIGURE_ARGS+= --disable-python2
+.endif
+
+.if ${LIBPEAS_SLAVE} == python3
+USES+= python:3
+USE_GNOME+= py3gobject3
+.else
+CONFIGURE_ARGS+= --disable-python3
+.endif
-PLIST_SUB+= PYVER=${PYTHON_VER:S/.//}
+# lua needs lua 5.1 and devel/lua-lgi. The latter is build for lua 5.2 however..
+CONFIGURE_ARGS+= --disable-lua5.1 --disable-luajit
.include <bsd.port.mk>
diff --git a/devel/libpeas/files/patch-Makefile.in b/devel/libpeas/files/patch-Makefile.in
index aedda64cade2..29aa5e77e881 100644
--- a/devel/libpeas/files/patch-Makefile.in
+++ b/devel/libpeas/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2012-05-25 22:12:44.000000000 +0200
-+++ Makefile.in 2012-05-25 22:12:52.000000000 +0200
-@@ -328,7 +328,7 @@
+--- Makefile.in.orig 2015-05-17 08:39:30.610386000 +0200
++++ Makefile.in 2015-05-17 08:41:22.473716000 +0200
+@@ -406,7 +406,7 @@
top_srcdir = @top_srcdir@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-glade-catalog
diff --git a/devel/libpeas/files/patch-loaders_python3_Makefile.in b/devel/libpeas/files/patch-loaders_python3_Makefile.in
new file mode 100644
index 000000000000..7342d9e4d088
--- /dev/null
+++ b/devel/libpeas/files/patch-loaders_python3_Makefile.in
@@ -0,0 +1,20 @@
+--- loaders/python3/Makefile.in.orig 2015-04-01 09:02:28.737155000 +0200
++++ loaders/python3/Makefile.in 2015-04-01 09:02:51.423432000 +0200
+@@ -126,7 +126,7 @@
+ LTLIBRARIES = $(loader_LTLIBRARIES)
+ am__DEPENDENCIES_1 =
+ libpython3loader_la_DEPENDENCIES = \
+- $(top_builddir)/libpeas/libpeas-1.0.la $(am__DEPENDENCIES_1) \
++ $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
+ am_libpython3loader_la_OBJECTS = peas-plugin-loader-python.lo \
+ peas-python-internal.lo peas-python3-resources.lo
+@@ -436,7 +436,7 @@
+ $(PYTHON3_LDFLAGS)
+
+ libpython3loader_la_LIBADD = \
+- $(top_builddir)/libpeas/libpeas-1.0.la \
++ -lpeas-1.0 \
+ $(PEAS_LIBS) \
+ $(PYGOBJECT_LIBS) \
+ $(PYTHON3_LIBS)
diff --git a/devel/libpeas/files/patch-loaders_python_Makefile.in b/devel/libpeas/files/patch-loaders_python_Makefile.in
new file mode 100644
index 000000000000..f85b29938f94
--- /dev/null
+++ b/devel/libpeas/files/patch-loaders_python_Makefile.in
@@ -0,0 +1,20 @@
+--- loaders/python/Makefile.in.orig 2015-04-01 09:00:01.465820000 +0200
++++ loaders/python/Makefile.in 2015-04-01 09:00:34.614747000 +0200
+@@ -126,7 +126,7 @@
+ LTLIBRARIES = $(loader_LTLIBRARIES)
+ am__DEPENDENCIES_1 =
+ libpythonloader_la_DEPENDENCIES = \
+- $(top_builddir)/libpeas/libpeas-1.0.la $(am__DEPENDENCIES_1) \
++ $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
+ am_libpythonloader_la_OBJECTS = peas-plugin-loader-python.lo \
+ peas-python-internal.lo peas-python-resources.lo
+@@ -436,7 +436,7 @@
+ $(PYTHON2_LDFLAGS)
+
+ libpythonloader_la_LIBADD = \
+- $(top_builddir)/libpeas/libpeas-1.0.la \
++ -lpeas-1.0 \
+ $(PEAS_LIBS) \
+ $(PYGOBJECT_LIBS) \
+ $(PYTHON2_LIBS)
diff --git a/devel/libpeas/pkg-plist b/devel/libpeas/pkg-plist
index 11f507ee0d6c..02e73bc7f2a9 100644
--- a/devel/libpeas/pkg-plist
+++ b/devel/libpeas/pkg-plist
@@ -16,17 +16,12 @@ lib/girepository-1.0/PeasGtk-1.0.typelib
lib/libpeas-1.0.so
lib/libpeas-1.0.so.0
lib/libpeas-1.0.so.0.1201.0
-%%PYTHON%%lib/libpeas-1.0/loaders/libpython3loader.so
%%SEED%%lib/libpeas-1.0/loaders/libseedloader.so
lib/libpeas-gtk-1.0.so
lib/libpeas-gtk-1.0.so.0
lib/libpeas-gtk-1.0.so.0.1201.0
lib/peas-demo/plugins/helloworld/helloworld.plugin
lib/peas-demo/plugins/helloworld/libhelloworld.so
-%%PYTHON%%lib/peas-demo/plugins/pythonhello/__pycache__/pythonhello.cpython-%%PYVER%%.pyc
-%%PYTHON%%lib/peas-demo/plugins/pythonhello/__pycache__/pythonhello.cpython-%%PYVER%%.pyo
-%%PYTHON%%lib/peas-demo/plugins/pythonhello/pythonhello.plugin
-%%PYTHON%%lib/peas-demo/plugins/pythonhello/pythonhello.py
lib/peas-demo/plugins/secondtime/libsecondtime.so
lib/peas-demo/plugins/secondtime/secondtime.plugin
%%SEED%%lib/peas-demo/plugins/seedhello/seedhello.js
diff --git a/devel/py-libpeas/Makefile b/devel/py-libpeas/Makefile
new file mode 100644
index 000000000000..23a19274bf5e
--- /dev/null
+++ b/devel/py-libpeas/Makefile
@@ -0,0 +1,22 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libpeas
+PORTREVISION= 0
+CATEGORIES= devel gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+COMMENT= libpeas Python 2 support
+
+LIB_DEPENDS+= libpeas-1.0.so:${PORTSDIR}/devel/libpeas
+
+LIBPEAS_SLAVE= python2
+
+BUILD_WRKSRC= ${WRKSRC}/loaders/python
+INSTALL_WRKSRC= ${WRKSRC}/loaders/python
+
+MASTERDIR= ${.CURDIR}/../../devel/libpeas/
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/py-libpeas/pkg-plist b/devel/py-libpeas/pkg-plist
new file mode 100644
index 000000000000..61ff5753db91
--- /dev/null
+++ b/devel/py-libpeas/pkg-plist
@@ -0,0 +1 @@
+lib/libpeas-1.0/loaders/libpythonloader.so
diff --git a/devel/py3-libpeas/Makefile b/devel/py3-libpeas/Makefile
new file mode 100644
index 000000000000..dd2da3356167
--- /dev/null
+++ b/devel/py3-libpeas/Makefile
@@ -0,0 +1,22 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libpeas
+PORTREVISION= 0
+CATEGORIES= devel gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+COMMENT= libpeas Python 3 support
+
+LIB_DEPENDS+= libpeas-1.0.so:${PORTSDIR}/devel/libpeas
+
+LIBPEAS_SLAVE= python3
+
+BUILD_WRKSRC= ${WRKSRC}/loaders/python3
+INSTALL_WRKSRC= ${WRKSRC}/loaders/python3
+
+MASTERDIR= ${.CURDIR}/../../devel/libpeas/
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/py3-libpeas/pkg-plist b/devel/py3-libpeas/pkg-plist
new file mode 100644
index 000000000000..6c9c9ecb5280
--- /dev/null
+++ b/devel/py3-libpeas/pkg-plist
@@ -0,0 +1 @@
+lib/libpeas-1.0/loaders/libpython3loader.so
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index 8b5bae29fd69..9d7eb01f5951 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gedit-plugins
PORTVERSION= 3.14.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -41,7 +41,8 @@ PYTHON_DESC= Build plugins that depend on python
USES+= python
BUILD_DEPENDS+= py3?-dbus>=0:${PORTSDIR}/devel/py3-dbus
LIB_DEPENDS+= libgucharmap_2_90.so:${PORTSDIR}/deskutils/gucharmap
-RUN_DEPENDS+= py3?-dbus>=0:${PORTSDIR}/devel/py3-dbus
+RUN_DEPENDS+= py3?-dbus>=0:${PORTSDIR}/devel/py3-dbus \
+ ${PYTHON_PKGNAMEPREFIX}libpeas>=0:${PORTSDIR}/devel/py3-libpeas
USE_GNOME+= vte3
CONFIGURE_ARGS+=--enable-python
GLIB_SCHEMAS+= org.gnome.gedit.plugins.terminal.gschema.xml
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 5e35de9515da..ea1c44c3e79f 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gedit
PORTVERSION= 3.14.3
+PORTREVISION= 1
CATEGORIES= editors gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -19,7 +20,8 @@ LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant \
libpeas-gtk-1.0.so:${PORTSDIR}/devel/libpeas \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup
RUN_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes \
- gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
+ gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas \
+ ${PYTHON_PKGNAMEPREFIX}libpeas>=0:${PORTSDIR}/devel/py3-libpeas
USES= desktop-file-utils gettext gmake libtool \
pathfix pkgconfig python:3 tar:xz
diff --git a/graphics/entangle/Makefile b/graphics/entangle/Makefile
index e9abdaeeee3f..c87fe1cb4701 100644
--- a/graphics/entangle/Makefile
+++ b/graphics/entangle/Makefile
@@ -3,7 +3,7 @@
PORTNAME= entangle
DISTVERSION= 0.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://entangle-photo.org/download/sources/
@@ -20,9 +20,10 @@ LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2 \
libgexiv2.so:${PORTSDIR}/graphics/gexiv2 \
libraw_r.so:${PORTSDIR}/graphics/libraw \
libpeas-1.0.so:${PORTSDIR}/devel/libpeas
-RUN_DEPENDS:= ${BUILD_DEPENDS:Nitstool*}
+RUN_DEPENDS:= ${BUILD_DEPENDS:Nitstool*} \
+ ${PYTHON_PKGNAMEPREFIX}libpeas>=0:${PORTSDIR}/devel/py3-libpeas
-USES= gettext-tools gmake libtool pkgconfig
+USES= gettext-tools gmake libtool pkgconfig python:3
GNU_CONFIGURE= yes
USE_GNOME= gtk30 introspection:build
GLIB_SCHEMAS= org.entangle-photo.manager.gschema.xml
diff --git a/graphics/eog-plugins/Makefile b/graphics/eog-plugins/Makefile
index e57977c2d32a..2348c73d9a2e 100644
--- a/graphics/eog-plugins/Makefile
+++ b/graphics/eog-plugins/Makefile
@@ -4,6 +4,7 @@
PORTNAME= eog-plugins
PORTVERSION= 3.14.2
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -42,6 +43,7 @@ PLIST_SUB+= CHAMPLAIN="@comment "
PLIST_SUB+= PYVER=${PYTHON_VER:S|.||}
.if ${PORT_OPTIONS:MPYTHON}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}libpeas>=0:${PORTSDIR}/devel/py3-libpeas
CONFIGURE_ARGS+=--enable-python
USES+= python:3
PLIST_SUB+= PYTHON=""
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 7da03cd11fdc..bee13080533a 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -4,7 +4,7 @@
PORTNAME= totem
PORTVERSION= 3.14.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -27,7 +27,8 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-co
${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme \
gnome-settings-daemon>=2.91.0:${PORTSDIR}/sysutils/gnome-settings-daemon \
gnome-icon-theme-symbolic>=2.91.0:${PORTSDIR}/x11-themes/gnome-icon-theme-symbolic \
- grilo-plugins>=0:${PORTSDIR}/net/grilo-plugins
+ grilo-plugins>=0:${PORTSDIR}/net/grilo-plugins \
+ ${PYTHON_PKGNAMEPREFIX}libpeas>=0:${PORTSDIR}/devel/py3-libpeas
USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
python:3 shebangfix tar:xz