aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2014-05-24 15:11:55 +0000
committerTim Bishop <tdb@FreeBSD.org>2014-05-24 15:11:55 +0000
commit7fe45138460596797de367b34acc90e99f4a0498 (patch)
treea3e741b63502d9384e8e5ae780456149a018a1f9
parente9dbe8a346b78ef93aa068fe7193848c26ddd933 (diff)
downloadports-7fe45138460596797de367b34acc90e99f4a0498.tar.gz
ports-7fe45138460596797de367b34acc90e99f4a0498.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/self-service-password/Makefile35
-rw-r--r--net/self-service-password/distinfo2
-rw-r--r--net/self-service-password/files/pkg-message.in21
-rw-r--r--net/self-service-password/pkg-descr6
-rw-r--r--net/self-service-password/pkg-plist38
6 files changed, 103 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b0ef779a7661..fdfb09ef6e95 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1079,6 +1079,7 @@
SUBDIR += sdl2_net
SUBDIR += sdl_net
SUBDIR += seda
+ SUBDIR += self-service-password
SUBDIR += sendemail
SUBDIR += sendfile
SUBDIR += sendsms
diff --git a/net/self-service-password/Makefile b/net/self-service-password/Makefile
new file mode 100644
index 000000000000..64416b3f8582
--- /dev/null
+++ b/net/self-service-password/Makefile
@@ -0,0 +1,35 @@
+# Created by: Krzysztof Stryjek <ports@bsdserwis.com>
+# $FreeBSD$
+
+PORTNAME= self-service-password
+PORTVERSION= 0.8
+CATEGORIES= net www
+MASTER_SITES= http://tools.ltb-project.org/attachments/download/497/
+DISTNAME= ltb-project-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@bsdserwis.com
+COMMENT= A set of PHP-scripts to change LDAP password over the web
+
+LICENSE= GPLv2
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+USE_PHP= ldap openssl session hash mhash mcrypt mbstring filter
+
+WANT_PHP_WEB= yes
+
+CFGDIR= conf
+CFGFILE= config.inc.php
+
+SUB_LIST+= PKGNAME=${PKGNAME}
+SUB_FILES= pkg-message
+
+post-extract:
+ @${MV} ${WRKSRC}/${CFGDIR}/${CFGFILE} ${WRKSRC}/${CFGDIR}/${CFGFILE}.sample
+
+do-install:
+ @cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}/
+
+.include <bsd.port.mk>
diff --git a/net/self-service-password/distinfo b/net/self-service-password/distinfo
new file mode 100644
index 000000000000..4e48c0a4e68c
--- /dev/null
+++ b/net/self-service-password/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ltb-project-self-service-password-0.8.tar.gz) = e26d299ed6d2352056d545c3c5c826d296ff7a6152434db25196982dc14359d3
+SIZE (ltb-project-self-service-password-0.8.tar.gz) = 63084
diff --git a/net/self-service-password/files/pkg-message.in b/net/self-service-password/files/pkg-message.in
new file mode 100644
index 000000000000..c7526768f4b7
--- /dev/null
+++ b/net/self-service-password/files/pkg-message.in
@@ -0,0 +1,21 @@
+
+%%PKGNAME%% has been installed into:
+
+ %%WWWDIR%%
+
+Please edit config.inc.php to suit your needs.
+
+To make Self Service Password available through your web site, I suggest that
+you add something like the following to httpd.conf:
+
+ Alias /ssp/ "%%WWWDIR%%/"
+
+ <Directory "%%WWWDIR%%">
+ Options none
+ AllowOverride none
+
+ Order Deny,Allow
+ Deny from all
+ Allow from 127.0.0.1 .example.com
+ </Directory>
+
diff --git a/net/self-service-password/pkg-descr b/net/self-service-password/pkg-descr
new file mode 100644
index 000000000000..31e872634758
--- /dev/null
+++ b/net/self-service-password/pkg-descr
@@ -0,0 +1,6 @@
+Self Service Password is a web-based LDAP client. It provides easy,
+anywhere-accessible, multi-language service to change your LDAP password.
+Since it is a web application, this LDAP browser works on many platforms,
+making change of your LDAP/AD password accessible from any location.
+
+WWW: http://ltb-project.org/wiki/documentation/self-service-password/latest/start
diff --git a/net/self-service-password/pkg-plist b/net/self-service-password/pkg-plist
new file mode 100644
index 000000000000..bece8b543d18
--- /dev/null
+++ b/net/self-service-password/pkg-plist
@@ -0,0 +1,38 @@
+@sample %%WWWDIR%%/conf/config.inc.php.sample
+%%WWWDIR%%/index.php
+%%WWWDIR%%/lang/ca.inc.php
+%%WWWDIR%%/lang/de.inc.php
+%%WWWDIR%%/lang/en.inc.php
+%%WWWDIR%%/lang/es.inc.php
+%%WWWDIR%%/lang/fr.inc.php
+%%WWWDIR%%/lang/it.inc.php
+%%WWWDIR%%/lang/nl.inc.php
+%%WWWDIR%%/lang/pl.inc.php
+%%WWWDIR%%/lang/pt-BR.inc.php
+%%WWWDIR%%/lang/ru.inc.php
+%%WWWDIR%%/lib/detectbrowserlanguage.php
+%%WWWDIR%%/lib/functions.inc.php
+%%WWWDIR%%/lib/recaptchalib.php
+%%WWWDIR%%/pages/change.php
+%%WWWDIR%%/pages/resetbyquestions.php
+%%WWWDIR%%/pages/resetbytoken.php
+%%WWWDIR%%/pages/sendsms.php
+%%WWWDIR%%/pages/sendtoken.php
+%%WWWDIR%%/pages/setquestions.php
+%%WWWDIR%%/style/accept.png
+%%WWWDIR%%/style/email.png
+%%WWWDIR%%/style/error.png
+%%WWWDIR%%/style/exclamation.png
+%%WWWDIR%%/style/favicon.ico
+%%WWWDIR%%/style/help.png
+%%WWWDIR%%/style/key.png
+%%WWWDIR%%/style/light.png
+%%WWWDIR%%/style/ltb-logo.png
+%%WWWDIR%%/style/styles.css
+%%WWWDIR%%/style/user_suit.png
+@dirrm %%WWWDIR%%/pages
+@dirrm %%WWWDIR%%/conf
+@dirrm %%WWWDIR%%/style
+@dirrm %%WWWDIR%%/lang
+@dirrm %%WWWDIR%%/lib
+@dirrmtry %%WWWDIR%%