aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-11-13 14:50:39 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-11-13 14:50:39 +0000
commit9d205076787c9659fb5a83d0d576c64ddc24df36 (patch)
tree6120d4f36e7d7c7b73a4e978d1aae8e8ee46f1cb
parent56db876d7050f745d0ebeb9a197f885626e2c7e7 (diff)
downloadports-9d205076787c9659fb5a83d0d576c64ddc24df36.tar.gz
ports-9d205076787c9659fb5a83d0d576c64ddc24df36.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/Tee/Makefile40
-rw-r--r--sysutils/Tee/distinfo1
-rw-r--r--sysutils/Tee/pkg-comment1
-rw-r--r--sysutils/Tee/pkg-descr2
-rw-r--r--sysutils/Tee/pkg-plist1
6 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index eadec4a64538..4be39f15c1aa 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -4,6 +4,7 @@
SUBDIR += 3dm
SUBDIR += LPRng
SUBDIR += LPRngTool
+ SUBDIR += Tee
SUBDIR += abck
SUBDIR += afio
SUBDIR += ah-tty
diff --git a/sysutils/Tee/Makefile b/sysutils/Tee/Makefile
new file mode 100644
index 000000000000..21c65893048d
--- /dev/null
+++ b/sysutils/Tee/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Tee
+# Date created: Nov 1 2002
+# Whom: Stephen Gunn <csg@fedex.com>, <csg@waterspout.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tee
+PORTVERSION= 3.4
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.physics.purdue.edu/pub/pundits/ \
+ http://archive.progeny.com/pundits/
+DISTNAME= xapply-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= csg@fedex.com
+
+BUILD_DEPENDS= makeme:${PORTSDIR}/devel/msrc0 \
+ mkcmd:${PORTSDIR}/devel/mkcmd
+
+USE_REINPLACE= yes
+MAKE_FLAGS=
+MAKEFILE=
+MAN1= ${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,CFLAGS=,CFLAGS+=,' -e 's,^DEBUG,#DEBUG,'\
+ -e 's,gcc,${CC},' ${WRKSRC}/bin/Tee/Make.host
+
+do-build:
+ ( cd ${WRKSRC}/bin/${PORTNAME} && ${SETENV} ${MAKE_ENV} makeme \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET} )
+
+do-install:
+ ( cd ${WRKSRC}/bin/Tee && ${SETENV} ${MAKENV} makeme \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET} )
+ ${INSTALL_MAN} ${WRKSRC}/bin/${PORTNAME}/${PORTNAME}.man \
+ ${PREFIX}/man/man1/${PORTNAME}.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/Tee/distinfo b/sysutils/Tee/distinfo
new file mode 100644
index 000000000000..71994d72b2f5
--- /dev/null
+++ b/sysutils/Tee/distinfo
@@ -0,0 +1 @@
+MD5 (xapply-3.4.tgz) = 6e8b976cd3696c3d478e61104cc866e9
diff --git a/sysutils/Tee/pkg-comment b/sysutils/Tee/pkg-comment
new file mode 100644
index 000000000000..0d73638ff54f
--- /dev/null
+++ b/sysutils/Tee/pkg-comment
@@ -0,0 +1 @@
+An enhanced version of tee(1)
diff --git a/sysutils/Tee/pkg-descr b/sysutils/Tee/pkg-descr
new file mode 100644
index 000000000000..f0d7fe60fc21
--- /dev/null
+++ b/sysutils/Tee/pkg-descr
@@ -0,0 +1,2 @@
+Tee is an enhanced version of tee(1). Think of it as a switchboard
+for your pipeline, not just a Y-coupler.
diff --git a/sysutils/Tee/pkg-plist b/sysutils/Tee/pkg-plist
new file mode 100644
index 000000000000..842512dee648
--- /dev/null
+++ b/sysutils/Tee/pkg-plist
@@ -0,0 +1 @@
+bin/Tee