aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-04 11:07:26 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-04 11:07:26 +0000
commitb36c608d0dae2680469518758b8358e2ef0a0c7a (patch)
tree1bf18d22de795bf80e1123aeef3fbe222f8c9f16
parent3d2b0e285a074ae100671923ddf0e98f6a765488 (diff)
downloadports-b36c608d0dae2680469518758b8358e2ef0a0c7a.tar.gz
ports-b36c608d0dae2680469518758b8358e2ef0a0c7a.zip
Notes
-rw-r--r--net/p5-Net-Amazon/Makefile10
-rw-r--r--net/p5-Net-Hiveminder/Makefile10
-rw-r--r--net/p5-Net-MovableType/Makefile2
-rw-r--r--net/p5-Net-PcapUtils/Makefile2
-rw-r--r--net/p5-Net-Yadis/Makefile2
-rw-r--r--net/p5-SOAP-Lite-060/Makefile12
-rw-r--r--net/p5-Spread-Session/Makefile2
-rw-r--r--net/p5-X500-DN/Makefile2
8 files changed, 21 insertions, 21 deletions
diff --git a/net/p5-Net-Amazon/Makefile b/net/p5-Net-Amazon/Makefile
index 3300f34c4e8d..ca82269c9b86 100644
--- a/net/p5-Net-Amazon/Makefile
+++ b/net/p5-Net-Amazon/Makefile
@@ -17,10 +17,10 @@ COMMENT= Framework for accessing amazon.com via SOAP and XML/HTTP
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
- ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -30,7 +30,7 @@ PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500805
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS+= p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
.endif
.if ${PERL_LEVEL} < 501000
diff --git a/net/p5-Net-Hiveminder/Makefile b/net/p5-Net-Hiveminder/Makefile
index b8dd8c9596a3..d63c43f4ffd5 100644
--- a/net/p5-Net-Hiveminder/Makefile
+++ b/net/p5-Net-Hiveminder/Makefile
@@ -15,11 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to hiveminder.com
-RUN_DEPENDS= ${SITE_PERL}/Email/Simple/Creator.pm:${PORTSDIR}/mail/p5-Email-Simple \
- ${SITE_PERL}/${PERL_ARCH}/Moose.pm:${PORTSDIR}/devel/p5-Moose \
- ${SITE_PERL}/Term/Encoding.pm:${PORTSDIR}/devel/p5-Term-Encoding \
- ${SITE_PERL}/Net/Jifty.pm:${PORTSDIR}/net/p5-Net-Jifty \
- ${SITE_PERL}/Number/RecordLocator.pm:${PORTSDIR}/converters/p5-Number-RecordLocator
+RUN_DEPENDS= p5-Email-Simple>=0:${PORTSDIR}/mail/p5-Email-Simple \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Term-Encoding>=0:${PORTSDIR}/devel/p5-Term-Encoding \
+ p5-Net-Jifty>=0:${PORTSDIR}/net/p5-Net-Jifty \
+ p5-Number-RecordLocator>=0:${PORTSDIR}/converters/p5-Number-RecordLocator
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-MovableType/Makefile b/net/p5-Net-MovableType/Makefile
index 9dd50d9f5931..3f699671e795 100644
--- a/net/p5-Net-MovableType/Makefile
+++ b/net/p5-Net-MovableType/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A light-weight MovableType client Perl module
-BUILD_DEPENDS= ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+BUILD_DEPENDS= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-PcapUtils/Makefile b/net/p5-Net-PcapUtils/Makefile
index c83ae8ea6c0e..d2abb689301a 100644
--- a/net/p5-Net-PcapUtils/Makefile
+++ b/net/p5-Net-PcapUtils/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Utility routines for Net::Pcap module
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/Pcap.pm:${PORTSDIR}/net/p5-Net-Pcap
+BUILD_DEPENDS= p5-Net-Pcap>=0:${PORTSDIR}/net/p5-Net-Pcap
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-Yadis/Makefile b/net/p5-Net-Yadis/Makefile
index bdbacdb63fc0..a6fc60c37636 100644
--- a/net/p5-Net-Yadis/Makefile
+++ b/net/p5-Net-Yadis/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Yadis service discovery protocol, and parses XRDS xml documents
-RUN_DEPENDS= ${SITE_PERL}/XML/XPath.pm:${PORTSDIR}/textproc/p5-XML-XPath \
+RUN_DEPENDS= p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/net/p5-SOAP-Lite-060/Makefile b/net/p5-SOAP-Lite-060/Makefile
index 9f2934e38f8e..49539ba7396d 100644
--- a/net/p5-SOAP-Lite-060/Makefile
+++ b/net/p5-SOAP-Lite-060/Makefile
@@ -15,12 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= SOAP::Lite - Client and server side SOAP implementation
-RUN_DEPENDS= ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
- ${SITE_PERL}/MIME/Tools.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
- ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
- ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS= p5-MIME-Lite>=0:${PORTSDIR}/mail/p5-MIME-Lite \
+ p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
BUILD_DEPENDS= ${RUN_DEPENDS}
CONFLICTS= p5-SOAP-Lite-0.6[1-9]* p5-SOAP-Lite-0.[7-9]*
diff --git a/net/p5-Spread-Session/Makefile b/net/p5-Spread-Session/Makefile
index ca5a76f1c75a..6079ad2a1c7e 100644
--- a/net/p5-Spread-Session/Makefile
+++ b/net/p5-Spread-Session/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl OO wrapper for Spread messaging toolkit
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Spread.pm:${PORTSDIR}/net/spread
+BUILD_DEPENDS= spread>=0:${PORTSDIR}/net/spread
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-X500-DN/Makefile b/net/p5-X500-DN/Makefile
index b7870bdd8148..9b188be36eae 100644
--- a/net/p5-X500-DN/Makefile
+++ b/net/p5-X500-DN/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Handle X.500 DNs (Distinguished Names), parse and format them
-BUILD_DEPENDS= ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+BUILD_DEPENDS= p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes