aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-02-22 04:09:39 +0000
committerSteve Price <steve@FreeBSD.org>1999-02-22 04:09:39 +0000
commitcb427df05f096f0ca4442e0e96b0482610431214 (patch)
treef4a205077fd9ae12364eb58e698cd9cb55e619a1
parent1b94d66d82f6ffdcdce540a6cb45c06785b2d274 (diff)
downloadports-cb427df05f096f0ca4442e0e96b0482610431214.tar.gz
ports-cb427df05f096f0ca4442e0e96b0482610431214.zip
Notes
-rw-r--r--x11/eterm/Makefile35
-rw-r--r--x11/eterm/distinfo2
-rw-r--r--x11/eterm/files/patch-ac26
-rw-r--r--x11/eterm/pkg-descr3
-rw-r--r--x11/eterm/pkg-plist70
5 files changed, 85 insertions, 51 deletions
diff --git a/x11/eterm/Makefile b/x11/eterm/Makefile
index ca8e849d866f..38a75d6de7b5 100644
--- a/x11/eterm/Makefile
+++ b/x11/eterm/Makefile
@@ -1,25 +1,29 @@
# New ports collection makefile for: eterm
-# Version required: 0.8.7
+# Version required: 0.8.8
# Date created: 24 November 1997
# Whom: Murray Stokely <murray@cdrom.com>
#
-# $Id: Makefile,v 1.12 1999/01/14 17:08:22 vanilla Exp $
+# $Id: Makefile,v 1.13 1999/01/17 17:56:12 nectar Exp $
#
-DISTNAME= Eterm-0.8.7
-PKGNAME= eterm-0.8.7
+DISTNAME= Eterm-0.8.8
+PKGNAME= eterm-0.8.8
CATEGORIES= x11
-MASTER_SITES= ftp://ftp.enlightenment.org/pub/Eterm/ \
- http://www.tcserv.com/archive/E/
+MASTER_SITES= ftp://ftp.eterm.org/pub/Eterm/ \
+ http://eterm.is.nontoxic.org/download/ \
+ ftp://ftp.livewire.com.au/pub/linuxberg/files/x11/system/ \
+ ftp://ftp.c-com.net/pub/.30/LinuxBerg/files/x11/system/ \
+ ftp://ftp.sunsite.auc.dk/disk6/linuxberg.com/files/x11/system/
MAINTAINER= murray@cdrom.com
+BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
LIB_DEPENDS= Imlib.2:${PORTSDIR}/graphics/imlib
USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" LOCALBASE=${LOCALBASE}
MAN1= Eterm.1
@@ -34,15 +38,16 @@ post-patch:
post-install:
chown root.wheel ${PREFIX}/bin/Eterm
chmod 4755 ${PREFIX}/bin/Eterm
- ${INSTALL_DATA} ${WRKSRC}/ReleaseNotes ${PREFIX}/share/Eterm
-.ifndef NOPORTDOCS
- ${INSTALL_DATA} ${WRKSRC}/doc/Eterm.help ${PREFIX}/share/Eterm
- ${INSTALL_DATA} ${WRKSRC}/doc/Eterm.ref ${PREFIX}/share/Eterm
- ${INSTALL_DATA} ${WRKSRC}/doc/Eterm.tcap ${PREFIX}/share/Eterm
- ${INSTALL_DATA} ${WRKSRC}/doc/Eterm.ti ${PREFIX}/share/Eterm
- ${INSTALL_DATA} ${WRKSRC}/doc/FAQ.html ${PREFIX}/share/Eterm
${INSTALL_SCRIPT} ${WRKSRC}/doc/colortest.sh ${PREFIX}/share/Eterm
- ${INSTALL_DATA} ${WRKSRC}/doc/menu_cmd ${PREFIX}/share/Eterm
+.ifndef NOPORTDOCS
+ ${MKDIR} ${PREFIX}/share/doc/Eterm
+ ${INSTALL_DATA} ${WRKSRC}/ReleaseNotes ${PREFIX}/share/doc/Eterm
+ ${INSTALL_DATA} ${WRKSRC}/doc/Eterm.help ${PREFIX}/share/doc/Eterm
+ ${INSTALL_DATA} ${WRKSRC}/doc/Eterm.ref ${PREFIX}/share/doc/Eterm
+ ${INSTALL_DATA} ${WRKSRC}/doc/Eterm.tcap ${PREFIX}/share/doc/Eterm
+ ${INSTALL_DATA} ${WRKSRC}/doc/Eterm.ti ${PREFIX}/share/doc/Eterm
+ ${INSTALL_DATA} ${WRKSRC}/doc/FAQ.html ${PREFIX}/share/doc/Eterm
+ ${INSTALL_DATA} ${WRKSRC}/doc/menu_cmd ${PREFIX}/share/doc/Eterm
.endif
.include <bsd.port.mk>
diff --git a/x11/eterm/distinfo b/x11/eterm/distinfo
index 3dcfc6e73dee..f1fcc6ceb611 100644
--- a/x11/eterm/distinfo
+++ b/x11/eterm/distinfo
@@ -1 +1 @@
-MD5 (Eterm-0.8.7.tar.gz) = 00de2b1fb7d35bff42337a9723195114
+MD5 (Eterm-0.8.8.tar.gz) = 19c0571f900757e5a90ac36baac3f79b
diff --git a/x11/eterm/files/patch-ac b/x11/eterm/files/patch-ac
index 1dd8835ed18b..502ce8dc705b 100644
--- a/x11/eterm/files/patch-ac
+++ b/x11/eterm/files/patch-ac
@@ -1,12 +1,14 @@
---- src/Makefile.in.orig Fri Oct 23 01:09:50 1998
-+++ src/Makefile.in Mon Oct 26 18:54:35 1998
-@@ -123,6 +123,9 @@
- system.h threads.h graphics/Makefile.am graphics/Makefile.in \
- graphics/README graphics/data graphics/grxlib.c graphics/grxlib.h \
- graphics/qplot.c
-+ifeq ($(PORTOBJFORMAT),elf)
-+LDFLAGS+=-Wl,-rpath,$(X11BASE)/lib
-+endif
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
- CONFIG_CLEAN_FILES =
+*** src/Makefile.in Wed Jan 13 05:54:45 1999
+--- src/Makefile.in~ Sun Feb 7 23:00:35 1999
+***************
+*** 123,128 ****
+--- 123,131 ----
+ system.h threads.h graphics/Makefile.am graphics/Makefile.in \
+ graphics/README graphics/data graphics/grxlib.c graphics/grxlib.h \
+ graphics/qplot.c Eterm.xpm
++ ifeq ($(PORTOBJFORMAT),elf)
++ LDFLAGS+=-Wl,-rpath,$(X11BASE)/lib
++ endif
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/x11/eterm/pkg-descr b/x11/eterm/pkg-descr
index 199091370df2..00d95dfbc9a8 100644
--- a/x11/eterm/pkg-descr
+++ b/x11/eterm/pkg-descr
@@ -7,6 +7,5 @@ background for terminal windows, and much more!
If you want the KANJI feature enable, use
make -DKANJI install
-http://www.tcserv.com/Eterm
-http://www.rasterman.com
+http://www.eterm.org/
ported by murray@cdrom.com
diff --git a/x11/eterm/pkg-plist b/x11/eterm/pkg-plist
index ed96f05d1018..4ef587ca728f 100644
--- a/x11/eterm/pkg-plist
+++ b/x11/eterm/pkg-plist
@@ -1,32 +1,60 @@
-bin/Esetroot
bin/Eterm
-share/Eterm/themes/Eterm/Eterm.menu
+bin/Esetroot
+lib/libmej.so.8
+lib/libmej.so
+lib/libmej.la
+lib/libmej.a
+lib/libEterm.so.8
+lib/libEterm.so
+lib/libEterm.la
+lib/libEterm.a
+share/doc/Eterm/ReleaseNotes
+share/doc/Eterm/Eterm.help
+share/doc/Eterm/Eterm.ref
+share/doc/Eterm/Eterm.tcap
+share/doc/Eterm/Eterm.ti
+share/doc/Eterm/FAQ.html
+share/doc/Eterm/menu_cmd
+share/Eterm/pix/014.png
+share/Eterm/pix/backwave.jpg
+share/Eterm/pix/button1.jpg
+share/Eterm/pix/button5.jpg
+share/Eterm/pix/circuit.png
+share/Eterm/pix/nebula.jpg
+share/Eterm/pix/fourthday.jpg
+share/Eterm/pix/gaia.jpg
+share/Eterm/pix/galleon.jpg
+share/Eterm/pix/night_of_the_dragon.jpg
+share/Eterm/pix/pixmaps.list
+share/Eterm/colortest.sh
share/Eterm/themes/Eterm/MAIN
-share/Eterm/themes/chooser/MAIN
+share/Eterm/themes/Eterm/Eterm.menu
+share/Eterm/themes/Eterm/pixmaps.list
share/Eterm/themes/chooser/chooser.menu
-share/Eterm/themes/emacs/MAIN
+share/Eterm/themes/chooser/MAIN
+share/Eterm/themes/chooser/pixmaps.list
share/Eterm/themes/emacs/emacs.menu
-share/Eterm/themes/irc/MAIN
+share/Eterm/themes/emacs/MAIN
+share/Eterm/themes/emacs/pixmaps.list
share/Eterm/themes/irc/irc.menu
-share/Eterm/themes/mutt/MAIN
+share/Eterm/themes/irc/MAIN
+share/Eterm/themes/irc/pixmaps.list
share/Eterm/themes/mutt/mutt.menu
+share/Eterm/themes/mutt/MAIN
+share/Eterm/themes/mutt/pixmaps.list
share/Eterm/themes/tn3270/MAIN
-share/Eterm/themes/trans/MAIN
+share/Eterm/themes/tn3270/pixmaps.list
share/Eterm/themes/trans/trans.menu
-share/Eterm/Eterm.help
-share/Eterm/Eterm.ref
-share/Eterm/Eterm.tcap
-share/Eterm/Eterm.ti
-share/Eterm/FAQ.html
-share/Eterm/ReleaseNotes
-share/Eterm/colortest.sh
-share/Eterm/menu_cmd
-@dirrm share/Eterm/themes/trans
-@dirrm share/Eterm/themes/tn3270
-@dirrm share/Eterm/themes/mutt
-@dirrm share/Eterm/themes/irc
-@dirrm share/Eterm/themes/emacs
-@dirrm share/Eterm/themes/chooser
+share/Eterm/themes/trans/MAIN
+share/Eterm/themes/trans/pixmaps.list
+@dirrm share/doc/Eterm
@dirrm share/Eterm/themes/Eterm
+@dirrm share/Eterm/themes/chooser
+@dirrm share/Eterm/themes/emacs
+@dirrm share/Eterm/themes/irc
+@dirrm share/Eterm/themes/mutt
+@dirrm share/Eterm/themes/tn3270
+@dirrm share/Eterm/themes/trans
@dirrm share/Eterm/themes
+@dirrm share/Eterm/pix
@dirrm share/Eterm